Custom device prompt in Ciscoworks LMS

Answered Question
Feb 27th, 2010
User Badges:

Hello,


In emerging network infrastructure of our client we decided to use some custom promps at device VTY (SSH and Telnet). Console users are network authenticated by means of ACS, and in case ACS is not reachable, we decided to use login prompts as follows:

Username(local):

Password(local):


In this local mode, when CiscoWorks LMS (3.1) tries to collect configuration of switches, VLAN configuration exactly, we got such error messages in LMS interface:

TELNET: Failed to establish TELNET  connection to 10.52.0.1 - Cause: Authentication failed on device 3 times. VLAN  Config fetch is not supported using TFTP. Command failed VLAN Config fetch is  not supported using RCP.


Of course, we have checked the possibility to got from LMS host to these devices by SSH and Telnet, credentials are correct, only login prompts are as described earlier.


I conclude, we need to tell LMS to accept our custom prompts. Is there any possibility and how to achieve this?

Correct Answer by yjdabear about 7 years 3 months ago

Looks like in LMS 3.x (RME 4.x), restarting the daemon manager (dmgtd) is no longer needed:

https://supportforums.cisco.com/message/694146#694146

Correct Answer by yjdabear about 7 years 3 months ago

If you're sure the failure is due to the custom prompt, yes, you can simply follow the steps in the following document to let LMS know about that:

http://www.cisco.com/en/US/products/sw/cscowork/ps2073/products_tech_note09186a00801442c9.shtml

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
abedunkevich Tue, 03/16/2010 - 07:47
User Badges:

Thank you very much, it works!


Sorry for a little late reply

Actions

This Discussion

Related Content