published SIP server behind natting

Unanswered Question
Feb 27th, 2010
User Badges:

Hi,


I'm trying to publish a SIP server to the Internet, when SIP clients register in SIP server from the public network they get one way audio scenario, they hear audio originating from inside network but their audio won't reach inside network, we are using a 2811 router equiped with advanced security IOS for Internet connectivity (ADSL2+), the SIP server is natted through the 2811 router to the Internet, I read alot about SIP nat traversal and how that the SIP protocol is not nat friendly, yet I cannot figure out how exactly I can resolve the issue, any help would be appreciated


Thank you

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gogasca Sat, 02/27/2010 - 03:40
User Badges:
  • Green, 3000 points or more

What about using VPN ?

ramy.aboamra Sat, 02/27/2010 - 04:37
User Badges:

my client have that too and it works, however they need the sip server published without vpn as well to use all differnet sip capable devices they have

paolo bevilacqua Sat, 02/27/2010 - 03:39
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You should not have problems with Cisco NAT.

Check and post configuration as necessary.

ramy.aboamra Sat, 02/27/2010 - 04:35
User Badges:

well it won't let audio come from outside sip client if the ios natting configurations for sip server have something special i would appreciate the help

ramy.aboamra Sun, 02/28/2010 - 23:12
User Badges:

the thing got sorted out, no problems found with ios natting!!! it was a firewall on the sip server blocking the whole thing, ios natting works like a charm, thanks everyone for your posts


regards

krishan.saran Sun, 11/28/2010 - 18:33
User Badges:

Hi I am also trying this thing from couple of weeks but in may case some time its works some time doesn't, I have system like that

I have SIP server behind the Cisco router and i am using NAT for UDP port number 5060 to SIP server, and i am using a SIP soft phone in my LAPTOP, if i am try to connect it through VPN its works, but if my LAPTOP is behind the NAT at home i have ADSL and wireless router my phone get registered i can make a call if i call my cell phone from my SIP phone it rings but there is no Audio, it i am connecting my LAPTOP directly to ADSL Modem means no NAT than its works fine, i already disabled firewall on my home router and i already tried NAT to my Laptop IP for port number 5060 but didn't work.So i thing i need to do some thing in my home router, and i have a Simple D-LINK wireless router at home.we want to make it working so than i don't need to do any thing at client side it this case my home, definitely we need to open SIP traffic in firewall, I also tried Wireshark, to capture the port numbers it use the different ports for every call, i understand that there might be a range of ports that i need to use for NAT. Any help we will really appreciated




SIP Server=============Cisco Router==============Internet ==============D-Link Router=========Laptop

10.10.11.206                       10.10.11.1                                                                       192.168.1.1                              192.168.1.100


  IP NAT inside source static udp 10.10.11.206 5060 int fas 0/4 5060


there is no firewall on cisco router

ramy.aboamra Sun, 11/28/2010 - 23:49
User Badges:

SIP is not NAT friendly, and it opens dynamic ports to establish voice delivery (refer to the SIP server documentation for port range details), what you need is a SIP proxy or media gateway check this example http://www.ingate.com/siparators.php

Actions

This Discussion