STP Problem on Linksys SRW248G4P.

Unanswered Question
Feb 27th, 2010
User Badges:

Hi


Is there a way to change a switchport status from "Discarding" to "Forwarding" on SRW248G4P?


By the way, why all of a sudden a working switchport status is changed to "Discarding"?


This port is connected to an Avaya IP-Phone and a PC (via IP-Phone).


What possibilities can cause a switchport status to "Discarding"?


I disabled STP on this port but still the same result. It shows the status as Discarding and no communication is happening through this port.


Do I need to restart the switch after disabling STP on a port?



Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
alissitz Tue, 03/02/2010 - 07:34
User Badges:
  • Silver, 250 points or more

Sounds like STP found or thinks there is a loop.  Look at the interface properties, and many of the models include a place to re-enable a port.


Is the PC running STP?


HTH,


Andrew Lissitz

alissitz Tue, 03/02/2010 - 07:39
User Badges:
  • Silver, 250 points or more

Just read your other post.  Perhaps we keep this one?


Have you set the ports to portfast or are you using bpduguard?  Perhaps they have been set to one of these configs and then when the phones send STP, the switch thinks you have a misconfig or a loop.


The switch in this case would be keeping a loop or misconfig from occurring, and thus does the right thing by shutting the port.  As an admin and through the web gui, there is normally an option to re-enable the ports.  


HTH,


Andrew Lissitz

Actions

This Discussion

Related Content