Output drops on 3560

Unanswered Question
Feb 28th, 2010

Hi,

We have a 3560 connected via trunk to a 2950 (Both 10/100 ports), and we are seeing large amounts of output drops on the 3560 port - Ports were set to 100/FULL, now auto/auto(Negotiating to 100/FULL).

3560:

interface FastEthernet0/1
description Trunk-to-ESW01
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,11,12,35,103,104,106-108,112,113,115,120-123
switchport trunk allowed vlan add 156,158,206,472,473,475,478-488,590,591,957
switchport trunk allowed vlan add 970,1002-1005
switchport mode trunk
switchport nonegotiate
mls qos trust dscp
storm-control broadcast level 20.00
storm-control action trap
no cdp enable
spanning-tree bpdufilter enable
spanning-tree guard root

2950:

interface FastEthernet0/20
description trunk to esw02
switchport trunk allowed vlan 1,11,12,35,68,103,104,106-108,112,113,115
switchport trunk allowed vlan add 120-123,156,158,206,472,473,475,478-488,590
switchport trunk allowed vlan add 591,957,970
switchport mode trunk
mls qos trust dscp
storm-control broadcast level 20.00
storm-control action trap
no cdp enable
spanning-tree bpdufilter enable
spanning-tree guard root

And the drops:

3560:

FastEthernet0/1 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is f4ac.c17d.af83 (bia f4ac.c17d.af83)
  Description: Trunk-to-ESW01
  MTU 1998 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 138/255, rxload 53/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters 2d09h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 150147
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 20925000 bits/sec, 4704 packets/sec
  5 minute output rate 54280000 bits/sec, 7758 packets/sec
     497109451 packets input, 293548981757 bytes, 0 no buffer
     Received 1086289 broadcasts (242554 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 242554 multicast, 0 pause input
     0 input packets with dribble condition detected
     593084216 packets output, 451392427662 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

2950:

FastEthernet0/20 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0017.5af5.6694 (bia 0017.5af5.6694)
  Description: trunk to esw02
  MTU 1530 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 53/255, rxload 139/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 100BaseTX
  input flow-control is unsupported output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 6d14h, output 00:00:07, output hang never
  Last clearing of "show interface" counters 6d05h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 54592000 bits/sec, 7789 packets/sec
  5 minute output rate 20978000 bits/sec, 7139 packets/sec
     2485643391 packets input, 596308546 bytes, 0 no buffer
     Received 491697 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 244841 multicast, 0 pause input
     0 input packets with dribble condition detected
     2517124831 packets output, 2011506627 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Next thing we would try is to replace the eth cable(It is in remote location, so is difficult) - Other than cable, what else can we test to try and identify the cause of the drops?

Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Leo Laohoo Sun, 02/28/2010 - 20:45

johnelliot6 wrote:

3560:

FastEthernet0/1 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is f4ac.c17d.af83 (bia f4ac.c17d.af83)
  Description: Trunk-to-ESW01
  MTU 1998 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 138/255, rxload 53/255

2950:

FastEthernet0/20 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0017.5af5.6694 (bia 0017.5af5.6694)
  Description: trunk to esw02
  MTU 1530 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 53/255, rxload 139/255

MTU mis-match?

johnelliot6 Sun, 02/28/2010 - 20:54

Ah - Well done!

So miss-match in mtu would cause output drops?

As the 2950 only supports 1530byte mtu, is our only option to drop the 3560's mtu to match this?

johnelliot6 Mon, 03/01/2010 - 20:25

As per-interface mtu setting is not supported, is there anyway workaround(mtu discovery?) - As preference would not to have to drop system mtu to match 2950+reboot switch.

Thanks.

Actions

This Discussion