I need a help on cisco 1841 for support on port channel and switchport with 12.4(24)T

Unanswered Question
Mar 1st, 2010

Hi Tech,

I need an urgent help on this to check whether it is possible for switchport access and port channel on Cisco 1841 with 4 port switch moduel running IOS 12.4(24)T.

Your guys feedack is appreciate it ,we are doing a portchannel between fa0/1(onboard) and fa0/1/0 as a redudancy.Please let me know what IOS version is supported for this requirement.

Thanks Sanjeev

[email protected]

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
slopes Mon, 03/01/2010 - 08:00

Hi Varun,

Did you guys tried out before,on the integrated port fa0/1 we can specify as switchport access vlanx.

our aim to configured one integrated fa0/1 and other 4 port switch mod port fa0/1/0 as channel-group1

we tried using 12.4(24)T or 12.4(25)a also i doesnt allow to turn L3 port to be L2

Please let me know how you did it and if it works bcos we are having prob and our project is starting tom.



glen.grant Mon, 03/01/2010 - 08:46

  Don't believe you can use an integrated port as one of your ports . Both would have to be on the hwic.  Think of the hwic as a separate standalone switch.

Giuseppe Larosa Mon, 03/01/2010 - 11:20

Hello Sanjeev,

as Glen has noted you cannot mix "router" ports with switch ports in the HWIC.

This will never be possible they are designed for different use.

Hope to help


alshamlan Thu, 05/19/2011 - 03:20


I have router 1841 and I want to do etherchannel on two ports, The command for port channel is not acceptable in the router. Is the IOS needs to be upgraded, I have IOS


Is it supported?



cadet alain Thu, 05/19/2011 - 03:36


Is it supported?

No the only ports supporting etherchannel on routers are switching ports.



alshamlan Thu, 05/19/2011 - 07:07


If it supported on the switching port then Why the port-channel command in the globale configuration is not accepted?

policy-manager  policy-map

port-channel is not their.

Is it beacuse of the IOS?or this 1841 router is not supporting the port-channel at all?



cadet alain Thu, 05/19/2011 - 07:58

port-channel is not their.

Normal this is not a valid command.

You must go to interface config and issue channel-group command and this will create a port-channel interface and the command sh int port-channel x will show you its properties but again this must be done on a L2 interface not a native routed port.




This Discussion