Clients are switching between 2.4Ghz and 5GHz Radios

Unanswered Question
Mar 1st, 2010

Hi, I have configured a WLan with that is providing coverage for all the radios including a/b/g/n on a 4402 controller in WiSM Module.  The clients are also unable to run on all the radios.  Everything is working fine, but we are seeing clients that have been connected to either a 2.4ghz radio or 5ghz radio, tend to switch between them when running for a while.  I am trying to understand this scenario, since there is no setting on the controller that I can find would allow the preference of the radio.

Also attaching a WCS report that would explain the behavior.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Kayle Miller Mon, 03/01/2010 - 12:22

Just to confirm you have the Specified WLAN (SSID) configured to utilize all radios (802.11a, 802.11b, 802.11g, 802.11n) correct? What is the configuration of the data rates in your system for both radios. Also what code version are you using?

No aside from the questions the roaming decision which affects not only channel but band is generally (100%) of the time by the client device, the only exception to that rule is if you are running a 6.0.188.0 or newer code release that has Band Select or Load-Balancing Enabled. In terms of the clients there are several factors it uses to determine when, where, what to roam too; they are Signal Strength (RSSI), Noise, and Signal Strength cut-off. These values can vary from manufacturer to manufacturer and in some cases can even vary from model to model of wireless card. The other factor that can play into this is your selected data rates.

First and foremost lets discuss the overall all coverage area, 802.11a & 802.11g have a smaller coverage area than an 802.11b network due to the maximum power that is permitted to be transmitted so you need to keep that in mind. If a client was to connect to the network using 802.11a and was moving they are more likely to get a signal they can roam to on the 802.11b network before an 802.11a network unless your deployment is dense enough to provide edge to edge coverage on 802.11a. This is where the Signal Strength and data rates come into play when the client makes a decision to roam, because all clients have a value defined (not user configurable) that determines how low the signal can go before the client starts looking for a new access point to roam to; when this happens it looks at the RSSI from other AP's on all the bands it is configured for and looks to find one that has a signal that is generally 3db or more higher than the current signal. While this is true it also needs to have the minimum required data rate in order to associate, so sometimes it may prefer 802.11b over 802.11a.

There are 2 ways to possibly set a preference as you say, option 1) only allow one band or the other on the controller, 2) see if the software or drivers for your client allow you to set a preference.

Hope this helps..

fmirza007 Mon, 03/01/2010 - 12:31

Thanks Kayle, you brought up some good points, I unfortunately failed to give all of the information in my first post.  to start out, we are currently running the latest 6.0 code on the WLCs.  Secondly the data rates are set to 24Mbps or higher for both radios, that means 802.11b is not allowed.  Also I forgot to write about the testing scenario, the client machine was sitting at one position for 24hrs that means the user was not moving around hence the roaming should not be involved I think.  Lastly we did the survey for 802.11a coverage and I don't think there is any issue with the coverage, since it connects to 802.11a at excellent.  The question really is that once the client connects to 802.11a on excellent and is running on that radio for an hour perfectly and the user is not moving at all why is it that it switches it self to 802.11g and then again to 802.11a??  Do you think it might be interference?  but I have not seen any spikes from WCS about the interference thresholds?

Thanks

Kayle Miller Wed, 03/03/2010 - 13:36

This is an interesting issue, because I can see the client leaving the 802.11b/g  (2.4Ghz) band due to intereference, but no the 802.11a band (5Ghz) there is so little in that spectrum in terms of interference except Radar. This leads me to think it's a driver issue on the client itself and that it is detecting some sort of issue with the signal or interference and deciding to roam on it's own..  What kind of wireless card is in the device?

fmirza007 Wed, 03/03/2010 - 13:53

They are using Intel card a/b/g/n I think its the 5100 ABGN

model...with the latest drivers...we had an issue with the old drivers where the client would get hung up when it roamed, but that issue was corrected with the upgrade to latest drivers from Intel.  when you mentioned band select what did you mean by it?

mthurman Wed, 03/03/2010 - 14:08

You can enable band select it will then prefer a connection to the "a" radio rather than the "g" radio. On your WLC under Wireless/Advanced/Band Select.

Kayle Miller Wed, 03/03/2010 - 14:08

Band Select is a new feature in the 6.0.188.0 code release that basically allows the system to determine what bands (2.4/5.0) your client supports, then it determines which band is least congested and can provide the greatest service and then only responds to your clients probe with that band available.

so to make this easier to understand, picture 2 cars 1 red, 1 blue.  typically you'd walk up and pick which color car you want, but band-select say the salesman decides, if he feels you'd look better in the blue car that' is the only one he makes available to you, even though the red one is there and your ok with the red one, he says blue so you get blue.

Does that make sense? Band-select can be confusing.

Scott Fella Thu, 03/04/2010 - 16:31

Like what the others mentioned, Band-Select might help but doesn't prevent users from switching to a different band... it makes it more attractive:) but clients still makes the decision.  Maybe the reason is that there were more users on one band than the other and the client device choose the other band from the information it received in the beacons.  There are also requirements to use Band-Select like it only works with the 1140 & 1250 ap's, etc.   I don't have access to a WCS currently, but when looking at the report... I might be wrong, but do you have channel bonding enabled on the 2.4GHz or is that how WCS reports the protocol used?  I usually assign a WLAN to only a certain band and not both, but that's me and that is not the case all the time.  Is this causing a problem when they switch?

fmirza007 Fri, 03/05/2010 - 08:02

So I went under Aadvance in wireless and the

option is there to enable the band select, but there is no option to select the preference.  Is the preference still left on the client?  I am not familiar with the channel bonding option? what is it and how it could be beneficial to this installation.

Thanks

Scott Fella Fri, 03/05/2010 - 08:44

Kayle is right... here is a link regarding band selection if you have not seen it.

http://www.cisco.hm/en/US/docs/wireless/controller/6.0/configuration/guide/c60ccfg.html#wp1902089

Regarding channel bonding, You would have to confgiure it for 40mhz channel width, doesn't seem like you did so it must be a default in WCS.  Clients will also decide what band or AP they want to associate to no matter what.  Band select makes a certain band favoritable in the beacons, but doesn't mean the client will choose that band.

Kayle Miller Fri, 03/05/2010 - 08:10

When using Band Select you don't configure a preference for the band, the system does that based on Load, Interference, and client capabilities.

The Channel bonding is for 802.11n it enables you to get the data rates above 54mbps, it does this by bonding (joining) two channels together. This is ok to do in the 802.11a spectrum but not in the 802.11b spectrum since enabling that limits you to 2 non-overlapping channels. Generally you don't want to limit yourself in this manner, also unless your going to do a 2.4Ghz 802.11n only network you need to enable mixed mode to still allow B/G clients on.  Which means some traffic is sent on the standard channel, them some across the bonded channel.

Not sure if this helps or not.

tdennehy Sun, 06/12/2011 - 05:01

You have probably figured this out already, but I'll take a stab at it anyway.  We had the same issue - but it was *only* with our Macintosh clients.  Turns out we upgraded from 5.2.x code to 6.x last summer, and all of a sudden the Macintoshes started jumping around between bands.  I use asterisks because every now and then a Wintel would have the same issue.

We broadcast the same SSIDs on both 2.4 GHz and 5 GHz, so you would think this would not be a problem.  We turned on Fast SSID change, thinking this would fix the issue.  At first we thought it had, but later testing proved otherwise.

Brought in our Apple rep... he did some debugging and we discovered "Option 17 - AP is full" messages on those clients.  Did some more digging and found that Load Balancing had been turned on.  It wasn't turned on before the upgrade, and it was now turned on.  Not sure if this was a default when upgrading, but when we turned it back off, issue went away.

I'm not saying this will fix your problem, but if it still exists, it is worth looking into.

Actions

This Discussion