cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3248
Views
0
Helpful
1
Replies

Internet connection lost, when ISP changes IP address.

--Petzu--
Level 1
Level 1

Hi all

My ISP is providing WAN IP address to my router by using DHCP.
It's not possible to have static IP address here.

It's changing very often, some times only IP address will change and sometimes
whole network will change.

Some times router will handle it whit out problems, but very often I will lost connection to internet.
After this connection lost, it looks to be ok, BVI1 will have new IP address, and line seems to be up.
but I can't use internet before I have proceed reload of IOS.

Router is 2801 and HWIC-ADSL1 card.

Line (wire) from house to ISP is measured, and signal seems to be good.

My ISP told me, they can see from they log files, that there had been at leas 20 different
MAC address, requesting new IP address by DHCP? Is this normal? I've attached below
terminal window output when reloading router, it's mentioned there too.

I did proceed #write erase, #reload, and created very basic configuration, could you please
have a look at it, what might cause this problem? what I'm missing? I hope to have this part correct,
before I start modifying it.

Here is running config:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 10.10.1.1 10.10.1.199
!
ip dhcp pool LAN
   network 10.10.1.0 255.255.255.0
   default-router 10.10.1.1
   dns-server  xxx.xxx.xxx.xxx
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
voice-card 0
!
!
archive
log config
  hidekeys
!
!
bridge irb
!
!
interface FastEthernet0/0
ip address 10.10.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface ATM0/3/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/3/0.1 point-to-point
bridge-group 1
pvc 0/100
  encapsulation aal5snap
!
!
interface BVI1
ip address dhcp
ip nat outside
ip virtual-reassembly
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface BVI1 overload
!
access-list 1 permit 10.10.1.0 0.0.0.255
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end


This is taken from terminal output, when reloading router:

*Mar  1 22:23:50.963: %LINEPROTO-5-UPDOWN: Line protocol on Interface VoIP-Null0, changed state to up
*Mar  1 22:23:50.963: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/3/0, changed state to down
*Mar  1 22:23:52.623: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
*Mar  1 22:23:52.923: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Mar  1 22:23:54.283: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
*Mar  1 22:24:06.439:
Note: A random mac address of 0000.0c77.a5f8
      has been chosen for BVI in bridge group  1 since there is no mac address
      associated with the selected interface.
*Mar  1 22:24:06.439:
      Ensure that this address is unique.

*Mar  1 22:24:06.675:
Note: A random Spanning Tree Bridge Identifier address of 0000.0ab8.a6f4
      has been chosen for Bridge Group 1 since there is no mac address
      associated with the selected interface.
*Mar  1 22:24:06.675:
      Ensure that this address is unique.

*Mar  1 22:24:06.787: %SYS-5-CONFIG_I: Configured from memory by console
*Mar  1 22:24:07.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, changed state to up
*Mar  1 22:24:07.619: %SYS-5-RESTART: System restarted --
Cisco IOS Software, 2801 Software (C2801-SPSERVICESK9-M), Version 12.4(24)T1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 19-Jun-09 16:36 by prod_rel_team
*Mar  1 22:24:07.627: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing a cold start
*Mar  1 22:24:07.839: %SYS-6-BOOTTIME: Time taken to reboot after reload =  159 seconds
*Mar  1 22:24:08.291: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Mar  1 22:24:18.395: %LINK-3-UPDOWN: Interface BVI1, changed state to down
*Mar  1 22:24:19.395: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, changed state to down
*Mar  1 22:24:43.243: %LINK-3-UPDOWN: Interface ATM0/3/0, changed state to up
*Mar  1 22:24:44.243: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/3/0, changed state to up
*Mar  1 22:24:45.243: %LINK-3-UPDOWN: Interface BVI1, changed state to up
*Mar  1 22:24:46.243: %LINEPROTO-5-UPDOWN: Line protocol on Interface BVI1, changed state to up
*Mar  1 22:25:20.939: %DHCP-6-ADDRESS_ASSIGN: Interface BVI1 assigned DHCP address xxx.xxx.xxx.xxx, mask 255.255.240.0, hostname Router

*Mar  1 22:26:13.419: %DHCPD-4-PING_CONFLICT: DHCP address conflict:  server pinged 10.10.1.200.   <-------- This was my desktop IP address, on that time.

Please let me know if you need more information.

Regards
--Petzu--

1 Reply 1

Edison Ortiz
Hall of Fame
Hall of Fame

Instead of using ip address dhcp on the BVI interface, use ip address dhcp client-id as described on this document.

http://www.cisco.com/en/US/docs/ios/ipaddr/command/reference/iad_dhc1.html#wp1012800

With this method, the ISP will see one MAC address from you - the one listed on the client-id parameter.

BVI is a logical interface that will create random MAC addresses.

You can use any of the physical interfaces from this router as the source of the MAC address.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco