GRE tunnel max bandwidth

Answered Question
Mar 1st, 2010

Hi

we have point to point metro ethernet link terminating on 7204VXR router.On this point to point link we are configuring GRE over ipsec. Problem is when the traffic exceeding 8mbps we started getting packet drops.

from the cisco documentation it seems the tunnle bandwidth is by default 8mbps and there is parameter like Inherit/receive but those actullay not change the tunnel interface bandwidth.If we just give tunnle bandwidth with bandwidth mentioned it allows me to give option of 100mbps but again the tunnle interface bandwidth remians 8mbpos only and probabaly that 100mbps is useful only for routing decisions.

i am using advance security 12.4.15T12 image.

can anyone please confirm weather this is a limitation or any other way to go beyond 8mbps for the tunnle interface (7204VXR-NPEG1 processor)

Regards

Sameer

I have this problem too.
0 votes
Correct Answer by Leo Laohoo about 6 years 9 months ago

By default Tunnel bandwidth is set to 8mb.  I don't remember the exact command but it should be in the vicinity of "tunnel bandwidth transmit " and "tunnel bandwidth receive ".

Correct Answer by Leo Laohoo about 6 years 9 months ago

You can go beyond 8mbps.  It all depends on the IOS Feature Set.  If I'm not mistaken Advanced IP Services feature set will enable the "tunnel bandwidth" command.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Leo Laohoo Mon, 03/01/2010 - 18:04

You can go beyond 8mbps.  It all depends on the IOS Feature Set.  If I'm not mistaken Advanced IP Services feature set will enable the "tunnel bandwidth" command.

sameermunj Mon, 03/01/2010 - 18:13

Hi

Thanks for the reply..

in advance security also i am getting the bandwidth command and i can go upto 100mbps but when i do show interface  tunnel 0 it shows me bandwidth of 8mbps only.

please have look at attached doc regarding bandwidth command and let me know your opinion.

Correct Answer
Leo Laohoo Mon, 03/01/2010 - 18:33

By default Tunnel bandwidth is set to 8mb.  I don't remember the exact command but it should be in the vicinity of "tunnel bandwidth transmit " and "tunnel bandwidth receive ".

sameermunj Mon, 03/01/2010 - 18:39

Hi

That command was available in 12.3 but in 12.4 they removed this comamnd and it seems only option is bandwidth and the details of the same was attahced in last post,

if anyone can confirm weather the same is possibel anf exact softwrae version required i can check let u know the result.

sameermunj Mon, 03/01/2010 - 18:55

i am already using Advance security.can ypou please confirm which suit u want me to go.

Advance ip services/adnace enterprise servcies.

*in command lookup tool for 12.4T (without any sub category) tunnel bandwidth trans/receive not available.

sameermunj Mon, 03/01/2010 - 21:00

Hi

tried changing the software to advance ip services with same version (12.4.15t12) and i am getting the command to define transmit and receive bandwidth over tunnel interface.

i think this will work with my requirement.let me check in live enviornment and confirm back.

Giuseppe Larosa Tue, 03/02/2010 - 11:30

Hello Sameer,

I've checked on a C7200 VXR with NPE-G2 and

sh ver | inc image
System image file is "disk2:c7200p-advsecurityk9-mz.124-20.T.bin"

router(config)#int tunnel 20
router(config-if)#band
router(config-if)#bandwidth ?
  <1-10000000>  Bandwidth in kilobits
  inherit       Specify that bandwidth is inherited
  receive       Specify receive-side bandwidth

bandwidth 1000

bandwidth receive 200

we see

sh int tu20
Tunnel20 is up, line protocol is down
  Hardware is Tunnel
  MTU 9108 bytes, BW 1000 Kbit/sec, RxBW 200 Kbit/sec, DLY 50000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source UNKNOWN
  Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets disabled
  Tunnel TTL 255
  Fast tunneling enabled
  Tunnel transport MTU 1476 bytes
  Tunnel transmit bandwidth 8000 (kbps)
  Tunnel receive bandwidth 8000 (kbps)

with

bandwidth 20000

sh int tu20
Tunnel20 is up, line protocol is down
  Hardware is Tunnel
  MTU 9108 bytes, BW 20000 Kbit/sec, RxBW 200 Kbit/sec, DLY 50000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source UNKNOWN
  Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets disabled
  Tunnel TTL 255
  Fast tunneling enabled
  Tunnel transport MTU 1476 bytes
  Tunnel transmit bandwidth 8000 (kbps)
  Tunnel receive bandwidth 8000 (kbps)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)

a GRE tunnel is a logical interface and so it has some parameters associated to it, I cannot test with traffic but I don't think a single tunnel is limited to those 8 Mbps specified by the lines Tunnel transmit bandwidth and Tunnel receive bandwidth 8000.

I have experience of traffic over MPLS TE tunnels where the configured bandwidth can be easily overcomed.

Also the command modifies the rx BW in bold not the two lines

http://www.cisco.com/en/US/docs/ios/interface/command/reference/ir_a1.html#wp1013415

so or there are other commands to modify those settings or they are administrative (no real limit on traffic on the tunnel)

under tunnel I cannot find a bandwidth option

tunnel ?
  checksum            enable end to end checksumming of packets
  destination         destination of tunnel
  flow                flow options
  key                 security or selector key
  mode                tunnel encapsulation method
  path-mtu-discovery  Enable Path MTU Discovery on tunnel
  protection          Enable tunnel protection
  route-via           Select subset of routes for tunnel transport
  sequence-datagrams  drop datagrams arriving out of order
  source              source of tunnel packets
  tos                 set type of service byte
  ttl                 set time to live
  udlr                associate tunnel with unidirectional interface
  vrf                 set tunnel vrf membership

Hope to help

Giuseppe

Leo Laohoo Tue, 03/02/2010 - 12:44

Hi Giuseppe,

I believe you need Advanced IP Services feature set to enable "tunnel bandwidth transmit" or "tunnel bandwidth receive" function.

sameermunj Tue, 03/02/2010 - 18:21

Hi  Giuseppe / leolaohoo

with plain bangdwidth command its not changing the actual bandwidth of the interface.probabaly that command is just to communicate with higher level protocols which might help in taking routing decisions.

the actual command is tunnle bandwidth transmit/receive which i found in adavance ip services(c7200-advipservicesk9-mz.124-15.T12.bin ==256mb dram 64mb flash) . i am using NPEG1 so when i installed this software i was able to see and configure that command  and the tunnel interface was showing proper bandwdith but during boot i was getting the low memory error so finally i shifted to c7200-jk9s-mz.124-25a (Enterprise security==256mb dram/48mb flash) where the same command is available and bootin without any error message.

the command output i have attached for the reference.

thanks

sameer

Giuseppe Larosa Wed, 03/03/2010 - 02:08

Hello Leo,

I see that my device has advanced security instead!

Sorry for having caused confusion in this thread

But according to your experience, are these tunnel bandwidth TX and RX real limitations or not?

Hope to help

Giuseppe

milan.kulik Fri, 06/10/2011 - 07:21

Hi,

I just ran a test in my lab with following results:

c2811#sh int tunnel 100

Tunnel100 is up, line protocol is up

Hardware is Tunnel

Internet address is 192.168.100.1/24

MTU 17912 bytes, BW 100 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 255/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive set (5 sec), retries 3

Tunnel source 192.168.255.1, destination 192.168.255.3

Tunnel protocol/transport GRE/IP

Key 0x64, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255, Fast tunneling enabled

Tunnel transport MTU 1472 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input 01:15:12, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 51

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 20258000 bits/sec, 1760 packets/sec

962 packets input, 54292 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

4364334 packets output, 2042654264 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

On the other tunnel side:

c1841#sh int tunn 100

Tunnel100 is up, line protocol is up

Hardware is Tunnel

Internet address is 192.168.100.2/24

MTU 17912 bytes, BW 8000 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 1/255, rxload 255/255

Encapsulation TUNNEL, loopback not set

Keepalive set (5 sec), retries 3

Tunnel source 192.168.255.3, destination 192.168.255.1

Tunnel protocol/transport GRE/IP

Key 0x64, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255, Fast tunneling enabled

Tunnel transport MTU 1472 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input 00:52:58, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 23

Queueing strategy: fifo

Output queue: 0/0 (size/max)

30 second input rate 21082000 bits/sec, 1809 packets/sec

30 second output rate 0 bits/sec, 0 packets/sec

3972616 packets input, 1472446504 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

964 packets output, 53476 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

So the default settings seem not to be restricting the throughput in fact!

BR,

Milan

sameermunj Mon, 03/01/2010 - 18:31

Hi

I am awaiting your reply.i think that bandwidth parameter is only for taking routing decision.even  when i change the tunnle bandwidth 100mbps in my show interface tunnel 0 i can see bandwidth of 8mbps which is default.

Attachment: 
sameermunj Mon, 03/01/2010 - 18:21

can you please confirm my question .

hope u got the attached pdf which mention usage of bandwidth command

ajaju Thu, 06/09/2011 - 19:11

Hi Sameer,

I also noticed that if the router is running a universal image (as is the case if it has the 15.X code), then we need to enable the datak9 license inorder to get that command at interface level.

Regards,

Aniruddha

Actions

This Discussion