Is it possible to set an extension for the Voicemail system?

Unanswered Question
Mar 1st, 2010
User Badges:

I'd like to be able to dial an extension, and have this connect to the voicemail system.  The first thing I'd do would be to dial the extension, and then I'd enter the password for that extension.  I see that the auto-attendant can be set to go to voice, but is it possible to set an extension?  Then I could check other mailboxes from my desk, and also call in and have the front desk connect me to the voice mail extension.  I tried calling extension 800, but the crashes an SPA504 phone, ie needs a power cycle.  (This is for an SPA9000 and SPA400)  Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nseto Thu, 03/04/2010 - 17:29
User Badges:
  • Silver, 250 points or more

You can check other voicemail from an outside phone after reaching the AA.  To do this, put something like this into the AA dial plan, <7:vmm3> which means enter 7 to reach the voicemail on the spa400 which is located on line 3 (spa9000 connected to spa400).  After entering that number 7, you would enter the extension and pin when prompted.

Dialing from an internal extension to the AA in this manner may or may not work, some of the interaction with the AA requires you to dial from outside to the AA and not from an internal extension.

William Paulsen Fri, 03/05/2010 - 12:11
User Badges:

Thanks, but does someone know how to call directly or be transferred to the Auto-Attendant?

nseto Fri, 03/05/2010 - 13:56
User Badges:
  • Silver, 250 points or more

aa is normally in the contact list for line 1-4, dial the number associated with line 1 if that's what is connected and you should be connected to aa.

William Paulsen Mon, 03/08/2010 - 06:04
User Badges:

This seems like yet another bug in the SPA9000/SPA400:  On an extension that is not configured for voice mail, if I call into the aa, and then connect to vmm, I get a fast busy.  I expected that I would simply be connected to the voice mail manager, where you get prompted first for a mailbox number, and then enter the password.

nseto Mon, 03/08/2010 - 08:59
User Badges:
  • Silver, 250 points or more

Are calling the line 1 number or  calling aa directly?  It should work correctly when you dial the line 1 number and it's contact list is aa.

William Paulsen Mon, 03/08/2010 - 09:44
User Badges:

Maybe someone here can suggest something?  Otherwise this SPA9000/SPA400 combination is not too useful.  I realize it's a low end system, but I'd expect a these simple features would be working as described in the user manuals.  Here's what I'm trying to do:


I'm at a SPA504g where Line 1 (extension 101) is not on this set is not configured for voice mail.  That is, extension 101 does not have a voice mailbox associated with it.


I call the aa.


In the aa, I enter the key to take me to voicemail.


The voicemail gives a fast busy.  This is not good.


----


If I call on another SPA504g where Line 1 (eg, x102) does have a voice mailbox set up, then when I do the above steps I get to the voice mail for ext. 102.  This is also not good.


---


The behavior that I really want is this:


I call the aa from any phone, including from an external line.


When I enter a particular key for the aa (eg, 8), I want to get into the voice mail manager, where I will get the prompt: "Please enter your mailbox number" and then "Please enter your password"


---


I've spent many many hours and several customer service calls on this.  Cisco customer service simply says, "Oh well, too bad".  I think it's a bug in the SPA9000/SPA400.

nseto Mon, 03/08/2010 - 13:09
User Badges:
  • Silver, 250 points or more

It sounds like you are dialing aa internally from internal phone to aa directly.

From an external phone to the aa via the contact list in line 1, have you verified that this works?  It should.  After this is verified, you should be able to dial from the internal phone to the external number of line 1 to get to aa, then you should be prompted for the number and password to retrieve vm.  If this doesn't work, attach the html file of the spa9000 so we can verify the config.  Using IE, do a save as html.  Be sure to go to the voice side and log in as admin/advanced.  This will save all the various tabs in one html file.

William Paulsen Mon, 03/08/2010 - 13:56
User Badges:

Thanks.  Right now I'm waiting on a replacement SPA400, since it has stopped serving webpages even after hard resets.  I upload info in a few days.

William Paulsen Mon, 03/22/2010 - 19:58
User Badges:

Here's the SPA9000 html.  If you go to Voice/SIP/Auto Attendant Parameters you will see AA Dial Plan 1. 


From an internal station that has called the aa, if you press key 8, you are supposed to go to vmm1, the voice mail manager, but instead you get a fast busy.


But if in the AA Dial Plan 1, I replace <8:vmm1> with <8:[email protected]:5090>  then this works correctly - I get to the vmm.


Do I have something mis-configured?


Note that I also have a new SPA400, but when I updated the firmware with 1.1.2.2, th SPA400 became unstable - after a few minutes of simple setups (like setting static ip), the SPA400 would not serve any webpages.  After many hard reset attempts, I got it to come alive, and I immediately loaded the firmware version 1.0.1.4, and this has been stable.


Thanks, Bill.

nseto Tue, 03/23/2010 - 11:45
User Badges:
  • Silver, 250 points or more

I see that you found a way for an internal station to work....  the procedure I gave allows you access from external.  I know the one I gave didn't allow for internal calls to aa to get to vmm but you found a way to do that.  I haven't heard of a later version of spa400 being worse than previous version....

Actions

This Discussion