Help with 3800 Series to have pppoe

Answered Question
Mar 2nd, 2010

Hello all, i would like to ask whatsthe confiuration for cisco 3845  router, my set up is DSL Modem> Cisco3845>PC, my internet is  Static but it need to dial a username and password, but i cant seem to  make it work, been doin it for almost 2 weeks now but i still dont get  internet access hope to hear from you soon, im new at configurin this  routers and i dont know if im doing the right codes for it, sorry to  bother you all, have a reat day

I have this problem too.
0 votes
Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

You need to change the config register in to 0x2102.the configuration register shows 0x2142. The             router bypasses the startup configuration stored in NVRAM during its boot             sequence. This feature is normally used during a password recovery             procedure.

router(config)#config-register 0x2102

then write the confiig. reload you router.

Regards

Karuppu

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

Can you paste the sh version of your router.susecting the config-register value.

regards

karuppu

Correct Answer by Reza Sharifi about 6 years 9 months ago

When you are at the router save the config by issuing this command

"wr" after that your config is saved and when your reboot the router you don't loose your config any more

HTH

Reza

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

Now, configuration wise everything is ok.Better check with your ISP.

GigabitEthernet0/1         unassigned      YES unset  down                  down

I hope the cable is coming from your modem to router might be not working.befor contact with ISP check that
cable because the interface is down now.

If both your router and modem's are powered on then it should be up

Regards

Karuppu

Just have a look of my BOLD LETTERS once again

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

Have you tried to configure the below lines in your router.

vpdn enable
no vpdn logging
vpdn-group pppoe
  request-dialin
   protocol pppoe

Can you paste the output of the below command

#sh ip int br

Even if you are not able to access internet, contact your ISP.

regards

karuppu

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

Can you paste the router current running configuration.

DHCP is not necessary to configure,that is used to assign the IP dynamically to your desktops.

regards

karuppu

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

I have prepared the configuration for your router.

Just do copy paste. for more infor refer that url which i gave in the same post

vpdn enable
no vpdn logging
vpdn-group pppoe
  request-dialin
   protocol pppoe

interface GigabitEthernet0/0
ip address 192.168.10.3 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
media-type rj45

int gi0/1
no sh
pppoe-client dial-pool-number 1

interface dialer1
ip address negotiated
mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password
ppp pap sent-username password


ip nat inside source list 1 interface dialer1 overload

ip route 0.0.0.0 0.0.0.0 interface dialer 1

access-list 1 permit 192.168.10.0  0.0.0.255

Regards

Karuppu

I have changed the interface config (bold).Hope it will clear your doubt

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

I have prepared the configuration for your router.

Just do copy paste. for more infor refer that url which i gave in the same post

vpdn enable
no vpdn logging
vpdn-group pppoe
  request-dialin
   protocol pppoe

interface GigabitEthernet0/0
ip address 192.168.10.3 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
media-type rj45

int gi0/1
no sh
pppoe-client dial-pool-number 1

interface dialer1
ip address negotiated
mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password
ppp pap sent-username password


ip nat inside source list 1 interface dialer1 overload

ip route 0.0.0.0 0.0.0.0 interface dialer 1

access-list 1 permit 192.168.10.0  0.0.0.255

Regards

Karuppu

I have changed the interface config (bold).Hope it will clear your doubt

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

As per your configuration you have one E1 controller card and 2 Giga interfaces in your router.

Can you tell me about your internet connection. ??  -- If yes then connect your internet link into one of the gigabitethernet port and configure that interface as ppoe interface.

Is the internetconnection via  ethernet connection or connected via any modem ??  --

Regards

Karuppu

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

Instead of ATM , you have to use your current interface which is going to connect your ISP from your router and configure ppoe in that interface.

regards

karuppu

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

Glad to help you.Once you got success in the configuration update your status in the post.

Regards

Karuppu

Correct Answer by KARUPPUCHAMY MA... about 6 years 9 months ago

Hi,

Nothing to worry.

Find the url which will help you to configure PPoE in cisco router.

In the below example use your ethernet interface instead of ATM

Cisco DSL Router Acting as a PPPoE Client with a Dynamic IP Address


http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml

Cisco DSL Router Acting as a PPPoE Client with a Static IP Address

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a799.shtml

Hope it will helps u to configure PPoE in cisco 3845 router.

regards

karuppu

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (14 ratings)
Loading.
Paolo Bevilacqua Tue, 03/02/2010 - 03:31

Recommend you engage someone experienced.

if he still has trouble can come back here at any time.

nekaratal Wed, 03/03/2010 - 22:18

Hello, good day, im still havin trouble with my cisco3845, i cant have internet access, i tried to have my friend help me but still wont work, can you help me please, i dont know anyone who is more expirience with the device, hope im not bothering you, have a great day many thanks

Correct Answer
KARUPPUCHAMY MA... Wed, 03/03/2010 - 22:26

Hi,

Nothing to worry.

Find the url which will help you to configure PPoE in cisco router.

In the below example use your ethernet interface instead of ATM

Cisco DSL Router Acting as a PPPoE Client with a Dynamic IP Address


http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml

Cisco DSL Router Acting as a PPPoE Client with a Static IP Address

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a799.shtml

Hope it will helps u to configure PPoE in cisco 3845 router.

regards

karuppu

nekaratal Wed, 03/03/2010 - 22:33

Thank you very much i will try to configure the Router now, thank you thank you, hope im not bothring you, have a great day and thanks alot again

Correct Answer
KARUPPUCHAMY MA... Wed, 03/03/2010 - 22:35

Hi,

Glad to help you.Once you got success in the configuration update your status in the post.

Regards

Karuppu

nekaratal Wed, 03/03/2010 - 22:45

some commands are not reconize by cisco3845   like the atm comand, is there any substitute?

Correct Answer
KARUPPUCHAMY MA... Wed, 03/03/2010 - 22:47

Hi,

Instead of ATM , you have to use your current interface which is going to connect your ISP from your router and configure ppoe in that interface.

regards

karuppu

nekaratal Wed, 03/03/2010 - 22:49

i will try which one, i dont have any idea what to use i just new at configuring this routers hope im not bothering you thanks again

KARUPPUCHAMY MA... Wed, 03/03/2010 - 22:52

Hi,

No problem. See In which interface you have terminated your internet(DSL) link to your router.It should be either your ethernet interface or your serial interface.

can you paste the sh running-configuration and sh interface of your router

regards

karuppu

nekaratal Wed, 03/03/2010 - 22:58

This is the sh interface

GigabitEthernet0/0 is down, line protocol is down
  Hardware is BCM1125 Internal MAC, address is 001e.f7ae.6ec0 (bia 001e.f7ae.6ec
0)
  Internet address is 192.168.10.3/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Unknown duplex, Unknown Speed, media type is RJ45
  output flow-control is XON, input flow-control is XON
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
     2 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     2 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
GigabitEthernet0/1 is administratively down, line protocol is down
  Hardware is BCM1125 Internal MAC, address is 001e.f7ae.6ec1 (bia 001e.f7ae.6ec
1)
  MTU 1492 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Unknown duplex, Unknown Speed, media type is RJ45
  output flow-control is XON, input flow-control is XON
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     1 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     1 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
Service-Engine1/0 is administratively down, line protocol is down
  Hardware is I82559FE, address is 001e.f7ae.6ed0 (bia 001e.f7ae.6ed0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
323 packets input, 124171 bytes, 0 no buffer
     Received 110 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     325 packets output, 134628 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
NVI0 is up, line protocol is up
  Hardware is NVI
  Interface is unnumbered. Using address of NVI0 (0.0.0.0)
  MTU 1514 bytes, BW 10000000 Kbit, DLY 0 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation UNKNOWN, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out

And this is the running config

Current configuration : 1025 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
no network-clock-participate wic 3
ip cef
!
!
!
!
vpdn enable
!
!
voice-card 0
no dspfarm
!

!
!controller E1 0/3/0
!
interface GigabitEthernet0/0
ip address 192.168.10.3 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
mtu 1492
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface Service-Engine1/0
no ip address
shutdown
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!

!
line con 0
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Correct Answer
KARUPPUCHAMY MA... Wed, 03/03/2010 - 23:47

Hi,

As per your configuration you have one E1 controller card and 2 Giga interfaces in your router.

Can you tell me about your internet connection. ??  -- If yes then connect your internet link into one of the gigabitethernet port and configure that interface as ppoe interface.

Is the internetconnection via  ethernet connection or connected via any modem ??  --

Regards

Karuppu

nekaratal Wed, 03/03/2010 - 23:55

My internet connection is a DSL connection, im using a modem, that is directly connected to my cisco3845 which is gigaethernet 0/1 then the other giga ethernet 0/0 is connected to my pc. DSL MODEM>CISCO3845>PC

Correct Answer
KARUPPUCHAMY MA... Thu, 03/04/2010 - 01:01

Hi,

I have prepared the configuration for your router.

Just do copy paste. for more infor refer that url which i gave in the same post

vpdn enable
no vpdn logging
vpdn-group pppoe
  request-dialin
   protocol pppoe

interface GigabitEthernet0/0
ip address 192.168.10.3 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
media-type rj45

int gi0/1
no sh
pppoe-client dial-pool-number 1

interface dialer1
ip address negotiated
mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password
ppp pap sent-username password


ip nat inside source list 1 interface dialer1 overload

ip route 0.0.0.0 0.0.0.0 interface dialer 1

access-list 1 permit 192.168.10.0  0.0.0.255

Regards

Karuppu

I have changed the interface config (bold).Hope it will clear your doubt

nekaratal Thu, 03/04/2010 - 01:14

hello, thank you very much, really appreciate it, btw how do i configure the giga0/1 what confiuration would i put in it? so it would connect to my pc

sorry to bother you

Correct Answer
KARUPPUCHAMY MA... Thu, 03/04/2010 - 01:19

Hi,

I have prepared the configuration for your router.

Just do copy paste. for more infor refer that url which i gave in the same post

vpdn enable
no vpdn logging
vpdn-group pppoe
  request-dialin
   protocol pppoe

interface GigabitEthernet0/0
ip address 192.168.10.3 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
media-type rj45

int gi0/1
no sh
pppoe-client dial-pool-number 1

interface dialer1
ip address negotiated
mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password
ppp pap sent-username password


ip nat inside source list 1 interface dialer1 overload

ip route 0.0.0.0 0.0.0.0 interface dialer 1

access-list 1 permit 192.168.10.0  0.0.0.255

Regards

Karuppu

I have changed the interface config (bold).Hope it will clear your doubt

nekaratal Thu, 03/04/2010 - 01:23

thanks you very much sir really appreciate it, sorry to bother you, goin to try it now ty ty, have a great day

nekaratal Thu, 03/04/2010 - 16:26

Hello again sir, the configuration is not workin do i need to put an ip dhcp pool? but i dont know how. sorry to bother you again, hope you have a great day

Correct Answer
KARUPPUCHAMY MA... Thu, 03/04/2010 - 17:23

Hi,

Can you paste the router current running configuration.

DHCP is not necessary to configure,that is used to assign the IP dynamically to your desktops.

regards

karuppu

nekaratal Thu, 03/04/2010 - 17:42

hello sir good day, this is the confiuration of my cisco3845

Current configuration : 1419 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
no network-clock-participate wic 3
ip cef
!
vpdn enable
!
voice-card 0
no dspfarm
!
controller E1 0/3/0
!

interface GigabitEthernet0/0
ip address 192.168.10.3 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
media-type rj45
pppoe enable
pppoe-client dial-pool-number 1
!
interface Service-Engine1/0
no ip address
shutdown
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname 27061455
ppp chap password 0 196581626
ppp pap sent-username 27061455 password 0 196581626
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 192.168.10.0 0.0.0.255
!

control-plane
!

!
line con 0
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Correct Answer
KARUPPUCHAMY MA... Thu, 03/04/2010 - 17:50

Hi,

Have you tried to configure the below lines in your router.

vpdn enable
no vpdn logging
vpdn-group pppoe
  request-dialin
   protocol pppoe

Can you paste the output of the below command

#sh ip int br

Even if you are not able to access internet, contact your ISP.

regards

karuppu

nekaratal Thu, 03/04/2010 - 17:53

yes i tripe to put the command

vpdn enable
no vpdn logging
vpdn-group pppoe
  request-dialin
   protocol pppoe

but the last line is not available its just l2tp but still i put the protocol pppoe

this is the sh ip int brief

Interface                  IP-Address      OK? Method Status                Prot
ocol
GigabitEthernet0/0         192.168.10.3    YES manual down                  down

GigabitEthernet0/1         unassigned      YES unset  down                  down

Service-Engine1/0          unassigned      YES unset  administratively down down

NVI0                       unassigned      NO  unset  up                    up

Dialer1                    unassigned      YES manual up                    up

Correct Answer
KARUPPUCHAMY MA... Thu, 03/04/2010 - 18:17

Hi,

Now, configuration wise everything is ok.Better check with your ISP.

GigabitEthernet0/1         unassigned      YES unset  down                  down

I hope the cable is coming from your modem to router might be not working.befor contact with ISP check that
cable because the interface is down now.

If both your router and modem's are powered on then it should be up

Regards

Karuppu

Just have a look of my BOLD LETTERS once again

nekaratal Thu, 03/04/2010 - 18:20

hello, so my configuration is correct? the cable to use it straight = DSL modem > cisco 3845 then cross over cable from cisco 3845 to PC right?

nekaratal Thu, 03/04/2010 - 18:55

hello sir i tried to put the utp cables to the modem and my pc they are both up, but still i have limited sonnectivity i dont know what seems to be the problem, sorry to bother you sir

nekaratal Fri, 03/05/2010 - 18:47

can i ask a question again, whats the command for the router so it will load its start up config when ever i turn it off? i keep on copyng the start up to runnn everytime i turn it off.

Correct Answer
Reza Sharifi Fri, 03/05/2010 - 18:57

When you are at the router save the config by issuing this command

"wr" after that your config is saved and when your reboot the router you don't loose your config any more

HTH

Reza

nekaratal Fri, 03/05/2010 - 19:09

wont work what  mean is every time i restart the router the runnng config is set on default so i have to load the start up config aain so it will be in runnin, is there any option that it will auto load the start up config every time it is turn on

Correct Answer
KARUPPUCHAMY MA... Fri, 03/05/2010 - 19:34

Hi,

Can you paste the sh version of your router.susecting the config-register value.

regards

karuppu

nekaratal Fri, 03/05/2010 - 19:45

Cisco 3845 (revision 1.0) with 225280K/36864K bytes of memory.
Processor board ID FHK1209F19G
2 Gigabit Ethernet interfaces
1 terminal line
1 Channelized E1/PRI port
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity enabled.
479K bytes of NVRAM.
62720K bytes of ATA System CompactFlash (Read/Write)

Configuration register is 0x2142

Correct Answer
KARUPPUCHAMY MA... Fri, 03/05/2010 - 19:48

Hi,

You need to change the config register in to 0x2102.the configuration register shows 0x2142. The             router bypasses the startup configuration stored in NVRAM during its boot             sequence. This feature is normally used during a password recovery             procedure.

router(config)#config-register 0x2102

then write the confiig. reload you router.

Regards

Karuppu

nekaratal Fri, 03/05/2010 - 19:52

its ok now thanks alot have a great day sir many thanks agan

Actions

This Discussion