VPN client won't install on Ubuntu 9.10

Unanswered Question
Mar 2nd, 2010

I am trying to install the 4.8.02.0030 VPN client for Linux on Ubuntu 9.10. The following information applies:

uname -a

Linux dell-desktop 2.6.31-19-generic #56-Ubuntu SMP Thu Jan 28 01:26:53 UTC 2010 i686 GNU/Linux

Pertinent output from vpn_install:

* Binaries will be installed in "/usr/local/bin".
* Modules will be installed in "/lib/modules/2.6.31-19-generic/CiscoVPN".
* The VPN service will *NOT* be started automatically at boot time.
* Kernel source from "/lib/modules/2.6.31-19-generic/build" will be used to build the module.

Is the above correct [y]

Making module
make -C /lib/modules/2.6.31-19-generic/build SUBDIRS=/home/sbrenneis/vpnclient modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.31-19-generic'
  CC [M]  /home/sbrenneis/vpnclient/linuxcniapi.o
  CC [M]  /home/sbrenneis/vpnclient/frag.o
  CC [M]  /home/sbrenneis/vpnclient/IPSecDrvOS_linux.o
  CC [M]  /home/sbrenneis/vpnclient/interceptor.o
/home/sbrenneis/vpnclient/interceptor.c: In function ‘interceptor_init’:
/home/sbrenneis/vpnclient/interceptor.c:132: error: ‘struct net_device’ has no member named ‘hard_start_xmit’
/home/sbrenneis/vpnclient/interceptor.c:133: error: ‘struct net_device’ has no member named ‘get_stats’
/home/sbrenneis/vpnclient/interceptor.c:134: error: ‘struct net_device’ has no member named ‘do_ioctl’
/home/sbrenneis/vpnclient/interceptor.c: In function ‘add_netdev’:
/home/sbrenneis/vpnclient/interceptor.c:271: error: ‘struct net_device’ has no member named ‘hard_start_xmit’
/home/sbrenneis/vpnclient/interceptor.c:272: error: ‘struct net_device’ has no member named ‘hard_start_xmit’
/home/sbrenneis/vpnclient/interceptor.c: In function ‘remove_netdev’:
/home/sbrenneis/vpnclient/interceptor.c:294: error: ‘struct net_device’ has no member named ‘hard_start_xmit’
make[2]: *** [/home/sbrenneis/vpnclient/interceptor.o] Error 1
make[1]: *** [_module_/home/sbrenneis/vpnclient] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.31-19-generic'
make: *** [default] Error 2
Failed to make module "cisco_ipsec.ko"

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
johnd2310 Tue, 03/02/2010 - 08:55

Hi,

Use the native client that comes with Ubuntu. It's called vpnc. Your install is probably not working cause you need to patch your kernel.

Thanks

John

jelvington@goul... Mon, 03/08/2010 - 06:44

I have tried using vpnc before with the Cisco concentrator and didn't have much luck. I will try it again.

What kernel patch are you referring to?

kontrabant Tue, 05/11/2010 - 03:12

I got it working with this patch on Ubuntu && FEDORA (with slight modification of sed command):

Untar vpnclient-linux-x86_64-4.8.02.0030-k9.tar.gz

# Download patch file for newer kernel (2.6.30+) and apply it:

    wget http://lamnk.com/download/vpnclient-linux-2.6.31-final.diff

    cd vpnclient  

    patch < ./vpnclient-linux-2.6.31-final.diff

# Next we must edit a kernel source file

    sudo sed -i 's/const\ struct\ net_device_ops\ \*netdev_ops;/struct\ net_device_ops\ \*netdev_ops;/' `find /usr/src -name netdevice.h`

Yes, it is a one liner, you should copy & paste that command instead of typing The command's translation into English: find the string const struct net_device_ops *netdev_ops; and change it to struct net_device_ops *netdev_ops; in the file locates at

    find /usr/src -name netdevice.h

# And finally, install Cisco VPN Client:

    sudo ./vpn_install

Actions

Login or Register to take actions

This Discussion

Posted March 2, 2010 at 5:16 AM
Stats:
Replies:3 Avg. Rating:
Views:3652 Votes:0
Shares:0

Related Content

Discussions Leaderboard