European FSK Caller ID

Unanswered Question
Mar 2nd, 2010
User Badges:

Hi,

I have Linksys SPA400 and can't get Caller ID on incomming calls. Waiting for firmware that will fix this over 2 years.

I use this adapter on 2 installs: one with SPA9000 and one with Asterisk. Same problem with both.

I am from Bulgaria. Telecom operator Vivacom ( formerly BTC ).

With SPA3102 Caller ID is working fine. Settings are ETSI FSK - bell 202 and FXO Port Impedance 600

Tried all suggestions in other posts with no success.


Also I find a document from my provider that describes specifications for end-user devices:


Specification ETSI ETS 300 6593 FSK


Timeparameters:

500 ms ≤ T5 ≤ 2000 ms

T6 ≥ 200 ms

T 9 = 0 ms to 150 ms

T 10 = 0 ms to 150 ms

T 11 = 40 ms to 55 ms

T 12 = 55 ms to 200 ms

T 13 = 40 ms то 120 ms

T 14 = 160 ms ± 5 ms


Can you give me some advise how to get CLIP from my lines?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Tue, 03/02/2010 - 08:24
User Badges:
  • Cisco Employee,

Dear Sir;


You would need the latest SPA400 BETA. See attached. In principle, all you need is to configure the settings to Bellcore or Euro FSK depending the switch you are connecting this to.


Regards
Alberto

stylecomltd Tue, 03/02/2010 - 11:54
User Badges:

Hi,

Thank you for your answer.

I tried this firmware, but can't see difference with 1.1.2.2.

If  European FSK is set, I get anonymous as incoming caller id.

If North American is set, I get line ID as incoming caller id.

Please let me know if you need logs.


Chavdar

Alberto Montilla Tue, 03/09/2010 - 06:21
User Badges:
  • Cisco Employee,

Dear Sir;


Can you take the SPA400 logs for each case?


Regards
Alberto

stylecomltd Wed, 03/10/2010 - 01:25
User Badges:

Hi,

Attached files are log from SPA400 connected to my office Asterisk.

I saw my number detected in full North American log, but the result was line ID for Caller ID.

I hope this will help.

Thank you!

Alberto Montilla Wed, 03/10/2010 - 07:03
User Badges:
  • Cisco Employee,

Dear Sir;


I'm escalating this to engineering. Stay tuned.


Regards
Alberto

Alberto Montilla Thu, 03/11/2010 - 05:25
User Badges:
  • Cisco Employee,

Dear Sir;


Please follow the configuration parameters of the following document/docs/DOC-9873. It should work properly. If it does not work, I would need to see also the SIP traces between the SPA400 and the SPA9000 as well as the configuration of the SPA400 (html pages).


Regards

Alberto

naim.ghoussoub Mon, 05/10/2010 - 06:48
User Badges:

Dear Alberto,


Sorry for the duplicate post...




I am facing similar problems with PSTN lines in Lebanon. I tried the localization settings as follows:

Lebanon 0 270+(750||150nF) 3.5 10 3 Enable North America


no success at all. I tried lot of settings and I upgraded to the latest beta firmware. Any suggestions to solve this problem ? Usually here we FSK settings with caller id after first ring. how can i apply it?

kradoyno Thu, 03/11/2010 - 08:47
User Badges:

Hello,

In our Lab we use SPA9000, SPA942, SPA400 (with beta firmware 1.1.2.3) connected to Vivacom PSTN line.

Caller ID works normally. I am sending you the settings that we use (see attached file "BG Settings Caller ID.zip").

After configuring SPA400 and SPA9000 and saving the settings, do the following:

1. reboot SPA400 and after it is up and running ...

2. unplug power cord of SPA9000 and plug it in again.

3. after restart of the phones, make one outbound call to your mobile, for example.


After all these measures, the Caller ID should work properly.


Best regards,

Kino

stylecomltd Fri, 03/12/2010 - 05:30
User Badges:

It's not working.

I left behind my Asterisk and build a test Linksys PBX:

SPA9000 firmware 6.1.5

SPA400 firmware 1.1.2.3 - test build AU CID mix

SPA941 firmware 5.1.8

Attached log is for 4 incoming calls. First was success. On second I get only 4 digits from Caller ID. On third and fourth I got nothing.

Attached also and config in html for SPA400.

Thanks!

Attachment: 
kradoyno Fri, 03/12/2010 - 07:07
User Badges:

Hello, again,

Try with "Call progress tone settings.mht" that I sent you in my previous posting.

And please try to avoid using any splitters or any additional devices on your PSTN lines - just standart line as it comes from Vivacom.


Good luck :)


Best regards,

Kino

stylecomltd Fri, 03/12/2010 - 08:10
User Badges:

Hi,

And thank you for your help.

I tryed them, but with the same result.

I found something else. Test line come to my office via PCM and that is why I don't get CLIP every time.

For test I plug another line and I got CLIP every time, but on phone is show incorect. It is the line ID.

Attached log is from this line with 3 incoming calls.

Attachment: 
idiamanti Wed, 04/14/2010 - 04:05
User Badges:

Hello Guys,


We have the same problem in Greece (also described in msg. 3709,  https://www.myciscocommunity.com/message/3709#3709 ), from PSTN lines (provider FORTHnet).

In our Lab, the configuration is the same (SPA9000 - SPA400 - SPA942 with the latest F/W).

We have tried different Caller ID methods.

The one that works (only with ISDN lines - provider OTE), is North American. If we have incoming calls from analog ports of ISDN gateway/line, everything is OK. See 1st attachment log (ISDN).

If we have incoming calls from PSTN line, we have the same problem, as stylecomltd describes. See 2nd attachment log (PSTN).

If you compare the two logs, you can see (PSTN) that the system, instead of fetching the first number (which is caller's ID), sends - wrongly - to SPA9000, the second number (which is the called number).

The system must recognise as caller's ID, the number that follows the special character in the raw message. With this proposal, we are going to have the same correct result either the call is coming from ISDN line, either from PSTN line


Thx

John

Attachment: 
naim.ghoussoub Mon, 05/10/2010 - 06:42
User Badges:

I am facing similar problems with PSTN lines in Lebanon. I tried the localization settings as follows:

Lebanon 0 270+(750||150nF) 3.5 10 3 Enable North America


no success at all. I tried lot of settings and I upgraded to the latest beta firmware. Any suggestions to solve this problem ? Usually here we FSK settings with caller id after first ring. how can i apply it?

Alberto Montilla Tue, 06/01/2010 - 03:01
User Badges:
  • Cisco Employee,

Dear Naim;


If you have FSK with PR, then please try European FSK.


Regards
Alberto

idiamanti Tue, 06/01/2010 - 01:47
User Badges:

For God's shake!!!!!!!!!!!

We are waiting for an answer (what ever will be), from Cisco.

We have disappointed customers and we don't know what to tell them.

Alberto Montilla Tue, 06/01/2010 - 02:57
User Badges:
  • Cisco Employee,

Dear Sir;


I'm trying to help you as much as possible with this resolution, which is not easy based on the fact that threads are including multiple countries and multiple type of lines. This is hard to replicate as may not be able to see the issue you are seeing


I suggest that if you have urgency to solve the issue, please contact the Small Business Support Center. http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html


Regards;

Alberto

idiamanti Thu, 07/01/2010 - 07:26
User Badges:

Hi Alberto.


Any news from your Engineering Team?

When we can expect something?


Regards

John

Alberto Montilla Fri, 07/02/2010 - 03:07
User Badges:
  • Cisco Employee,

Dear Sir;


Checking. Will provide you an update as soon as I get a response


Regards
Alberto

idiamanti Tue, 08/24/2010 - 02:20
User Badges:

Dear Alberto,

After one and a half month, i'm comming back to ask you to contact with your engineers and remind them the subject problem.

Is there any progress?

And one more info, with SPA-3102, there isn't such a problem.


Regards

John

idiamanti Tue, 11/02/2010 - 01:55
User Badges:

Dear Alberto,


is it possible to ask your engineers, if they have examined the proposal that we sent with our first message (14 April)?


Regards

John

stylecomltd Tue, 10/11/2011 - 07:36
User Badges:

Four years you can't fix this CallerID problem.

Please tell us it will be solution or not.

If not I'll get the all SPA400 direction to the trash.

Daniele Giordano Sat, 11/12/2011 - 01:44
User Badges:
  • Gold, 750 points or more

Have you try to change the Ring Validation Time under Voice-Line menu?

Try to change the default value to 100 ms.


Regards.

Actions

This Discussion