Can't RDP through VPN

Unanswered Question
Mar 2nd, 2010
User Badges:

Dear Experts,


I've the following problem:


PC with VPN Client > Internet > ISR router > LAN


Successfully connected to VPN, ping works but RDP not.


I've googled and red a lot of forums about likely the same problem but what I've found doesn't worked.


I've tried to change the MTU and tcp mss to different sizes on both the WAN and LAN interfaces, but neither worked.


Any thoughts?


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
johnd2310 Tue, 03/02/2010 - 09:01
User Badges:
  • Silver, 250 points or more

Hi,


That usually indicates an mtu issue. Have you tried changing mtu on the client as well. If you are using nat also check your nat config and access-lists are okay.




Thanks

John

integris-kiuf Tue, 03/02/2010 - 23:02
User Badges:

The MTU on the client is 1300 by default, because Cisco VPN Client is installed.

I've tried to lower it to 1260, 1200, etc, but nothing changed.

The max MTU which goes through is 1260 (tried with ping, df-bit set).


The NAT and access-list are ok, I've triple checked it:)


I know that this is an MTU issue, but I doesn't know what and where to change.



Oh, I forgot it: the server os is Windows 2000 (I know, but this is our custumers, cannot change it).

nomair_83 Tue, 03/02/2010 - 11:58
User Badges:
  • Bronze, 100 points or more

Try to telnet that server on RDP port from client and enable logging on VPN gateway then paste any specific logs here.


make sure that users are allowed in server for RDP.

integris-kiuf Tue, 03/02/2010 - 23:05
User Badges:

Can you tell me which type of logs do you want to see?

I can telnet to the server, but after I press Enter it disconnects. Is this normal?


The users are allowed to RDP to the server, from the local LAN it works.

Actions

This Discussion