IPCC upgrade required???

Answered Question
Mar 2nd, 2010
User Badges:

Hi,


I am working on doing an upgrade for a Call Manager server version 4.1.3 to Communications Manager version 7.1.3a, but this server is integrated with a IPCC Express 4.0 server, but I need to know if there is any way I can integrate the IPCC 4.0 server with the CUCM v7.1 server, or if I will need to upgrade the IPCC as well.


Also, if this is not possible, I would like to have a guide for the IPCC upgrade.


Thanks in advance.

Correct Answer by Aaron Harrison about 7 years 3 months ago

Hi


You will need to upgrade IPCC as well.


This document lists each version of UCCX, and which versions of CCM it is compatible with.


http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_compatibility/matrix/crscomtx.pdf


UCCX 7.0(1)SR4 is the first release to support CM 7.1.3.


There is no upgrade path from IPCC 4.0 to 7.0, so to upgrade you would need to:


1) Back up all application settings, triggers, scripts, documents, and other config elements such as agent skills, supervisor and team configs

2) Build a fresh install of UCCX7.0

3) Manually reconfigure all applications, scripts, config, agents etc.


You will also lose all your historical unless you use the Historical Data Migration tool to move that to the new version. To use that you would have to ensure you are on a supported version of IPCC4 (4.0.5 or 4.0.5a). The migration of all the settings is the tricky part, and I would strongly suggest you get someone experienced with IPCC to do this or you may find yourself in trouble. If you can deploy on new hardawre, this will allow you to look back at the old server if it turns out you missed something important.


This document details the process:


http://www.cisco.com/web/software/282467017/23664/UCCX_DataMigrationTool_Guide_405x-701.pdf


Regards


Aaron


Please rate helpful posts...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Correct Answer
Aaron Harrison Wed, 03/03/2010 - 05:58
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


You will need to upgrade IPCC as well.


This document lists each version of UCCX, and which versions of CCM it is compatible with.


http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_compatibility/matrix/crscomtx.pdf


UCCX 7.0(1)SR4 is the first release to support CM 7.1.3.


There is no upgrade path from IPCC 4.0 to 7.0, so to upgrade you would need to:


1) Back up all application settings, triggers, scripts, documents, and other config elements such as agent skills, supervisor and team configs

2) Build a fresh install of UCCX7.0

3) Manually reconfigure all applications, scripts, config, agents etc.


You will also lose all your historical unless you use the Historical Data Migration tool to move that to the new version. To use that you would have to ensure you are on a supported version of IPCC4 (4.0.5 or 4.0.5a). The migration of all the settings is the tricky part, and I would strongly suggest you get someone experienced with IPCC to do this or you may find yourself in trouble. If you can deploy on new hardawre, this will allow you to look back at the old server if it turns out you missed something important.


This document details the process:


http://www.cisco.com/web/software/282467017/23664/UCCX_DataMigrationTool_Guide_405x-701.pdf


Regards


Aaron


Please rate helpful posts...

Anthony Holloway Wed, 03/03/2010 - 09:00
User Badges:
  • Purple, 4500 points or more
There is no upgrade path from IPCC 4.0 to 7.0, so to upgrade you would need to:


Actually there is an upgrade path.  In fact, you linked to the tool that does it.  The DMT migrates your config and your historical data now.  Perhaps you were thinking of the original tool that was released to only migrate the historical data.  So that should be good news for you too.

Aaron Harrison Wed, 03/03/2010 - 09:37
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi Anthony


So I did  :-)


Not like Cisco to do extra dev for a product that's so near death.. nice though.


Thanks

sergiope Wed, 03/03/2010 - 10:40
User Badges:

Thanks for your replies,


Just to let you know, I will be installing a brand new server for the IPCC version 7, so it should be a little easier to install as you mentioned.


I guess we will have to upgrade it using the data migration tool so we don't lose the previous information.


Again, thanks for your help on this.

Anthony Holloway Wed, 03/03/2010 - 19:56
User Badges:
  • Purple, 4500 points or more

Do be aware, that if you use DMT, you must keep the hostname and IP of the UCCX and CUCM the same.  Once DMT has completed, and your system is stable, you can then rename and/or re-ip CUCM, and you can also re-ip UCCX.  However, you cannot rename UCCX.


So if that poses a problem for your upgrade, you may just want to skip DMT and cut your losses with that method, and do a fresh install.

ra_jeshkalra_2 Thu, 03/04/2010 - 00:02
User Badges:

Hi Anthony,


I have CCM 4.3 and IPCCX6.0 HA. the customer wants to upgrade CCM 4.3 to CCM 7.x and so I am forced to upgrade IPCCX6.0 also, since IPCCX6.0 doesn't work with CCM 7.x as per the compatibility guide.


Question:

I plan to do a fresh install of IPCCX7.0,and o.k. with  HR data not needed. Before I do a fresh install of IPCCX7.0, do I need to delete the old setup info... of IPCCX6.0, from cCM 4.3 and then upgrade CCM 4.3.

OR

I don't delete JTAPI trigger e.t.c.

2)Upgrade CCM 4.3-> 7.x

3)Then I install IPCCX7.x ---> While installing this will not conflict with the old config of IPCCX6.0 in CCM?


Thanks

Anthony Holloway Thu, 03/04/2010 - 20:35
User Badges:
  • Purple, 4500 points or more

Thread hijacking...nice.


Good question though.  The short answer is, you delete the CCX config from CUCM yourself.  Whether you do it before the upgrade of CUCM, or after CUCM is upgraded, it's up to you.  The fresh install of CCX will not know about the Route Points etc, and when you try and create them in CCX, it will throw an error stating they already exists in CUCM.

marknigh1 Sat, 11/06/2010 - 16:26
User Badges:

I have a question regarding the requirement of keeping the same IP Address and Hostname. If I have a co-resident CallManager UCCX deployment in v4, how do I keep the IP address when upgrading? Thanks.

Anthony Holloway Sat, 11/06/2010 - 21:25
User Badges:
  • Purple, 4500 points or more

You just type it into the new server?  What version are you coming from, and going to?

marknigh1 Sun, 11/07/2010 - 08:59
User Badges:

I have CallManager v4.1(3) and IPCC v4.0(5) Co-resident on a single server both have the same IP address (10

.1.1.1). When I upgrade I must move IPCC to a new server since co-residence is no longer supported. How

do I perform an IPCC upgrade from v4.0(5) to v7.0(1) if the requirement is to keep the same IP

address. CallManager will be upgraded from v4.1(3) to version 7.1(3) with 10.1.1.1.


I hope this explains my scenario a little more. No where in the documentation does it state that IPCC upgrades that originate co-resident with CallManager is NOT supported. It also only states that it is "strongly recommended" to keep the IP address. It doesn't say it is required or mandatory to keep the IP address when upgrading.

Actions

This Discussion

Related Content