Spanning-tree question on a pair of 6509 and HP BL p-class GbE2 Interconnect Switch

Unanswered Question
Mar 2nd, 2010

We have 2 core 6509 switches core1 and core2 that connected to each other over a port-channel1 made up of 6 ports (5/1-5/6). All Vlans are allowed on this etherchannel.


We also have a HP Interconnect switch connected to core1 and core2 on port 8/1 core1 and port 8/1 core2.  For some reason all the network traffic is going from core1 to HP switch first and then go over to core2 via port 8/1.  That how our traffic is going across the cores right now.  We would like to have our network traffic going across the cores through the etherchannel.


6509 core1

vtp domain FP_VTP

vtp mode transparent


interface port-channel1

switchport

switchport trunk encap dot1q

switchport trunk native vlan 999

switchport trunk allowed vlan 1,100-107,999

switchport mode trunk

no ip address


When we do show spanning-tree root, Vlan0001 is going to root port gi8/1 which connected to HP switch.


What would be the best way to configure the 6509s to use etherchannel instead of gi8/1 between core1 and core2?


-Smith-

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Tue, 03/02/2010 - 12:20

ssamaharn wrote:


We have 2 core 6509 switches core1 and core2 that connected to each other over a port-channel1 made up of 6 ports (5/1-5/6). All Vlans are allowed on this etherchannel.


We also have a HP Interconnect switch connected to core1 and core2 on port 8/1 core1 and port 8/1 core2.  For some reason all the network traffic is going from core1 to HP switch first and then go over to core2 via port 8/1.  That how our traffic is going across the cores right now.  We would like to have our network traffic going across the cores through the etherchannel.


When we do show spanning-tree root, Vlan0001 is going to root port gi8/1 which connected to HP switch.


What would be the best way to configure the 6509s to use etherchannel instead of gi8/1 between core1 and core2?


-Smith-


Have you configured the 6500 switches to be the STP root and secondary for all the vlans. If youy haven't then the HP switches could be selected as root and secondary.


If you haven't you need to configure them but you will need an outage because there will be an STP recalculation.


Jon

contech-nelsong Tue, 03/02/2010 - 12:22

Do you have one of the 6509s configured as root?


spanning-tree vlan root primary sets the device to the recommended root bridge settings

spanning-tree vlan root secondary can be used on another device to make that the backup root bridge

ssamaharn Tue, 03/02/2010 - 12:53

Thank you very much for a quick reply.  How do I check on the core to see if I have the first core STP root for all vlans?  I'm pretty sure I dont have that setup for sure.


-Smith-

contech-nelsong Tue, 03/02/2010 - 12:58

on the device you want to be root:

sh spanning-tree vlan


see if the reported Root ID and Bridge ID match.


The Bridge ID is what that device thinks it is, and the Root ID is what it thinks the root bridge's ID is.

Jon Marshall Tue, 03/02/2010 - 12:58

Pick a vlan and do "sh spanning-tree vlan " and post output.


Also there would be lines in your config on the 6500 switches along the lines of


spanning-tree vlan root primary

spanning-tree vlan root secondary


or


spanning-tree vlan priority


Jon

ssamaharn Tue, 03/02/2010 - 13:28

show spanning-tree vlan 1

vlan0001

spanning tree enabled protocol ieee

Root ID Priority 32768

Address 0002.a5d1.275b

Cost 4

Port  897 (GigabitEthernet 8/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 0019.07b5.6400

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

contech-nelsong Tue, 03/02/2010 - 13:32

that device is not the root bridge.


the root bridge is one of the HP devices (0002.a5 is an HP MAC address), probably by virtue of its lower MAC address.


Set the device to be root and you should see the traffic passing correctly

Jon Marshall Tue, 03/02/2010 - 13:34

ssamaharn wrote:


show spanning-tree vlan 1

vlan0001

spanning tree enabled protocol ieee

Root ID Priority 32768

Address 0002.a5d1.275b

Cost 4

Port  897 (GigabitEthernet 8/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 0019.07b5.6400

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300


From the above -


Root ID Priority 32768
Address 0002.a5d1.275b 


the above is the root bridge. From the mac-address 0002.a5 is HP.

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 0019.07b5.6400


this is mac-address of the 6500.


When you are on the root switch the 2 mac-addresses will match.


Jon

ssamaharn Wed, 03/03/2010 - 13:11

I've been reading about portfast BPDU guard.  What would be the best practice for two 6509s to talk to each over an etherchannel?

I have the show spanning-tree root, show spanning-tree summary and show config on one of the core 6509s.


show spanning-tree root

vlan                         Root ID               Root   Hello Max Fwd     Root Port

________________________________Cost_______________________

vlan0001     32768     0002.a5d1.275b     4     2     20     15     gi8/1

vlan0100     32686     0019.07b5.6400     0     2     20     15   

vlan0101     32869     0019.07b5.6400     0     2     20     15

vlan0102     32870     0019.07b5.6400     0     2     20     15

vlan0103     32871     0019.07b5.6400     0     2     20     15

vlan0104     32872     0019.07b5.6400     0     2     20     15

vlan0105     32873     0019.07b5.6400     0     2     20     15

vlan0106     32874     0019.07b5.6400     0     2     20     15

vlan0107     32875     0019.07b5.6400     0     2     20     15

vlan0109     32877     0019.07b5.6400     0     2     20     15

vlan0111     32879     0019.07b5.6400     0     2     20     15

vlan0200     32769     001e.1477.e200     19     2     20     15     gi8/24

vlan0999     33767     0019.07b5.6400     0     2     20     15

Jon Marshall Wed, 03/03/2010 - 13:14

ssamaharn wrote:


I've been reading about portfast BPDU guard.  What would be the best practice for two 6509s to talk to each over an etherchannel?

I have the show spanning-tree root, show spanning-tree summary and show config on one of the core 6509s.




Not sure how this relates to your original question. Is this now a different question ? BPDUGuard will do nothing to help you with your original problem.


Jon

ssamaharn Wed, 03/03/2010 - 13:18

Hi, Jon


It's the same question.  I was just reading about the BDPU guard on Cisco site yesterday about helping with spanning-tree.

Jon Marshall Wed, 03/03/2010 - 13:21

ssamaharn wrote:


Hi, Jon


It's the same question.  I was just reading about the BDPU guard on Cisco site yesterday about helping with spanning-tree.


BPDUGuard is used for ports that should not receive BPDUs on them ie. ports connected to devices such as client PCs/servers etc. It is no use for connections between switches because you want BPDUs to be sent and received on these ports.


Are you sure you are not thinking of rootguard which would help in making sure that your HP switches could not become the root switches ? You still need to sort out the STP root and secondary on your 6500 switches.


Jon

ssamaharn Wed, 03/03/2010 - 13:22

Should I do these command on my core1 and core2 ?


core1

spanning-tree vlan 1-111,999 root primary


core2

spanning-tree vlan 1-111,999 root secondray

Jon Marshall Wed, 03/03/2010 - 13:25

ssamaharn wrote:


Should I do these command on my core1 and core2 ?


core1

spanning-tree vlan 1-111,999 root primary


core2

spanning-tree vlan 1-111,999 root secondray


Yes, if these are all the vlans you have between the 6500 switches and the HP switches. But as already mentioned there will be a short outage while STP reconvergences so you need to schedule some downtime.


Jon

Actions

This Discussion