cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1144
Views
0
Helpful
3
Replies

ADSL Config assistance

melwin.uk
Level 1
Level 1

Hi Experts, looking for configuraiton assistance.

ADSL is configured on Thomson ADSL router with static IP address. I want to move the ADSL connection to cisco 2801 router and be able to access the router using public static IP address. Router is equiped with HWIC ADSL port.  What config is needed.

3 Replies 3

Francis Garcia
Level 1
Level 1

Hi Melwin,

The configuration will depend on what kind of encapsulation your ISP network is using for terminating the connection, I mean PPPoA or PPPoE. You must speciffy too what is the pvc number that ur ISP is using in the connections, usually it is 8/35 or 0/33 and the last information that we need is how ur isp is assinging u the public IP address, I mean if it is using and PAP (clear username and password) this is for authenticating with the AAA server, or If this is directly assinged to the interface, I say this because I got 2 ADSL lines with diferents ISP and I got to use both methods. Here I send u some samples, just change the X for the convenient value depending ur configuration.

PPPoA using Authentication to receive the public IP address from ur services provider.

!
interface ATM0/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc X/XX

encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0/0
ip address X.X.X.X X.X.X.X
no ip proxy-arp
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
!
interface Dialer0
mtu 1488
ip address negotiated
ip nat outside
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username xxxxxx password xxxxxx

!

dialer-list 1 protocol ip permit

!

ip nat inside source route-map XxXx interface Dialer0 overload

!

route-map XxXx permit 10
match ip address 100
match interface Dialer0

!

access-list 100 permit ip X.X.X.X X.X.X.X any

!

ip route 0.0.0.0 0.0.0.0 dialer 0

!

Using Mac address encapsulation, that is equivalent to aal5snap

!

bridge irb

!
interface ATM1/0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
bridge-group 1
pvc X/XX

encapsulation aal5snap

!
interface BVI1
mtu 1488
ip address X.X.X.X X.X.X.X

no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly

!

ip route 0.0.0.0 0.0.0.0 BVI1 ip-address-of-thenext-hop

!

access-list 100 permit ip X.X.X.X X.X.X.X any

!

ip nat inside source route-map XxXx interface Dialer0 overload

!

route-map XxXx permit 10
match ip address 100
match interface BVI1

!

Post the settings of ur network and the ISP, (PVC, encapsulation type, Internal network settings etc) to build a sample from this.

Regards,

Francis

Thanks

MY ISP settings

PVC1       0/35     LLC/snap      PPPoE


ppp pap sent-username xxxxxx password xxxxxx

the above line should be under dialer 0 or outside

Here you got a sample configuration for your settings. Just adjust the the parameters depending ur cisco's module settings. The pap and is not mandatory, if ur isp is using chap as method of authentication just change it. I don't know if those dns will resolve in ur country, they work fine in most

countries around the world, if u want you can put the dns of ur isp for more security.

!

int ATM0/0
no ip address
dsl operating-mode auto
no sh
pvc 0/35
pppoe-client dial-pool-number 1

!

interface dialer0
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ppp authentication pap
ppp pap sent-username xxxxxx password xxxxxx
dialer pool 1
no sh
!
ip route 0.0.0.0 0.0.0.0 dialer0
!
int f0/0
ip add 192.168.0.254 255.255.255.0
ip nat inside
ip tcp mss-adjust 1452
no sh
!
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
ip nat inside source list 100 interface dialer0 overload
!
!
ip dhcp pool Router
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.254
   dns-server 208.67.220.220 208.67.222.222
!

Regards,

Francis

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card