Nokia N97 and CUCM 6

Unanswered Question
Mar 3rd, 2010

Hi All

Having issues registering the N97 to the CUCM, can anyone point me in the right direction or provide steps neccesary.

Much Appreciated...

Shaun

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
shaunswales Thu, 03/04/2010 - 00:00

Hi Aaron

Thanks for the post. Perhaps I should post what has been configured, maybe it'll help me see where I went wrong by seeing it once all the config is written down.

On the CUCM 6 side:

I have created:

  • SIP Realm:                     sip_africa.enterprise.root
  • Phone Security Profile:     Nokia N97
    • Enable 'Digest Authentication' checkbox
    • Everything else left as default
  • Standard SIP Profile is being used (nothing changed)
  • 3rd Party SIP Device (Basic)
    • Device Configuration
      • Configured MAC Address C038F9E430C2
      • Phone button templete - 3rd Party SIP Device
      • Owner UserID : shaunsw
      • Device Security Profile: Nokia N97 (The one I created)
      • SIP Profile: Standard SIP Profile
      • Digest User: shaunsw
    • Directory Number configuration
      • DN 0621 (my DN)
      • Associated end user: shaunsw

On the Nokia N97:

  • Profile name: CUCM
  • Service Profile: IETF
  • Default Destination: Internet (This has my WiFi at work priority)
  • Access Point in use: None (As destinations are defined)
  • Public user name: sip:[email protected]
  • Use compression: No
  • Registration: Always on
  • Use security: No
  • Proxy Server:
    • Proxy Server Address: sip:172.21.34.163
    • Realm: sip_africa.enterprise.root
    • username: shaunsw
    • Password: xxx (same as digest credentials)
    • Allow loose routing: yes
    • Transport type: auto
    • Port: 5060
  • Registrar Server:
    • Server address: sip:172.21.34.163
    • Realm: sip_africa.enterprise.root
    • username: shaunsw
    • password: xxx (same as digest credentials)
    • Transport type: Auto
    • Port: 5060

I have also tried using public username: sip:[email protected]

Although today the phone just says: Not registered and not registration failed. On CUCM side, state uis Unknown.

Do you think it could be because the realm is not 'ccmsipline'  (CUCM default) on both the SI Phone and the SIP Realm (I don't think it matters if you create your own SIP Realm) - I saw a guy having this issue with his integration on the forum relating to your previous posts.

I'm going to restart the phone now and check again if it works... can you see anything wrong here?

Thanks for the great posts

shaunswales Sun, 03/07/2010 - 23:11

Hi Aaron / NetPro's

I have checked all settings as above and gone through the older post as suggested by you, however still getting registration failed.

Is there something I'm missing? I upgraded to the latest firmware on the N97, in case of a software issue, but as I say I still get the same problem.

Any ideas?

shaunswales Wed, 03/10/2010 - 01:36

Got it Working, everything is the same as above, public username must be your DN (0621) and make sure in the proxy server and registrar server your username (as configured in CUCM ) is exactly as it appears, it is CASE SENSATIVE.

Other than that if you go to service parameters in CUCM you will see the SIP Realm (Even if you configure your own under user management) is set to ccmsipline, so make sure you use this realm when configuring your SIP Phone. You do not need to create one under end user. If you want to change this default ccmsipline change it under service parameters for the publisher server.

Hope this helps everyone else!!!

Actions

This Discussion