Error about Ciscoworks JRM process

Unanswered Question
Mar 3rd, 2010

Hi All,

I just reinitallize my database to get rid of some error message. But still have some issue with my Ciscoworks. My version is CS 3.1.0 Campus Manager 5.0.1. DFM 3.0.1

There is one error at "Job Information Status" in CS tab.

"Exception when getting Job information from  JRM Could not locate the following Object: repository id :  IDL:jrm/JrmServiceManager:1.0 object name : JrmServiceManager_hostname host  name : hostname"

And also I have 3 down processes: CTMJrmServer, DFMCTMStartup, DataPurge

It appears these 3 processes are all related to JRM. I checked my jrm process:

Process= jrm
State  = Running normally
Pid    = 8844
RC     = 0
Signo  = 0
Start  = 3/3/2010 8:21:24 AM
Stop   = Not applicable
Core   = Not applicable
Info   = Server started by admin request

It's working fine.

I checked jrm.log and found there is one error:

[Wed Mar 03 08:54:27 CST 2010] ERROR: CORBAREGISTRY:Unable to connect to ManagerControl object.  Reason: org.omg.CORBA.OBJECT_NOT_EXIST:
  Could not locate the following Object:
     repository id : IDL:manager/ManagerControl:1.0
       object name : ManagerControl
         host name : hostname
  vmcid: 0x0  minor code: 0  completed: No
1267628067371 March 3, 2010 8:54:27 AM jrm hostname Error EDSSY0012: Cannot connect to EDS.

I found one post dealing with this similar issue but they have wrong hostname configured. It appears mine is correct. So not sure why jrm throw this error. Please help!

Thanks a lot!!!


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
hxmengmetro Wed, 03/03/2010 - 07:45

I changed some services to manual start and the job information status error disappear. Right now I have only 2 processes can't be started at boot:

DFMCTMStartup, DataPurge

And the weird thing now is "InCharge" erorr shows up again in Event Viewer. I remember it disappeared after I upgrade DFM and CM to 3.0.1 and 5.0.1. I don't understand why it comes back again now after I adjusted service start mode.

Did anyone have this issue before?



Joe Clarke Wed, 03/03/2010 - 09:15

DFMCTMStartup and DataPurge should be down under normal operation.  If you are not running DFM 3.0.4 or higher, you could see problems with all network-enabled applications on the server.  You will also see these Event Viewer errors.  You need to upgrade to LMS 3.0.1, then move to DFM 3.0.5, and those problems and errors should go away.


This Discussion