Network Switch Trunk Port Config VoIP

Answered Question
Mar 3rd, 2010

I am just getting into VoIP and have a question about trunking with switches. The network I am working on has some different configurations for trunking on different switches. And I don't see why.


Example:


Switch_01

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
queue-set 2
mls qos trust cos
auto qos voip trust


Switch_02:

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk


Access Ports

interface FastEthernet0/1
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
switchport voice vlan 172
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast


Currently changing  switchport mode dynamic desirable to sw mode access, due the 7970 series phones dropping out.


They are both connected the the 6509 and I do not see any reason for the difference. I would like to eventually like to put them on a different Native VLAN.


Do I need the srr-queue, cos and auto qos lines?


What is cos and dscp, and what are the benifits?

Correct Answer by Aaron Harrison about 6 years 11 months ago

Hi


So many questions!


The first config and second config examples are the same, except the first also has QoS configured on it. These configurations are suitable for links between switches, all VLANs will be carried accross as they are configured as trunks.


The third config is an edge port config, but not a great one as you've discovered. In the middle ages it was normal to configure the edge ports as dot1q trunks to allow the phones to get into a different VLAN to the PC that was attached to the phone, but that's not what you would do now. A more suitable port config would be:


int x/x

switchport mode access

switchport access vlan X          <--- whatever VLAN you want for the PC

switchport voice vlan Y          <.--- VLAN for the phone

auto qos voip cisco-phone     <--- see below

spanning-tree portfast                < start the port quickly rather than going through full STP process


In terms of QoS, DSCP, etc... there's lots to know here. If you're new to QoS, set 'auto qos voip cisco-phone' on your edge ports, and 'auto qos voip trust' on all inter-switch links, and then read up on it! There's lots of info on the Cisco web site...


Essentially once you do this you will have a network that runs on CoS markings. CoS is a field in the dot1q or ISL header found on trunk or Voice VLAN enabled interfaces.


DSCP is a field in the IP Header that is more granular, and has the advantage of being present on all IP packets whether traversing a trunk link or not.


There are maps on the switch that will rewrite each of these fields based on configured settings - these settings are applied to the switch the first time that you enter an 'auto qos' command on a port, so you don't have to get too hung up on it for now.


Regards


Aaron


Please rate helpful posts...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Aaron Harrison Wed, 03/03/2010 - 08:01

Hi


So many questions!


The first config and second config examples are the same, except the first also has QoS configured on it. These configurations are suitable for links between switches, all VLANs will be carried accross as they are configured as trunks.


The third config is an edge port config, but not a great one as you've discovered. In the middle ages it was normal to configure the edge ports as dot1q trunks to allow the phones to get into a different VLAN to the PC that was attached to the phone, but that's not what you would do now. A more suitable port config would be:


int x/x

switchport mode access

switchport access vlan X          <--- whatever VLAN you want for the PC

switchport voice vlan Y          <.--- VLAN for the phone

auto qos voip cisco-phone     <--- see below

spanning-tree portfast                < start the port quickly rather than going through full STP process


In terms of QoS, DSCP, etc... there's lots to know here. If you're new to QoS, set 'auto qos voip cisco-phone' on your edge ports, and 'auto qos voip trust' on all inter-switch links, and then read up on it! There's lots of info on the Cisco web site...


Essentially once you do this you will have a network that runs on CoS markings. CoS is a field in the dot1q or ISL header found on trunk or Voice VLAN enabled interfaces.


DSCP is a field in the IP Header that is more granular, and has the advantage of being present on all IP packets whether traversing a trunk link or not.


There are maps on the switch that will rewrite each of these fields based on configured settings - these settings are applied to the switch the first time that you enter an 'auto qos' command on a port, so you don't have to get too hung up on it for now.


Regards


Aaron


Please rate helpful posts...

Actions

This Discussion