Transfer to VM softkey sometimes sends wrong diversion header

Unanswered Question
Mar 3rd, 2010


Customer has a 2851 running 12.4(24)T CME with a CUE module running 3.2.1.  Occasionally when callers are transferred directly to a user's voice mail box via the TransfVM softkey they are automatically being transferred back to the configured operator extension.  The SIP trace of these calls indicates that the diversion header is being set to the site's main 10 digit number, not the extension that is being chosen.  It is not on all calls, but the calls that it does occur on seem to always have this call flow: 

Caller dials main 10 digit number and is sent to AA, caller chooses the operator extension (2000) and the call is answered, caller asks to leave message for user x and is transferred to that user's mailbox via softkey, caller may or may not hear "no mailbox" message (customer not clear on this part) and then receives ringback and has been transferred back to operator extension. 

Other callers with the same call flow will experience no problems,but once the transfer to voice mail fails once for a call all repeated attempts exhibit the same behavior.  I did a search through the bug toolkit but nothing turned up.  Again, the problem seems to be the diversion header.  Has anybody heard of this being a bug?  Or preferably does anyone have suggestions as to what may be causing this?  I can provide detailed call trace if needed but the only flag in the sip messages is that diversion header...



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)


This Discussion