CUPC Softphone Not Working

Unanswered Question
Mar 3rd, 2010

Hi Everyone,

  I am hoping someon can help since I have been beating my head over this...

Everything in my cups integration works fine, IM, Presence Status and Deskphone control.   I have read over and configured a Softphone profile for a CUPC user done all the dirty work and it never gives softphone control....   when I look at the serve health page TFTP.Filename is blank.  I am expecting to see UPCCSTACHOWICZ.cnf.xml here   ...  what do i need to do to make the CUPC client populate and try downloading this...  this is extremely urgent..

Chad

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Wed, 03/03/2010 - 13:39

Hi

As far as I am aware to get softphone working you just need two things:

1) CUPC Device added to CCM as UPCusername (without any punctuation etc).

2) TFTP Server address put in the Personal Communicator settings page in CUPS

Regards

Aaron

Please rate helpful posts...

Chad Stachowicz Wed, 03/03/2010 - 13:55

I know both of these, but this isn't doing the trick, in server health it lists no file name to download, so clearly there is more steps then what was listed.. i ahve gottne this to work mnay times before also...


Chad

htluo Thu, 03/04/2010 - 06:16

I would do a packet capture from CUPC computer.

First step is for CUPC to download config file from TFTP.

If you didn't see CUPC sent out any TFTP request, you should check CUPC logs to see if it got any TFTP address at all.

If you saw "file not found" message from TFTP response, it's probably the devicename was misconfigured (or a TFTP restart is needed from the server).

If you saw TFTP request but no TFTP response.  It might be a network issue.  On Windows XP, you may use tftp command to test:

tftp -i 192.168.1.100 get UPCJDOE.CNF..XML

Second step is for CUPC to register to CUCM as a SIP phone.

If you saw no SIP messages sent to CUCM, it's probably name resolution issue.  In the config file, CUCM was defined as hostname instead of IP address.

If you saw outgoing SIP message to CUCM but no reponse, it might be network issue.  Try telnet to CUCM on port 5060:

telnet 192.168.1.100 5060

If the port was opened but you still got no SIP response, you'll have to look at "Cisco CallManager" logs on CUCM.

Hope this helps!

Michael

http://htluo.blogspot.com

cstachowicz Mon, 03/08/2010 - 15:53

Michael,

   It never tried to connect on TFTP at all, and I hope this screenshot shows what im explaining.  The CUPC Client is not lokoing for UPCCSTACHOWICZ.conf.xml.  As shown here from the server statistics....  any ideas how to get this populating?

Attachment: 
htluo Mon, 03/08/2010 - 16:54

If your are in desk phone mode, CUPC won't try to download the soft phone config file.  What happened when you tried to switch to soft phone mode?

Can you upload the problem report here? (with detailed logging turned on).

Thanks!

Michael

Chad Stachowicz Mon, 03/08/2010 - 17:47

Hello,

   I don't have the option to select a softphone thats the problem.  From my experience you didn't have that ability until it downloaded the conf...

Cheers,

Chad

Chad Stachowicz Mon, 03/08/2010 - 18:05

Just finished upgrading from 7.0(3) base no ES to 7.0(7) and it fixed it up no problem, like a champion..  annnooooyyyying  I even searching for

bugs

htluo Tue, 03/09/2010 - 05:12

Do you have any non-alphabet characters in the user name?  such as dot (.)?

Michael

Chad Stachowicz Tue, 03/09/2010 - 05:22

No I don't tried three users. As I said the problem is the

tftp.filename not being populated nothing more... I'm sure it was a

bug because I saw nothing referncing that file anywhere. Trust me I

found that bug far before I came to netpro

Chad Stachowicz

415-794-8770

Please excuse any mispellings as this message was from my mobile device

On Mar 9, 2010, at 8:08 AM, "htluo"

Actions

This Discussion