Fax Detect Dialing Ephone-DN instead of answering Fax Call (PRI)

Unanswered Question
Mar 3rd, 2010
User Badges:

Hello,


I've bene trying to get the fax detect script working on a UC520 with a PRI. I've managed to get the script to detect an incoming fax call successfully however it seems to be handing off the fax call to the ephone-dn instead of to CUE for processing. If I change my ephone-dn number to something other than the extension being used for the fax call it works perfectly. Here is the config:


fax receive called-subscriber $d$
fax interface-type fax-mail

mta send server 10.1.10.1 port 25
mta send subject Fax from UC500
mta send with-subject both
mta send postmaster uc500@abc.com
mta send mail-from hostname abc.com

!

application
  service fax_detect flash:/bacdprompts/app_fax_detect.2.1.2.3.tcl
  param mode listen-first
  param prompt flash:/bacdprompts/en_Uone_listen-first.au
  !

!

voice translation-rule 41
rule 1 /5551822/ /122/

!

!
voice translation-profile 122_Called_41
translate called 41
!

!
dial-peer voice 3037 pots
description 122
translation-profile incoming 122_Called_41
service fax_detect
incoming called-number 5551822
direct-inward-dial
port 0/3/0:23
!

!
dial-peer voice 4037 mmoip
service fax_on_vfc_onramp_app out-bound
destination-pattern 122
information-type fax
session target mailto:abc@abc.com
!

!
ephone-dn  14  dual-line
number 122 no-reg primary
label Spare Office - 122
description Spare OfficeA
name Spare OfficeA
call-forward busy 299
call-forward noan 299 timeout 10
!


So in short what is happening is a fax call comes in, Fax Detect script answers, plays the prompt "press start on your fax machine, or stay on line for voice call" CNG tone is detected, and then it stats ringing the desk phone and then CFNA to voicemail and leaves a voicemail...


If I change the number on ephone-dn 14 to something unrelated the fax call is handed off to CUE, fax transmission goes through successfully and I get an email with the .tif attachment.


What am i doing wrong here?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Sun, 03/07/2010 - 07:19
User Badges:
  • Blue, 1500 points or more

Can you please add "preference 5" under your ephone-dn and let me know what you get?


Thanks,


Marcos

sferrero2 Tue, 03/09/2010 - 09:14
User Badges:

Adding 'Preference 5' produced no change.


However I did speak with TAC and they recommended using an earlier version of the Fax Detect script as I am possible running into a known defect... They asked me to try app_fax_detect.2.1.2.2.tcl which I did and my first tests seem to be working.


I didn't try re-arranging my dialpeers but I have a suspicion that may have worked as well.


I am going to do some more testing to confirm this is working now.

JOHN NIKOLATOS Mon, 03/08/2010 - 19:08
User Badges:
  • Bronze, 100 points or more

This is because one of your other dial-peers are answering the call first.  I run into this everytime I set up fax.  You have to make sure youre fax dial-peer for fax is near the top of all other dial-peers in the configuration because for some reason they are played top down..

Debug VOICE CCAPI INOUT to see which ones you have to change...and which ones are picking up first.

Actions

This Discussion

Related Content