Cisco 877-M IOS software upgrade

Unanswered Question
Mar 3rd, 2010

I am trying to find the best or right version for my 877-M Modem Router.

Currently the device is running 12.4(11)XJ4.

I need to know what version is best for my device.

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kmccourt Wed, 03/03/2010 - 22:46

The 'best or right version' to do what?

Is it  currently doing what you want it to do?

However, for example:

If you mean the latest IOS  version, there are many later versions available from the software  download section of the Cisco site if you have a Smartnet contract on  the device and a Cisco login.

If you mean with features that you need which are missing from  your current IOS version, use the Cisco feature navigator to compare  your current IOS release with the one you're thinking of upgrading to.

http://tools.cisco.com/ITDIT/CFN/

If you mean with security vulnerabilities fixed, you can check  this link to see if there are any known vulnerabilities in your current  release and what the suggested IOS version to upgrade to is.
http://www.cisco.com/en/US/products/products_security_advisories_listing.html

damienmac Wed, 03/03/2010 - 23:39

Hi,

Thanks for the reply. Yes I should have added a bit more detail to my post.
Our Cisco 877-M is almost 3 years old, it's the DHCP Server and internet connection for an office of 15 staff in a design house. I have been given the honor of getting it working propely. Currently its not functioning correctly, it's not giving out IP addresses to some machines on our network, its listing multiple errors in the log file but its still keeping a constant connection to our ISP (thank god!) so my assesment is that its acting strange

So I thought I would erase the unit, and install a the latest system on it, reconfigure it and hope this fixes the problem.

But I dont want to install the wrong thing on it and turn it into a brick.

So my question is, what version do I install on my particular devices, and where to get it.

Navigating the Cisco website is not easy, I have found the download section but have no idea what to download and finding the right answer for a questions...almost impossible.

Thanks!

kmccourt Thu, 03/04/2010 - 08:41

To get to the IOS download section for the 877, log in at the Cisco homepage and follow:

Support > Download software > Routers > Branch Routers > Cisco 800 Series > Cisco 877 ISR > IOS Software

I believe that Annex-M support was part of the IOS 12.4(11)XJ release and it was then integrated into the 'T' train starting with the release of 12.4.15T so you'll want to use something like 12.4.15T12 or a later version of IOS.

Of course the usual caveats apply: back up your current IOS and config before attempting any of this and make sure you're comfortable with the concepts of upgrading IOS and digging yourself out of a hole.

Actions

This Discussion