ACE module - should 'sh serverfarm' and the SNMP OID 'slbVServerNumberOfConnections' show the same value?

Answered Question
Mar 4th, 2010

I've recently begun to notice that the current connections value displayed by the ACE when using the 'sh serverfarm' command isn't matching up with the value returned by a custom MIB poller I'm using to return the value of the associated 'slbVServerNumberOfConnections' OID when I had assumed that they represented the same thing?

As an example at the moment the ACE is showing 400 current connections for a particular serverfarm but my customer poller is returning 250?

I'd noticed this behaviour whilst the ACE was running software version A2(1.6a) and had hoped that an upgrade to A2(2.3) might fix it but it hasn't - assuming it's a bug as opposed to just my misunderstanding of what value 'slbVServerNumberOfConnections' is actually returning?

Can anyone explain what I'm seeing or am I polling the wrong OID?

Thanks in advance



I have this problem too.
0 votes
Correct Answer by Gilles Dufour about 6 years 7 months ago

What about the 'show conn' ? do you see 400 or 250 concurrent connections ?

What about 'sho service-policy'

The OID refers to the VIP not the serverfarm.

Also the show serverfarm is known to display incorrect information

CSCtc94844: ACE: show serverfarm current connection counter incorrect

The fix will be in A2(2.4)


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
bgfl-tech Fri, 03/05/2010 - 04:43


The current connection value displayed by 'sh service-policy' is the same as the value returned by 'slbVServerNumberOfConnections' so I'm assuming we're suffering from the bug you mentioned where 'sh serverfarm' is displaying an incorrect value.




This Discussion