Separate codec for certain DNs

Unanswered Question
Mar 4th, 2010
User Badges:

Hello Everyone,


I'm running into a situation where I have a user that will be using IP Communicator over a low speed WAN link.  I use the g.711u codec primarily for everything, MoH, IP Phones, etc.  It is just this user (at least for now) that with the speed of their connection g.711u is not good.  I am running CUCM 6.01 and an h.323 gateway (Cisco 3745).  What I'd like to do is to have calls that go out to DN 1007 use the g.729 codec instead, hopefully this will enable him to use IPC with the lower speed.  Any ideas on how I would accomplish such a feat?  I'm sure it will require some modification on both the CUCM side as well as router side.  Thanks for the help.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
fieryhail Thu, 03/04/2010 - 14:55
User Badges:

Thank you for the response, that does appear to work...partially.  But now I am running into the issue of one way audio.  The end user can hear me or other people fine albeit with the lower audio quality expected from using g.729 vs. g.711 but no one can hear him.  No network settings have changed and this artifact only shows up now with the low-bandwidth option selected.  He is connecting via the Cisco VPN client to an EasyVPN server.  The VPN tunnel seems fine and the one-way audio doesn't seem to be present when using the g.711u (normal bandwidth) when he is connected via VPN through either a hardwired or standard wireless link.  I believe it has something to do with the change to a different codec.  Perhaps a codec mismatch issue?  If so, where would I go to solve this?  The h.323 gateway?  I'm still new to this so am unsure, any guidance would be appreciated.  Thanks in advance.

Actions

This Discussion