xconnect not working

Unanswered Question
Mar 4th, 2010
User Badges:
  • Silver, 250 points or more

Hi I am facing issue with configuring xconnect .


I want to configure L3 interface & xconnect in same router. using different physical interface.


Below is the detail :



R1 === > R2 ====> R3


Configured xconnect in R2 & R1.


The Layer 3 interface in configured in R3 & R1


xconnect is configured in R1 with fa0/0 connected to R2

Layer 3 interface in configured with fa1/0


R3 will come to R2 and R2 will encap with l2tpv3 & send it to R1 and in R1 that is bind with fa0/0. But that layer 3 interface in configured in fa1/0 for same to communicate R3.


Please suggest how it will communicate , Here actullay i dont wnat to wast another router next to R1 i.e. R0 , So intead of using R0 i want to configure L3 interface no R1 Itself.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 03/04/2010 - 14:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Chetan,

the xconnect interface has to be at the edge on the two L2 PE routers


>>

xconnect is configured in R1 with fa0/0 connected to R2

Layer 3  interface in configured with fa1/0


R3 will come to R2 and R2 will encap  with l2tpv3


No, this is just a terrible mess


see

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t2/feature/guide/gtl2tpv3.html



you need to do something like


L2 CE ---- xconnect interface --- R1 --- L3 interface ---- R2 --- xconnect --- R3


you need three interfaces on R1, R1 to R2 interface can also be a serial interface.

to avoid to bypass the L2 service put one interface in VRF and connect  it with a cross-over cable to the one with xconnect.


I guess this is just a lab. There is no great sense in doing  this in real world.


Hope to hlep

Giuseppe

Chetan Kumar Ress Fri, 03/05/2010 - 10:47
User Badges:
  • Silver, 250 points or more

Thanks Giuslar For Reply


But i was looking some else.


Please Ignore


Got the solution

judebryant Thu, 03/11/2010 - 13:11
User Badges:

...so share your solution


I would use xconnect via layer2 with layer3 svi.


How did you solve this issue


Regards

Jude Bryant

Pioneer Telephone

Actions

This Discussion

Related Content