SNMP Credentials Change - Must specify sysObjectID/MDF type

Unanswered Question
Mar 5th, 2010

Hi

We are running LMS 3.1 on Windows 2003R2.  I've carried out a change which changes the 'default SNMP Credentials' which we use to carry out our device imports from Cisco ACS.  Also I have changed the SNMP credentials for all the devices from the DCR (approx 1600).  All seems to have gone through ok except for 3 devices which have returned with:

  • Must specify sysObjectID/MDF type

Any ideas on how can I correct this problem ?

Many Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 03/05/2010 - 09:14

To be clear, you're importing a CSV file into DCR, and seeing this error for three of the devices?  If so, exactly what fields in the CSV file are populated for these devices?

dmistry21 Fri, 03/05/2010 - 09:19

What i'm doing is updating the SNMP credentials within the DCR by going to:

  • Common Services -> Device and Credentials -> Device Management -> "selecting All Devices" -> Edit Credentials - and then changing just the SNMP RO Community String.

It takes me through all the steps but gives me the error once clicking Finish.

Joe Clarke Fri, 03/05/2010 - 09:23

What are the three devices that are failing?  Can you provide a DCR export of those devices?

dmistry21 Fri, 03/05/2010 - 09:58

Bit of a mixed bag here looking into them:

I can snmpwalk two of the devices and they are a:

  1. "Cisco IOS Software, C2960 Software (C2960-LANBASE K9-M), Version 12.2(44)SE1, RELEASE SOFTWARE (fc1)
  2. "Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(19b), RELEASE SOFTWARE (fc1)

The other device I cannot snmpwalk to but if it is model/ios dependant, hopefully the above may help if they can be resolved.

Joe Clarke Fri, 03/05/2010 - 09:59

What about the DCR export?  I would need to see the attributes currently in DCR for these devices.

dmistry21 Sun, 03/07/2010 - 06:53

Unfortunately i'm not permitted to provide the DCR export.

I'll try removing the devices from the DCR and try a re-import and see whether I get the same error.

Also I may have to try amending the individual attributes of the devices in the DCR.

Actions

This Discussion