Routing problems on SGE2000 & SGE2000P stack

Unanswered Question
Mar 5th, 2010

Recently we've changed our network routing, and now we're seeing some strange behavior.  Inbound VPN connections can't connect to resources, and it looks like it's because return traffic is being routed incorrectly.

Example:

* Switch has some static IP routes:

     - 0.0.0.0 next hop 10.1.0.3 (Public internet)

     - 10.0.3.0/24 next hop 10.1.0.2 (WAN connection to VPN/firewall)

     - 10.10.10.0 (local)

* VPN client is connected on 10.0.3.3

* VPN client attempts to reach 10.10.10.10, but can't

* Tracert shows that outbound traffic from 10.10.10.x to 10.0.3.3 is being routed out 10.1.0.3 instead of 10.1.0.2

We've seen that 10.10.10.x clients on some ports will use the right route, while others use the wrong one.  This problem has only appeared in the past few days, and the most recent static route changes were a couple of weeks ago.  Rebooting the stack seems to take care of everything for a while, but then it creeps back in.  Assuming it's something to do with the switch's routing algorithm, but I'm not sure if there's anything that can be done to fix it directly.

We're still running firmware v1.0.0.45, and I see that there are v3.x versions available.  Is this a known issue that might be addressed by firmware, or should I be looking for a configuration problem?  Suggestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
alissitz Fri, 03/05/2010 - 20:01

I do not know if this was a known issue ... I have not heard of it. Certainly there have been bugs ... I just have not heard of this one in particular.

The fact that it 'creeps' back is pretty suspicious.

How long does it normally take to 'creep back'?

When the problem occurs, is it isolated to a particular switch or simply random for any port on any switch?

Devices 10.1.0.2 and 10.1.0.3 - are these sharing the same mac?  HSRP type of install ... and perhaps a failover event proceeds this routing confusion.

For sure I would suggest an upgrade to the latest code, and I think you will like the improved gui.  Kindest regards,

Andrew Lissitz