CUPC Desk Phone Control Issue

Answered Question
Mar 5th, 2010

I am struggling with getting Desk phone working.  I have done everything that is recommended except for changing the Ldap port on the CCM.  I have changed the port on the CUPS to the global catalog.  I have restarted the CTI Manager on all CCM's and I have changed the CTI Timer to 300 and restarted the services again.  I have done my best to verify that the user/phone is allowed for CTI access.  I can use the click to dial application without issue so I would expect the phone and user to be configured correctly.  Soft phone controll works with out issue.  After changing to timer I do see (on occasion) the Server Health respond that Desk Phone (CTI) is working and it has my device listed...but when I attempt to change to that device I go into disabled immediately.  If the solution is to change the CCM Ldap port what issue could that cause for my CCM users/directory listings?

TIA,

Thanks,

Joe

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 6 years 9 months ago

Hi Joe

Well - all I can tell you is that if I set my photo attribute to http://x.x.x.x/%%uid%%.jpeg, CUPC doesn't request anything.

If I set it to sAMAccountName, it requests jpegs for each of the people in my contact list at startup.

I can only presume that CUPS server itself is doing something a little more intelligent...

Have a look at your uid property in AD, if it's blank, then why use it?

It's in the manual:

Fetching Contact Pictures from a Web Server

You can configure a parameterized URL in the Photo field in the LDAP attribute map in Cisco Unified Presence Administration so that Cisco Unified Personal Communicator can fetch pictures from a web server instead of from the LDAP server.

Before You Begin

Use %%uid%% as the substitution string.

You can use any LDAP attribute whose query value contains a piece of data that uniquely identifies the photo of the user. For example:

http://wwwin.cisco.com/photo/std/%%uid%%.jpg

http://wwwin.cisco.com/photo/std/%%sAMAccountName%%.jpg (for ActiveDirectory)

The double percent symbols are required, and they must enclose the name of the LDAP attribute to substitute.

Regards

Aaron

Please rate helpful posts...

Correct Answer by htluo about 6 years 9 months ago

So we back to square one. 

The fix is very simple:

1) Change LDAP authentication to use GC (port 3268).

2) Restart CTIManager

Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.6 (19 ratings)
Loading.
Aaron Harrison Fri, 03/05/2010 - 06:41

Hi

Click-2-Dial Widget basically piggy backs on the WebDialer service, so that working isn't really comparable to CUPC desk phone mode - with CUPC, the actual CTI is CTIQBE from CUPC direct to the CCM CTI service, using the users credentials. Click-2-Dial goes vai the webdialer that uses different servers.

So - my checklist:

1) User is added to 'Standard CTI Enabled' group in CCM

2) User is associated to either the physical desk phone (i.e. the SEPxxx device) or the EM Profile

3) User has the 'Primary Extension' set to a valid line - this tells CUPC to try to control that line

4) Allow Control of Device via CTI is checked on the user account, and on the physical phone

5) In CUPS admin, the user is set to a CTI profile that includes the correct servers

Regards

Aaron

Please rate helpful posts...    

htluo Fri, 03/05/2010 - 06:44

Using Global Catalog (GC) port for LDAP authentication is recommended by Cisco.  Because GC port doesn't have to do LDAP referral thus provide better response time on authenticaiton.

Chaing authentication port on CUCM won't cause any outgage (you're just making it better).  However, for the change to take effect, you'll have to restart Cisco Tomcat service (on CUCM and CUPS).  During restart, all web-related service would be impacted, including:

  • Web page navigation (CCMAdmin or CCMUser)
  • Extension Mobility Login
  • Phone Directory lookup

Voice services (phone calls) are not affected.

Michael

http://htluo.blogspot.com

Aaron Harrison Fri, 03/05/2010 - 06:47

Hi

LDAP is used in CUPC for directory lookups and searches.. nothing to do with deskphone control as far as I recall.

Regards

Aaron

htluo Fri, 03/05/2010 - 07:03

It depends on which LDAP you're talking about.

If you're talking CUPS > Application > Cisco Unified Personal Communicator > LDAP.  That's for contact search only.

If you're talking CUCM > System > LDAP > LDAP Authentication.  It plays an important role on CUPC desk phone control.

Michael

Aaron Harrison Fri, 03/05/2010 - 07:11

Well - yeah, it authenticates the user. So it auths at login, and it auths the CTI control request... as he's logged in, it must be OK.

So it's down to the user/device config...right?

htluo Fri, 03/05/2010 - 07:22

If it was that simple, there wouldn't be so many desk phone control issues. 

When the user logs in, CUPC authenticates via SOAP protocol, which based on HTTP.  In the background, any HTTP authentication would trigger Java authenticate module, which is more tolerent to LDAP referral and timeout.

When the user tries to get desk phone control, CUPC authenticates via CTI protocol.  In the background, CTIManager would trigger the C++ authenticate module, which is very sensitive to LDAP referral and timeout.

Michael

joeharb Fri, 03/05/2010 - 07:34

Ok so I have made the port change on the Ldap in CCM and restarted Tomcat on all CCUM servers as well as the CUP server.  Desk Phone shows connected but I still can't switch to it.  Clicking on Desk Phone never changes the state, stays @ a disable.

Thanks,

Joe

joeharb Fri, 03/05/2010 - 12:56

Ok, I am still having issues with this...Still can't switch to Desk Phone mode but when I go offhook on the desk phone the personal communicator states phone is off hook.  I can switch to soft phone without issue and place calls.  I don't know if it matters but this is a lab install with the demo license.  Another thing that I have noticed is that the users on the CUP server all show that they are licensed for both presence and cupc.  In the CCM I only have 1 user licensed.  I am trying to get this going so I can do a demo for Brass.

Thanks,

Joe

htluo Fri, 03/05/2010 - 13:17

When CUPS is on demo license, it'll automatically license every user.  That's by designed.

For the desk phone issue, could you upload some screenshots?

Thanks!

Michael

htluo Fri, 03/05/2010 - 15:01

I would like to see the "problem".  From the screenshots you attached, I don't see any problem with desk phone (it doesn't mean there's no problem.  I'm just not able to see it from the screenshot).

Could you capture some screenshot of the problem?  And could you enable detailed logging from CUPC > Help?

Once you created the problem, you may create a problem report from CUPC > Help.

Upload the screenshot and problem report here.

Thanks!

Michael

Aaron Harrison Sat, 03/06/2010 - 02:06

Hi Joe

It can be quite confusing to work out why some things appear to work, and some don't.. so:

- 'On the phone' status - this is actually signalled over the SIP trunk to CUPS (usually via the PUBLISH trunk, based on the user being linked to the line appearance) so it's not related to the way the desk phone control works

- Softphone mode - this pulls a config from TFTP, and registers as a SIP phone - again, not using any CTI type functions really.

Are you using EM? I've seen on a few occasions that when initially setting these systems up the Desk Phone refuses to play until the EM phone has been logged out and in again..

Since you only have problems with the Desk Phone stuff, you could get the TSP downloaded from your CCM, install it on a PC, and configure it using the user's credentials. Once you've restarted, get the Julmar phone.exe, and use that to see if you can control your deskphone. That will prove you have that side of things correctly configured.

Regards

Aaron

joeharb Mon, 03/08/2010 - 05:51

Here is the Problem report and a few screen shots.  Notice that the "choose phone to control" is grayed out.  I attempted to changed to desk phone @ 7:45 this morning.

Aaron I will try your suggestions this morning for verifying the connection between the application and ccm.

Thanks,

Joe

htluo Mon, 03/08/2010 - 06:17

1) Which server SEP001EF7C34D9F is registered with?

2) Under CUCM > User Management > End User > joe.harbison > Device Association.  Is SEP001EF7C34D9F the only device associated?  If not, could you remove other devices and leave SEP001EF7C34D9F there?

Thanks!

Michael

http://htluo.blogspot.com

joeharb Mon, 03/08/2010 - 06:31

SEP001EF7C34D9F is registered with 10.2.17.11 ...and I have removed all other devices from user and shutdown cupc and still recieve the same results.Please see attached screen shot of user setup.  What I think is odd is that I don't see any devices I can control.

Thanks,

Joe

htluo Mon, 03/08/2010 - 06:55

Could you do the following?

1) Go to CUCM Admin page > Unified Serviceability > Tools > Control Center - Feature Services.

2) Choose 10.2.17.11 from the drop down.

3) Look for "Cisco CTIManager".  Look at the column "Up Time".

How long the service has been up?

Thanks!

Michael

joeharb Mon, 03/08/2010 - 06:59

Cisco CTIManagerStartedActivatedFri Mar  5 07:37:00 20103 days 01:20:35

I restarted all of the CTI Managers on all the CCM servers on Friday.

I am trying to use the software that Aaron sugested and have noticed that the TSP UI can't download the locale from the publisher...could this be an issue?

Thanks,

Joe

joeharb Mon, 03/08/2010 - 09:15

All,

I am also having trouble getting the phone.exe to work to verify the TSP/CTI configuration..I get a tftp error and debugging tftp give the error:

03/08/2010 09:13:50.055 TFTP|   CReqContext::tftp[0x9a84d00~0~200.0.11.144~1644] File[tsplocalechecksum] not found|

When I open phone.exe I don't see the callmanager tsp as a device.

This is getting better and better...

Joe

Attachment: 
Aaron Harrison Mon, 03/08/2010 - 09:39

Hi Joe

TSP is looking for Locale files on your CCM, but I don't believe it's mandatory for you to have them - I would leave your TFTP fields blank in the TSP config.

If you don't see any 'Cisco Line:' rows in the 'Device' field in the phone.exe program, then take a look at the TSP logs (C:\temp\Ciscotsp001Log) to see whether errors are being logged...

Regards

Aaron

joeharb Tue, 03/09/2010 - 07:49

I am still having the same issues.  I have removed the Standard CTI Enabled from the user and reapplied it but this made no difference.  Would detailed debugging of the CTI Manager help?  Attached is the latest TSP log file.  I have also searched for any bugs related to this but can't find anything.  I know in previous versions of CCM you had to have a jtapi user..is this the case in UCM 7.X?  We have a an ac application user, should I assoicate the phone that the user is trying to control to that application user?  I am starting to get more pressure on getting this installed so we can demo it the vp's.  Anyone have any suggestions on what the issue may be?

Thanks,

Joe

Aaron Harrison Tue, 03/09/2010 - 09:35

Hi

Looks like the connection attempt is timing out:

03/09/2010 09:37:13.359 CiscoTSP001.tsp|   CSelsiusTSPUIMsgGetInfo::ReadTimerSettingValuesFromRegistry() ProviderOpen Synchronous message timeout 50000|


....

03/09/2010 09:38:03.500 CiscoTSP001.tsp|   CQBEHelperBase::ProviderOpen() *ERROR* TSP Timed out waiting for synchronous message.  Check the Provider Open Completed Timeout and the Synchronous Message Timeout in TSP configuration.|

Try increasing the 'Provider Open Timeout' on the TSP Advanced properties... you can up it to 900 or so I think from the default of 50 seconds.

Did you verify that you have checked 'Allow control of CTI' enabled on the handset, as well as on the user account (important when using EM)?

Also, in response to your queries:

ac = this user is only applicable to the Attendant Console

JTAPI user = could be anything, but typically refers to the user that allows control of the CTI RPs/CTI Ports for UCCX.

Neither of these are relevant, as the CTI session is authenticated using the actual user's account.

Regards

Aaron

joeharb Tue, 03/09/2010 - 10:26

Ok I set the timer to 900 and it worked...Should I attempt to lower this and make sure it will work is this value fine?  How does this correspond the cupc if I am still having the same deskphone issues?  Is there a similar timer in the cupc/cups configuration?

Thanks for all you help,

Joe

Aaron Harrison Tue, 03/09/2010 - 10:39

Hi

I'm not aware of a comparable timer in CUPC - normally you only have to set that when you have a large number of controllable devices and it takes a while to open them.

Just to go back to Micheal's earlier post - did you modify the LDAP Authentication port in CCM?

Are you sure that all the servers listed for LDAP Auth in CCM are GCs?

What you need to do is reduce whatever is causing this setup delay so that it responds quick enough for CUPC - 900 seconds is a long time, and longer than users will wait before randomly clicking on stuff or phoning you...

Perhaps pull the CTI logs from the CCM server...

Aaron

joeharb Tue, 03/09/2010 - 11:15

Ok..I found one issue..I didn't change the authenication portion of LDAP, I only changed the directory ports...this has been changed and I have restarted tomcast on all server (cucm and presence) but I still have the same issue.  I have verified with our AD group that the ldap servers I am pointing to are correct and that the GC port is 3268.  I assume a restart of CTIManager is not needed for this change?  Would you recommend changing the debuging on the cti to be more detailed or would that impact the ccm enviroment?

Thanks,

Joe

Correct Answer
htluo Tue, 03/09/2010 - 11:18

So we back to square one. 

The fix is very simple:

1) Change LDAP authentication to use GC (port 3268).

2) Restart CTIManager

Michael

joeharb Wed, 03/10/2010 - 06:09

Ok that did it..I apprecieate all you help..got another quick question for you guys...I have the Presence Photo Parameter set and I can see the image in the presence viewer but I don't see anything in cupc, should I?  Is there a way to allow the cupc to pull the image from the server?

Thanks,

Joe

Aaron Harrison Wed, 03/10/2010 - 06:14

Hi Joe

As I recall there was a gotcha with the LDAP setup - if you use a GC for the LDAP server (i.e. port 3268) then it doesn't have the photos as part of the global catalog.

Did you specify 3268 as the LDAP port in the LDAP Server config in Presence Server (in the CUPC settings)?

The delay you had in auth was from the CTIManager, so you may be able to point CUPC at the standard non-GC domain controller for these lookups, whilst leaving CCM pointed at the GC.

Regards

Aaron

Please rate helpful posts...

joeharb Wed, 03/10/2010 - 06:28

Yes, I understand about the GC port and LDAP.  I have a web server that has the images and I have pointed the Presence Service Paramter

to it with %%uid%%.  I can see the image in the CUCS Presence viewer but it doesn't show up in the CUPC.

Thanks,

Joe

joeharb Wed, 03/10/2010 - 08:39

I am using AD and it appears to be working fine...what I am confused about is I see the image of the user in the Presence viewer on the

CUP Server.  That tells me that the image and the users are working together.  My question is how the client pulls these images?  I get the default blank image when I attempt to call someone that has an image.  I don't see their image in the contact details either under cupc.

Thanks,

Joe

Correct Answer
Aaron Harrison Wed, 03/10/2010 - 08:45

Hi Joe

Well - all I can tell you is that if I set my photo attribute to http://x.x.x.x/%%uid%%.jpeg, CUPC doesn't request anything.

If I set it to sAMAccountName, it requests jpegs for each of the people in my contact list at startup.

I can only presume that CUPS server itself is doing something a little more intelligent...

Have a look at your uid property in AD, if it's blank, then why use it?

It's in the manual:

Fetching Contact Pictures from a Web Server

You can configure a parameterized URL in the Photo field in the LDAP attribute map in Cisco Unified Presence Administration so that Cisco Unified Personal Communicator can fetch pictures from a web server instead of from the LDAP server.

Before You Begin

Use %%uid%% as the substitution string.

You can use any LDAP attribute whose query value contains a piece of data that uniquely identifies the photo of the user. For example:

http://wwwin.cisco.com/photo/std/%%uid%%.jpg

http://wwwin.cisco.com/photo/std/%%sAMAccountName%%.jpg (for ActiveDirectory)

The double percent symbols are required, and they must enclose the name of the LDAP attribute to substitute.

Regards

Aaron

Please rate helpful posts...

joeharb Wed, 03/10/2010 - 09:31

Again this was an oversite on my part..I was edited the Presence Server Parameter, no the LDAP attribute.  I think everyone for you help and I have rated the posts.

Thanks,

Joe

navdipatwal Thu, 06/28/2012 - 08:39

Hi there,

I have a similar issue with CUPS 8.6 and Deskphone mode usage for Jabber, I cant use my Deksphone as action takes too long and fails.

The debugs I have show directory authentication failure:

2012-06-28 13:13:56,961 WARN  [0x00001148] [src\deskphoneprovider\phonelog.cpp(38)] [csf.ecc] [prepareFor2GLogger] - ProviderOpen failed: reason: 0x8ccc0060, Directory login failed - authentication failed.

We are using AD LDS with CUCM with SSL Port 636.

How would be the best way to change this to work and which services would need to be restarted on CUCM and CUPS?

Actions

This Discussion