WRVS4400N Diag/Power LEDs blinking

Unanswered Question
Mar 5th, 2010


Recently tried to update firmware on our WRVS4400N (v1) router (from WRVS4400N_V1.0_V1.1_Firmware.zip), and ended up with router alternatively blinking the red Diag and the Power LEDs...

Googled the whole thing...and tried resetting the router (power off / on....reset button help for 60 secs +, etc)...pretty much everything most people were suggesting (including this page on the Cisco FAQ for the WRVS4400N: http://www.cisco.com/en/US/products/ps9923/products_qanda_item09186a0080a358b9.shtml - including trying with the LAN adapter speed set manually to 10Mpbs/Half-Duplex, w/Static IP address), and absolutely nothing.

So, a couple of questions:

1) Any other suggestions of what I could do...

and assuming that answer to 1 is No - what are my options?  Router was bought nearly 3 years ago from a Reseller (NCIX, in Canada)...

Trying to find the information on the warranty - getting different answer - although I did see 3 yrs somewhere...can I just call in and RMA it?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
lifennel Fri, 03/05/2010 - 10:11

Good afternoon,

The Small Business Routers typically come with three years of hardware support, including the ability to RMA if thorough troubleshooting proves the device to be faulty. However, if the tools we use determine that, based on your serial number, the product is no longer within that period, you may have to furnish a Proof of Purchase to verify entitlement.

I would highly suggest going ahead and contacting us at 1-866-606-1866 (US and Canada) with the serial number and a Cisco.com user ID so we can create you a case and troublshoot your router if it falls within the warranty period.

Thank you,



This Discussion