Strange problem on NPE-G1 Gigabiteth tx_underflow

Unanswered Question
Mar 5th, 2010

Hello all,

i have a 7206VXR NPE-G1 (IOS 12.4(18)) fitted with 2xPA-A3-OC3MM, 1xPA-A3-OC3SMI and 1xPA-A3-E3. I'm terminating DSL customers using Gi0/2 for uplink.

The Gigabit port is simply configured:

interface GigabitEthernet0/2
ip address
duplex auto
speed auto
media-type rj45
negotiation auto

The other end is connected to a Cisco 2960G with identical port configuration.

Sometimes the interface starts to behave badly and output errors counter starts to increase without any apparent reason. If i do a show controller, i see that the errors are due to tx_underflow. What's is strange is that if i cycle down/up any of the ATM interfaces, the problem disappears and come back later (30 mins to 7 hours). I see no errors on the 2960G port. I'm unsure if this could be an IOS bug or a bad hardware, i tried changing port to Gi0/1 but had the same results. Any hint?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Giuseppe Larosa Fri, 03/05/2010 - 13:36

Hello Simone,

so you have 3 STM-1 ATM links and one ATM E3 on this C7200?

I'm afraid it is too much for it.

I remember other threads where poor performances between POS or ATM port adapters and built in GE ports on C7200 NPE-G1 or NPE-G2 have been reported.

That is the performance between GE ports of NPE-G1 are better then the case where traffic goes between GE ports and WAN port adapters

your case is worse because the system is not behaving correctly.

Hope to help


simone.barbarella Fri, 03/05/2010 - 14:48

To Reza: i haven't tried it yet.. i think that would be my next step

To giuslar: that interface (Gi0/2) carries about 200Mbps IN and 80Mbps OUT in peak traffic times. I have the same setup on a NPE-G2 and never had any problem. I tought about possibly poor performance problems, but since the setup is inside "bandwidth points" limit i hoped that the 7206 could support the traffic. Do you advice me to split the setup adding another 7206?


Giuseppe Larosa Fri, 03/05/2010 - 15:01

Hello Simone,

before adding a new C7206 I would try to connect both gigabit ports to two different backbone vlans to have two equal cost paths towards core.

Changing the cable as suggested by Reza is always a wise step.

Hope to help



This Discussion