cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
447
Views
5
Helpful
1
Replies

QOS question

muca
Level 3
Level 3

Hello,

I am new to QOS configurations. I have to configure QOS on  few routers. The set up is basically simple, most sites have 5 Mbps and I just need to reserve 1 Mbps for voice, all other traffic goes to class-default queue. I've done the following configuration on the router. Can anyone tell me if it's ok and if it will work in case I of congestion?

Thanks

class-map match-any voice-out
match access-group name real-time

policy-map qos-policy
class voice-out
    priority 1000

interface GigabitEthernet0/0
bandwidth 5000
ip address 172.29.157.3 255.255.255.128
shutdown
duplex auto
speed auto
no cdp enable
service-policy output qos-policy

ip access-list extended real-time
remark rtp
permit udp any any range 16384 32767
remark SCCP
permit tcp any any range 2000 2002
permit tcp any range 2000 2002 any
remark h323
permit tcp any any eq 1720
permit tcp any eq 1720 any

1 Reply 1

Ganesh Hariharan
VIP Alumni
VIP Alumni

Hello,

I am new to QOS configurations. I have to configure QOS on  few routers. The set up is basically simple, most sites have 5 Mbps and I just need to reserve 1 Mbps for voice, all other traffic goes to class-default queue. I've done the following configuration on the router. Can anyone tell me if it's ok and if it will work in case I of congestion?

Thanks

class-map match-any voice-out
match access-group name real-time

policy-map qos-policy
class voice-out
    priority 1000

interface GigabitEthernet0/0
bandwidth 5000
ip address 172.29.157.3 255.255.255.128
shutdown
duplex auto
speed auto
no cdp enable
service-policy output qos-policy

ip access-list extended real-time
remark rtp
permit udp any any range 16384 32767
remark SCCP
permit tcp any any range 2000 2002
permit tcp any range 2000 2002 any
remark h323
permit tcp any any eq 1720
permit tcp any eq 1720 any

Hi Muca,

As per the configuration it should work as class map is created with acl for voice ports and same is applied with policy map,just for information difference between bandwidth and pirority in qos isdescribed below so that you can use as per your convienent.

Bandwidth command as the "amount of bandwidth, in kbps, to be assigned to the class.To specify or modify the bandwidth allocated for a class belonging to a policy map." The bandwidth command provides a minimum bandwidth guarantee during congestion.

Priority command as       reserving "a priority queue with a specified amount of available bandwidth for  traffic, During congestion conditions, the traffic class is guaranteed bandwidth equal to the specified rate. (Recall that bandwidth guarantees are only an issue when an interface is congested.) In other words, the priority command provides a minimum bandwidth guarantee.

Hope to Help !!

Ganesh.H

Review Cisco Networking products for a $25 gift card