GATEKEEPER CALLS FROM UCM TO CME

Unanswered Question
Mar 8th, 2010
User Badges:

Hello All,


I want to make a call from the UCM to the CME through a gatekeeper.


I must use the same tech prefix for the UCM and the CME. Calls from the UCM to CME never works. when i dial it rings on the CME phones and disconnects


Below is the config on the Gatekeeper

Q-RTR#  sh run
Building configuration...


Current configuration : 4260 bytes
!
! Last configuration change at 11:23:51 pst Sat Mar 6 2010
! NVRAM config last updated at 11:23:42 pst Sat Mar 6 2010
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ-RTR
!
boot-start-marker
warm-reboot
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
memory-size iomem 20
clock timezone pst -8
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
dot11 syslog
no ip source-route
!
!
ip cef
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
isdn switch-type primary-ni
!
voice-card 0
no dspfarm
dsp services dspfarm
!
!
!        
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
archive
log config
  hidekeys
!
!
!
!
controller T1 0/0/0
framing esf
linecode ami
pri-group timeslots 1-3,24 service mgcp
!
controller T1 0/0/1
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
!        
!
!
!
interface Loopback0
ip address 10.10.110.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex full
speed 100
ip rsvp bandwidth
!
interface FastEthernet0/0.10
encapsulation dot1Q 10 native
ip address 10.10.100.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.10.200.3 255.255.255.0
ip helper-address 10.10.210.10
!        
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.10.210.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
interface Serial0/0/1:0
no ip address
encapsulation frame-relay
fair-queue 64 256 36
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial0/0/1:0.1 point-to-point
ip address 10.10.111.1 255.255.255.0
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 201  
!
interface Serial0/0/1:0.2 point-to-point
ip address 10.10.112.1 255.255.255.0
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 202  
!
router ospf 1
router-id 10.10.100.1
log-adjacency-changes
network 10.10.0.0 0.0.255.255 area 0
!        
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
!
!
voice-port 0/0/0:23
!
ccm-manager switchback immediate
ccm-manager fallback-mgcp
ccm-manager redundant-host 10.10.210.10
ccm-manager mgcp
ccm-manager music-on-hold
!
mgcp
mgcp call-agent 10.10.210.11 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp bind control source-interface FastEthernet0/0.20
mgcp bind media source-interface FastEthernet0/0.20
!
mgcp profile default
!
sccp local FastEthernet0/0.20
sccp ccm 10.10.210.10 identifier 2 version 5.0.1
sccp ccm 10.10.210.11 identifier 1 version 5.0.1
sccp
!
sccp ccm group 1
bind interface FastEthernet0/0.20
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 1 register hqtranscoder
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 2
associate application SCCP
!
!
!
!
!
gatekeeper
zone local UCM 10.10.110.1
zone prefix UCM 1* gw-priority 10 gk-trunk_2
zone prefix UCM 1* gw-priority 9 gk-trunk_1
zone prefix UCM 1* gw-priority 0 UCME
zone prefix UCM 3* gw-priority 10 UCME
zone prefix UCM 3* gw-priority 0 gk-trunk_1 gk-trunk_2
zone prefix UCM 5* gw-priority 10 gk-trunk_2
zone prefix UCM 5* gw-priority 9 gk-trunk_1
zone prefix UCM 5* gw-priority 0 UCME
bandwidth total zone UCM 128
no shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
length 0
transport preferred none
transport input telnet
line vty 5 15
exec-timeout 0 0
privilege level 15
logging synchronous
no login
transport preferred none
transport input telnet
!
scheduler allocate 20000 1000
ntp clock-period 17179602
ntp server 10.10.100.2
!
end


Below is the config on the CME router


Current configuration : 5763 bytes
!
! Last configuration change at 19:31:51 gmt Sat Mar 6 2010
! NVRAM config last updated at 19:28:44 gmt Sat Mar 6 2010
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BR2-RTR
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.124-22.T.bin
warm-reboot
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
!
no aaa new-model
memory-size iomem 20
clock timezone gmt 0
clock summer-time CET recurring 1 Sun Apr 1:00 last Sun Oct 1:00
network-clock-participate wic 0
no network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 10.10.202.1 10.10.202.49
ip dhcp excluded-address 10.10.202.70 10.10.202.254
!
ip dhcp pool br2
   network 10.10.202.0 255.255.255.0
   option 150 ip 10.10.202.1
   default-router 10.10.202.1
!
!        
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
  registrar server expires max 600 min 60
!
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
!
voice register global
mode cme
source-address 10.10.110.3 port 5060
max-dn 3
max-pool 6
authenticate register
mwi reg-e164
voicemail 3600
tftp-path flash:
create profile sync 0002817099534509
ntp-server 10.10.100.2 mode unicast
!
voice register dn  1
number 3002
call-forward b2bua busy 3600 
call-forward b2bua mailbox 3002 
call-forward b2bua noan 3600 timeout 12
name br2 phone 2
no-reg
label br2 phone 2
mwi
!
voice register pool  1
id mac 1111.1111.1111
type 7941
number 1 dn 1
dtmf-relay rtp-nte
username 3002 password cisco
codec g711ulaw
!
!
voice translation-rule 1
rule 1 /3545623/ /3/
rule 2 /5623/ /3/
rule 3 /\+3545623/ /3/
!
voice translation-rule 2
rule 1 /^1#\(3...$\)/ /\1/
!
!
voice translation-profile GK
translate called 2
!
voice translation-profile IN
translate called 1
!        
!
voice-card 0
!
!
!
!
!
archive
log config
  hidekeys
!
!
controller E1 0/0/0
pri-group timeslots 1-3,16
!
controller T1 0/1/0
channel-group 0 timeslots 1-24
!
!
!
!        
!
interface Loopback0
ip address 10.10.110.3 255.255.255.255
ip ospf network point-to-point
h323-gateway voip interface
h323-gateway voip id UCM ipaddr 10.10.110.1 1719
h323-gateway voip h323-id UCME
h323-gateway voip tech-prefix 1#
h323-gateway voip bind srcaddr 10.10.110.3
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/3/0
switchport trunk native vlan 200
switchport mode trunk
switchport voice vlan 400
!
interface FastEthernet0/3/1
shutdown
!
interface FastEthernet0/3/2
shutdown
!
interface FastEthernet0/3/3
shutdown
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn outgoing display-ie
no cdp enable
!
interface Serial0/1/0:0
no ip address
encapsulation frame-relay IETF
no fair-queue
frame-relay lmi-type ansi
!
interface Serial0/1/0:0.1 point-to-point
ip address 10.10.112.2 255.255.255.0
ip ospf mtu-ignore
snmp trap link-status
frame-relay interface-dlci 102  
!
interface Vlan1
no ip address
!        
interface Vlan200
ip address 10.10.102.1 255.255.255.0
!
interface Vlan400
ip address 10.10.202.1 255.255.255.0
!
router ospf 1
router-id 10.10.202.1
log-adjacency-changes
network 10.10.0.0 0.0.255.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!        
control-plane
!
!
!
voice-port 0/0/0:15
translation-profile incoming IN
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
dial-peer voice 100 pots
incoming called-number .
direct-inward-dial
!
dial-peer voice 200 voip
huntstop
max-conn 1
destination-pattern 3600
session protocol sipv2
session target ipv4:10.10.210.13
dtmf-relay rtp-nte
codec g711ulaw
!

dial-peer voice 300 voip
destination-pattern [15]...
session target ras
dtmf-relay h245-a
no vad
voice-class codec 1


dial-peer voice 400 voip
translation-profile incoming GK
voice-class codec 1
incoming called-number 1#3...
dtmf-relay h245-alphanumeric
no vad
!
!
gateway
timer receive-rtp 1200
!
sip-ua
mwi-server ipv4:10.10.210.13 expires 3600 port 5060 transport udp unsolicited
!
!
telephony-service
em logout 0:0 0:0 0:0
max-ephones 8
max-dn 8
ip source-address 10.10.202.1 port 2000
voicemail 3600
mwi reg-e164
max-conferences 8 gain -6
transfer-system full-consult
transfer-pattern .T
create cnf-files version-stamp 7960 Mar 06 2010 15:19:43
!
!
ephone-dn  1  dual-line
number 3001 no-reg primary
label Br2 pHone 1
name Br2 Phone 1
call-forward busy 3600
call-forward noan 3600 timeout 12
!
!
ephone-dn  2
number 3600 no-reg primary
!
!
ephone-dn  3
number A01 no-reg primary
!
!
ephone-dn  4
number 1998 secondary 1999 no-reg both
mwi on-off
!
!
ephone  1
mac-address 001E.EC15.996D
type CIPC
button  1:1
!
!
!
ephone  2
!        
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line 194
no activation-character
no exec
transport preferred none
transport input all
transport output all
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
no login
transport preferred none
transport input telnet
line vty 5 15
exec-timeout 0 0
privilege level 15
logging synchronous
no login
transport preferred none
transport input telnet
!
scheduler allocate 20000 1000
ntp server 10.10.100.2
end

BR2-RTR#$     




I really need support to fix this

Thanks for the anticipated cooperation

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Hythim Ali El Hadad Sun, 03/14/2010 - 01:42
User Badges:
  • Silver, 250 points or more

Hi,


The first thing I noticed in your configuration is:



gatekeeper
zone local UCM 10.10.110.1

&



interface Loopback0
h323-gateway voip h323-id UCME



You should specify a domain including both the gateway and the GK


So it should be like:


gatekeeper
zone local UCM cisco.com


interface Loopback0
h323-gateway voip h323-id [email protected]




then issue " sh gatekeeper endpoints" you should find the CME phones registered to the GK



wish this be helpful



Thanks

Actions

This Discussion