SA520 Load Balancing Problems

Unanswered Question
Mar 9th, 2010

Hi,


we've got an SA520 with activated Load Balancing for two ISP's on the two WAN ports. Both WAN ports are showing "WAN status UP".


The problem is, that every connection stalls after a few minutes (for example a download, a web radio live stream or an PPTP VPN connection). It seems that the load balancing is switching the lines permanently for all sessions, which doesn't make any sense. How can I configure an session based load balancing without binding protocols on a special WAN port?


Best Regards, Klaus

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tiya Rabb Thu, 03/18/2010 - 10:25

Hello Klaus,


Thank you so much for your inquiry.

It seems that the load balancing is switching the lines permanently for
all sessions, which doesn't make any sense.

With Load Balancing enabled, pacekts traverse through the gateway in a manner that has no initial regard to protocol assignment to a specific WAN port. After the SA learns the routes to destination networks, it uses the route that is best, usually the shortest. The router will automatically switch back and forth, literally balancing the load, based on packet amount, with no regard to protocols.


How can I configure an
session based load balancing without binding protocols on a special WAN
port?


That said, protocol binding is neccessary in order to direct the traffic, based on protocol assigment, in a specified manner. The nature of Load Balancing requires protocol binding in order to prevent a protocol, even HTTP, from jumping WAN ports. I hope this helps!

Actions

This Discussion

Related Content