cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3225
Views
0
Helpful
1
Replies

Cisco 1841 QOS For VOIP

sidd
Level 1
Level 1

Hello,

   I guess this has been asked in past, but I need some help. I was suggested that we use following config. I want to know, your opinion, before I install this 1841

   So we have 2 megabits/sec (up&down) leased line and we want to allocate 1mbps for VOIP.

Thanks!

-------------------------------------------------------------------------------------------------------------------------------------------------

class-map match-any VOIP_C
match access-group name RTP
match access-group name SIP
!
!
policy-map SHAPE-TO-LAN
class VOIP_C
  bandwidth 1024
class class-default
  shape average 1024000
policy-map SHAPE-TO-INTERNET
class VOIP_C
  bandwidth 1024
class class-default
  shape average 1024000
!
interface FastEthernet0/0
description WAN
bandwidth 2048
ip address 94.185.xxx.xxx 255.255.255.248
  ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map MAPNAME1
service-policy output SHAPE-TO-INTERNET
!
interface FastEthernet0/1
description LAN
bandwidth 2048
ip address 211.1.7.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
service-policy output SHAPE-TO-LAN

!

ip access-list extended RTP
remark ** voice payload **
permit udp any any range 16384 32768
!

ip access-list extended SIP
remark ** SIP Protocol **
permit tcp any any eq 5060
permit udp any any eq 5060
permit tcp any eq 5060 any
permit udp any eq 5060 any

1 Reply 1

Lei Tian
Cisco Employee
Cisco Employee

Hi,

The template you have probably will not work as you expect.

1, I see you have crypto-map configured under WAN interface, the traffic will be encrypted before enter the egress queue; which means the marking based on pre-encryption port number will not work, you need to classify on the LAN interface in ingress direction or use ipsec pre-classify feature.

2, You are using 100M interface on your side, and on SP side they will police down to 2M. So any traffic beyond 2M will be dropped by the provider side. You need to configure a HQOS with parent level shaping down to 2M to make sure your egress traffic rate wont exceed 2M.

3,voice traffic is delay sensitive traffic, it is better give them priority level rather than bandwidth guarantee, but you should not give priority queue more than 33% of the total available bandwidth, otherwise it can saturate other type traffic and lower down your overall performance.

4,You don’t need shape the traffic going out to your LAN interface; basically the traffic coming in from WAN interface will not exceed the 100M LAN bandwidth, the queue will never be used.

HTH,

Lei Tian

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card