LMS 3.2 RME 4.3.1 - Inventory goes into running status never completes.

Unanswered Question
Mar 9th, 2010
User Badges:

    I recently added 15 switches to my CiscoWorks install via the DCR.  I waited a bit and none of them were discovered. I tried to kick start a job in inventory in the RME but they wouldn't leave the running state. I poked around the theads here and checked for ../CSCOpx/conf/csdiscovery/DiscoveryStatusObj (it wasn't there) and then tried running "pdexec  CSDiscovery".  This didn't fix my problem.  I bounced all the CW services, problem is still there.  Anyone have any ideas?


chris

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 03/10/2010 - 10:02
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Your title and body do not agree.  Inventory collection has nothing to do with Discovery.  Exactly where are you experiencing a problem?

CJasztrabTMW Wed, 03/10/2010 - 10:13
User Badges:

Sorry for the confusion.  From what I understand  / have seen; Whenever I add a device into the DCR, RME automatically picks it up and goes and figure our what  kind of device it is, then i can see what it is, it's config etc.  What is happening now is that this isn't happening.  When i go to the device center and try to kick off this process manually it goes into a running state and never finishes.


chris

Joe Clarke Wed, 03/10/2010 - 11:31
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Is this on Windows or Solaris?

CJasztrabTMW Wed, 03/10/2010 - 12:20
User Badges:

Windows.


On a side note existing devices that were able to be seen by RME now are not.  I cannot do a sync archive for example on them.

Joe Clarke Wed, 03/10/2010 - 17:25
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You most likely have a thread or threads which have locked up in ICServer.  Since you are on Windows, you will need to contact TAC to get the procedure for producing a full thread dump from ICServer when the problem has occurred.  In the meantime, restarting ICServer may allow you to get those devices inventoried:


pdterm ICServer

pdexec ICServer

CJasztrabTMW Thu, 03/11/2010 - 10:13
User Badges:

Joe,


Thanks for the reply.  I've tried to do the pdterm and pdexec for the ICServer, but it's still not working.  I've opened a case with TAC now. So far he's reset the causer account.  We've tried to manually kick off an inventory job after we've put the device type in.  None of that worked so he had me send a few of the job folders as well all the ICServer logs and the logs that come from archive syncs.  I plan on calling in a few hours to check on the status.  Any ideas as to where we can go from here?

Joe Clarke Thu, 03/11/2010 - 10:33
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You need to get a full thread dump of the ICServer process when it has locked up.  The logs alone will probably not show why this problem is occurring.

Actions

This Discussion