Cisco 1841 IOS Code Upgrade

Unanswered Question
Mar 9th, 2010

I have a Cisco 1841 running IOS Image C1841-advsecurityk9-mz.124-3i and the following feature sets: IP, Firewall, VPN, IPS and NAC. I am having an issue viewing the Additional Task tab under the Configure menu in the GUI. Without doing much research i assumed this is an browser issue and new code would fix it. When i look on the download software there are many different codes availible and i am unsure which i need to get to update the software on my IOS. Any help would be greatly appreciated.

Here are the ones i am look at and not sure which one to choose from.

15.1.1-XB(ED)

Thanks,

Ryan Burney

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Paolo Bevilacqua Tue, 03/09/2010 - 11:35

The real problem is the GUI, it is too buggy and limited to allow you do things correctly.

Using CLI, chances are you can do what you need to do, without upgrading IOS.

Beside, what is thta you need to do ?

rburneyx10 Tue, 03/09/2010 - 13:50

I need to reserve an IP in DHCP. The 1841 is handleing DHCP. What is the CLI commands for that? Where can i find reference for these commands?

Neeraj Arora Tue, 03/09/2010 - 22:50

** sample config for manual binding of an ip address with a MAC, so that everytime this PC boots up, DHCP server will always allocate the same ip:

conf t
ip dhcp pool [new_pool]
host 10.12.1.99 255.255.255.0
client-identifier 0100054B970A7B
end

** If you simply want to exclude an ip address from the pool, so that the router does not allocate it dynamically to a user (you might want to assign this ip statically on a PC/server), then you need to use the command:
ip dhcp excluded-address x.x.x.x

More details about this command:
http://www.cisco.com/en/US/customer/docs/ios/ipaddr/command/reference/iad_dhc1.html#wp1042318


Note: In case you go for an IOS upgrade (which really is not required here), always check "sh ver" output to find out how much DRAM and FLash your router has. Accordingly look for an IOS  version whose requirement matches your router's memory specification.

Hope it helps.

Neeraj

gscholz_2 Tue, 04/12/2011 - 01:26

Adding a little extra to define choice aside from just selecting latest version, (taking into account cost of upgrade is also a consideration)

Cisco hardware frequently goes EOS and EOL therfore notices relating to your fleet need to be monitored.

Here is one which may be peculiar to you for ongoing software support

http://www.cisco.com/en/US/prod/collateral/routers/ps5853/qa_c67-631674_ps5855_Products_End-of-Life_Notice.html

Overall, the Cisco ISR G2 Series offers unparalleled operational savings and network agility through the continued intelligent integration of market leading security, unified communications, wireless, and application optimization services. The recommended product migration path for base chassis and bundles is captured in the 1841, 2800 and 3800 End-of-Life and End of Sale Notices located at:

1800 Series EOL7249: http://www.cisco.com/en/US/prod/collateral/routers/ps5853/eol_c51-625662.html

• 2800 Series EOL7237: http://www.cisco.com/en/US/prod/collateral/routers/ps5854/eol_c51-631228.html

• 3800 Series EOL7247: http://www.cisco.com/en/US/prod/collateral/routers/ps5855/eol_c51_624090.html

Q

A. IOS release 15.1(4)M will be the long term IOS release supported on the 1800, 2800, and 3800 Series through the end of software maintenance. Software maintenance on 15.1(4)M will be offered until Nov. 1, 2014.

Q What options do I have for software support if I cannot migrate to 15.1(4)M because of insufficient memory on my Cisco Integrated Services Router 1800, 2800 or 3800?

A. Software maintenance of IOS release 12.4(24)T will be extended through Oct 2012 for those customers who cannot migrate to 15.1(4)M. Customers desiring software support on 1800, 2800 or 3800 from Oct 2012 through the EoSM date (Oct 2014) must migrate to 15.1(4)M.

Note obviously it will depend if you wic cards are supported.  For example we have found that Generation 1 VWIC cards are only supported in 12.4 T train.  i doubt very much that Gen 1 cards will be supported in version 15

Look again the latest versions have moved for T Train to 12.4(24)T5

Actions

Login or Register to take actions

This Discussion

Posted March 9, 2010 at 10:55 AM
Stats:
Replies:5 Avg. Rating:
Views:7094 Votes:0
Shares:0
Tags: ios, 1841
+

Related Content

Discussions Leaderboard