device not discovered

Answered Question
Mar 9th, 2010

I have very important  Cisco 2801 (revision 7.0) router and never discover by CW. when I log to the devices I can see the neighbor and alos when i log to the neighbor device also I can see this device as neighbor. also all the switches attached to this router also discovered by CW. when I checked on device center to this device also did not seen as neighbor. simply there is no recored as device or as neighbor about this device. the device not filtered out on discovery either. any suggestion...? how I can troubleshooting. Thanks

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 6 years 9 months ago

You can do this using the SNMP Walk tool in Device Center.  Just specify "cdpCacheTable" as the starting OID.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Wed, 03/10/2010 - 10:15

You can walk the cdpCacheTable on the device (and its neighbors) to verify CDP is correct from an SNMP standpoint.  If it's Discovery that cannot find the device, make sure you have configured Discovery's hop counts to allow this device to be picked up.  You might try starting a sniffer trace filtering on SNMP traffic to the device and its neighbors, then run a Discovery to see what Discovery polls on these devices.

raindrop18 Wed, 03/10/2010 - 14:27

could you please tell me how I can do these things.

You can walk the cdpCacheTable on the device (and its neighbors) to verify CDP is correct from an SNMP standpoint. regarding hop counts, I am using all DCR devices as seed device so no hop limitation. Thanks again for your time

1st -

Correct Answer
Joe Clarke Wed, 03/10/2010 - 17:22

You can do this using the SNMP Walk tool in Device Center.  Just specify "cdpCacheTable" as the starting OID.

Actions

This Discussion