Nexus 1000v and LACP

Unanswered Question
Mar 9th, 2010

I'd like to know if anyone has successfully configured LACP on 1000V? I'm having problem with LACP where etherchannels are not establishing. If I don't use LACP, and turn on etherchannel unconditionally, then it works fine. My 1000v is connected to 3120 blade switch.

The port-profile where I use for uplinks to the 3120 is-

port-profile type ethernet system-uplink
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan 501-502,900
  channel-group auto mode active
  no shutdown
  system vlan 501-502,900
  state enabled

On my 3120-

interface GigabitEthernet1/0/x

switchport mode trunk

switchport trunk allowed vlan 501-502,900

channel-group 10 mode active

'show etherchannel summy' shows the ports are stand-alone ports (I). Again, if i don't use LACP and use 'channel-group mode on', then it works fine.


Any help is appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
gdetweiler Thu, 03/11/2010 - 06:32

I am having problems as well. However my issues are with multiple VEMs. The first VEM that comes on line, LACP works fine. The 2nd one, ports keep dropping out.

Anyway, for your issue, I would try allowing vlan 1 as part of the allowed vlans or set your native vlan to something that is an allowed vlan. However, there is a bug though where you can only have 1 LACP port-channel that is not native vlan 1. Bug-id CSCtd27624.

Greg

felixjai Thu, 03/11/2010 - 06:58

Thanks for BugID. It does seem that I'm hit with the bug. But also, I notice that I also need to add two more spanning-tree commands for my environment (with AIPC). Found this on 1000V document.

http://www.cisco.com/en/US/docs/switches/datacenter/nexus1000/sw/4_0_4_s_v_1_2/interface/configuration/guide/n1000v_if_5portchannel.html#wp1263480

In order to support LACP when inband/AIPC are also carried over the link, you must configure the following commands on the ports connected to the ESX host:

–spanning-tree portfast trunk

–spanning-tree bpdufilter enable

gdetweiler Thu, 03/11/2010 - 07:29

I already had the portfast edge trunk, but not the bpdufilter. I added it, didn't make a difference for my issue, but its better to have that in there. Thanks.

anoogupt Wed, 03/24/2010 - 05:15

try adding vlan 1 explicity as part of your port-profile on N1K and also on upstream switch.

gdetweiler Wed, 03/24/2010 - 05:28

I recommened that to felixjai in the 2nd post.

As for my issue, Vlan 1 was already added. I opened a TAC case to figure out why LACP would fail on the 2nd VEM that was added, they couldn't figure it out, saying that there were known LACP issues with the 1KV. They had me configure mac-pinning, which is stable. It is kind of funny that I have to configure mac-pinning (which is for uplink switches that don't support port-channels) in order for stability to connect to 6509 VSS switches, which feature multi-switch port-channels as one of their biggest features.

Rami Bakri Mon, 12/13/2010 - 16:08

Hello,

When configuring LACP (Active) on the NEXUS 1000v and the Upstream switch(s), you will need a minimum of 2 vmnics in the uplink port-profile if you have the management vlans allowed over it. Please take a look at the Guidelines and Limitations from the Cisco Nexus 1000V Interface Configuration Guide (see below).

If you have a single vmnic in the LACP port-channel it will into individual mode and re-initialize every 30 seconds. You can attempt the following:

1.) Add a second vmnic to the lacp port-channel.

2.) do not allow the management traffic over the port-channel; use a separate vmnic which is not in an lacp port-channel configuration. This would require another uplink port-profile.

Guidelines and Limitations

There should be at least two links connecting two switches when inband/aipc are also carried over the LACP channel.

Reference:
HTH,
rbx

Actions

This Discussion

Related Content