LAN QOS on 6509 switch

Unanswered Question

Hi,


I am trying to classify and mark traffic at the interface level with Weighted round robin queuing on a Cisco 6509 switch running in VSS mode to prioritize specific data traffic.


Here is a copy of the QOS configuration i've applied, currently only to one port. I want to know if this is going apply QOS at layer 2 because I am setting layer3 DSCP markings and queue traffic as per WRR configuration on the interface.



mls qos


mls qos map cos-dscp 0 11 21 31 32 40 48 56


policy-map Set-COS

  class Cos3

   set dscp af31

  class Cos2

   set dscp af21

  class Cos1

   set dscp af11



class-map match-all Cos3

  match access-group name Cos3

class-map match-all Cos2

  match access-group name Cos2

class-map match-all Cos1

  match access-group name Cos1


ip access-list extended Cos1

permit tcp any any eq 1352

permit tcp any eq 1352 any

ip access-list extended Cos2

permit tcp any any eq 22

permit tcp any any eq 443

permit tcp any any eq ftp-data

permit tcp any any eq ftp

permit tcp any any eq www

permit tcp any any eq domain

permit udp any any eq domain

permit tcp any any eq smtp

permit tcp any any eq 445

permit udp any any eq 445

permit tcp any any eq 118

permit tcp any any eq 156

permit tcp any any eq 1433

permit tcp any any eq 1434

permit udp any any eq 118

permit udp any any eq 156

permit udp any any eq 1433

permit udp any any eq 1434

permit tcp any any eq 389

permit udp any any eq 389

permit udp any any eq netbios-ns

permit udp any any eq netbios-dgm

permit udp any any eq netbios-ss

permit tcp any any eq 1512

permit tcp any eq 22 any

permit tcp any eq 443 any

permit tcp any eq ftp-data any

permit tcp any eq ftp any

permit tcp any eq www any

permit tcp any eq domain any

permit udp any eq domain any

permit tcp any eq smtp any

permit tcp any eq 445 any

permit udp any eq 445 any

permit tcp any eq 118 any

permit tcp any eq 156 any

permit tcp any eq 1433 any

permit tcp any eq 1434 any

permit udp any eq 118 any

permit udp any eq 156 any

permit udp any eq 1433 any

permit udp any eq 1434 any

permit tcp any eq 389 any

permit udp any eq 389 any

permit udp any eq netbios-ns any

permit udp any eq netbios-dgm any

permit udp any eq netbios-ss any

permit tcp any eq 1512 any

ip access-list extended Cos3

permit udp any any eq 1604

permit tcp any any eq 1494

permit tcp any eq 1494 any

permit udp any eq 1604 any



interface range GigabitEthernet1/6/17

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport nonegotiate

wrr-queue bandwidth 15 25 60

wrr-queue cos-map 2 1 1

wrr-queue cos-map 2 2 2

wrr-queue cos-map 3 1 3

storm-control broadcast level 1.00

spanning-tree portfast edge trunk

service-policy input Set-COS

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion