Fax to Email HELP

Unanswered Question
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Smith Wed, 03/10/2010 - 10:53
User Badges:
  • Gold, 750 points or more

I have done this configuration before and it does work, but I think the problem for you is actually quite simple.


The first thing I see is

service onramp flash:app_faxmail_onramp.2.0.1.3.tcl

might need to be...

service onramp flash:/app_faxmail_onramp.2.0.1.3.tcl


Making this change will require a reboot to test.  Also, where is the script located on flash?

Steven Smith Wed, 03/10/2010 - 10:59
User Badges:
  • Gold, 750 points or more

And, in the config, I also see...


ephone-dn  2

number 801

label Fax

description Fax

name Fax

hold-alert 30 originator




This is going to cause a problem.  ephone-dn 2 should not be 801.

Steven Smith Wed, 03/10/2010 - 13:52
User Badges:
  • Gold, 750 points or more

Yes, you should definitely remove ephone-dn 2, or change the number.

Steven Smith Wed, 03/10/2010 - 15:20
User Badges:
  • Gold, 750 points or more

If you change the location on flash, it will require a reload of the router for the script to load.  You must do that as well.


After that, if it is still not working, post another debug.

JOHN NIKOLATOS Wed, 03/10/2010 - 18:13
User Badges:
  • Bronze, 100 points or more

Here is an example for you that I have created.


Here is one suggestion, after you type fax interface-type fax-mail.. CME must be reloaded..  So restart as well... Also some inbound dial-peers in the configuration like to answer even though these commands below work... so you have to "debug voip ccapi inout" and watch to see what dial-peer is answering... then copy it from CLI and then delete it and then test...  Make sure to copy all the dial-peers so you can paste them back in..  the order of the dials-peers matter as well from top to bottom..  almost like an access-list..


FAX to EMAIL on UC500 using analog line - CONFIGURATION EXAMPLE


**Please note this is for Analog lines. PRI will work as well but you do not have to PLAR from the FXO ports. Also make your incomming called number and destination pattern matches the number exact;y from your ISP (i.e, some PRI's only send 3 or 4 digits not the whole 10 digit number)

1) You have to download and application from Cisco's website. It is under Voice Products.

app_faxmail_onramp.2.0.1.3.tcl
http://www.cisco.com/cgi-bin/tablebuild.pl/tclware

Load this file onto the FLASH of your UC500 using TFTP and "copy tftp flash" command.

** Load the application with the following commands.. **

application
service onramp flash:app_faxmail_onramp.2.0.1.3.tcl

In global configuration mode of UC500 type the following: (Not all are needed)
-------------------------------
fax interface-type fax-mail
mta send server 192.168.1.2 port 25 (***substitute your mail srvr IP)
mta send subject Fax from UC500
mta send with-subject both
mta send postmaster [email protected]
mta send mail-from hostname UC500.domain.com
mta send mail-from username $s$
mta send return-receipt-to hostname domain.com
mta send return-receipt-to username administrator
mta receive aliases domain.com
mta receive aliases wmc2k3-sbs.domain.com
mta receive aliases mail.domain.com
mta receive aliases mail.domain.com
mta receive aliases 192.168.1.2 (***substitute your mail server IP)
mta receive maximum-recipients 10
mta receive generate permanent-error
--------------------------------------------------

Find the FXO port you plugged your ANALOG phone line into - mine is 0/1/1
-----------------------------------------------
voice-port 0/1/1
connection plar opx 2031111111 (**THIS # can be anything unique)
caller-id enable
!
dial-peer voice 7 mmoip
description FAX to SERVICE Dept
service fax_on_vfc_onramp_app out-bound
destination-pattern 2031111111 (**Match PLAR command above)
information-type fax
session target mailto:[email protected] (**Any email address)
!
dial-peer voice 6 pots
description FAX to SERVICE
service onramp
incoming called-number 2031111111
direct-inward-dial
port 0/1/1

*** Make sure to enable mail relay on your mail server for your UC500 internal address.


John Nikolatos  www.niktek.com

I struggled with this for a week.  Every config I tried did not work.  It ended up adding one command made it start working.


tftp-server flash:app_faxmail_onramp.2.0.1.3.tcl

I will also attach a config example I got from TAC when I setup it up on another box awhile ago.  I think if you use a combination on those config lines along with the guide from Marcos for the CUE pieces, it should work easily.

Actions

This Discussion