CME-PBX Integration Problem

Unanswered Question
Mar 11th, 2010
User Badges:

Hello,


I have this strange problem I'm facing.

I have a single site on a Panasonic PBX and three remote site on Cisco CME.

I configured the remote sites with a voip dial-peer pointing to the PBX IP Address. I have a problem with a single site.


The problem can be broken down as follows:


IP Phone -> Analog = Ringing then the call disappears from the "voice call status" as the user picks up

Analog -> IP Phone = Ringing then as the IP Phone picks up, and I see "Connected" on my IP Phone but the "show voice call status" shows none in the codec column indicating that it's not picked up yet and all the while the the analog phone is hearing ringback and the IP Phone hears MOH tone !!!!!


I have changed the codecs repeatedly even from the PBX side but still no luck. I now have a voice class with all the codecs

There are firewalls at each site but I've set policies to allow H323 and RTP between them.

I'm sure I'm not hitting any bug or anything as one of the working remote sites have the exact IOS image and CME version.


In all cases I have hardware transcoders configured and they seem to be registered.


Router#sh sdspfarm units


mtp-1 Device:confdsp1 TCP socket:[-1]  UNREGISTERED

actual_stream:0 max_stream 0 IP:0.0.0.0  0  Unknown 0 keepalive 0 


mtp-2 Device: TCP socket:[-1]  UNREGISTERED

actual_stream:0 max_stream 0 IP:0.0.0.0  0  Unknown 0 keepalive 0 


mtp-3 Device:mtp001bd5ed6bf0 TCP socket:[1]  REGISTERED

actual_stream:8 max_stream 14 IP:10.10.21.102  44045  MTP Dixieland keepalive 22486 

Supported codec: G711Ulaw

                 G711Alaw

                 G729

                 G729a

                 G729b

                 G729ab

                 GSM FR


max-mtps:5, max-streams:8, alloc-streams:8, act-streams:0


Excerpts of the configuration:



!

voice class codec 20

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g711ulaw

codec preference 4 g711alaw

!

dial-peer voice 6660 voip

description <<INCOMING DIAL-PEER>>

  paramspace callsetup after-hours-exempt TRUE

session target ipv4:10.10.21.102

incoming called-number [789]..

!

dial-peer voice 6665 voip

description <<VOIP CONNECTION TO REMOTE SITE>>

destination-pattern 6[123]..

voice-class codec 20

session target ipv4:10.10.2.101

!



sccp local GigabitEthernet0/0

sccp ccm 10.10.21.102 identifier 1 version 4.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0

associate ccm 1 priority 1

associate profile 2 register mtp001bd5ed6bf0

associate profile 1 register confdsp1

switchback method graceful

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729br8

codec g729r8

maximum sessions 7

associate application SCCP

!


!

telephony-service

ip source-address 10.10.21.102 port 2000

sdspfarm units 5

sdspfarm transcode sessions 4

sdspfarm unregister force

sdspfarm tag 1 confdsp1

sdspfarm tag 2 mtp001bd5ed6bf0



Any ideas?


Thanks,

Ahmed

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
markbatts Tue, 03/16/2010 - 07:33
User Badges:
  • Bronze, 100 points or more

Hi,


It does sound like you are hitting a codec issue from what you describe , can you just confirm that it only fails on one of the sites and that the other two work.

If the others work can you tell me what codec gets negotiated.


Cheers

Mark

Actions

This Discussion