Cisco 4948 no ios

Unanswered Question

Hi all First time here


we were handed a cisco 4948 switch and after some advice to reset it to factory defaults i issued a clear all/non volatile command. this in turn wiped the IOS and it only boots to rommon


so i followed the recovery guide for a 4500 and now i am stuck i get to this bit



12.
Ping the TFTP server by issuing the ping <tftp_server_ip_address> command to make sure the T
server is reachable, as this example shows:
Switch#ping 172.18.125.3
Type escape sequence to abort.
Sending 5, 100−byte ICMP Echos to 172.18.125.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round−trip min/avg/max = 8/10/16 ms
13.
If the ping is successful, skip to Step 15. If not, make sure you have a connection to the TFTP serv
from the switch. Typically you have to connect one of the regular 10/100 ports or Gigabit ports to
another switch, or connect the TFTP server installed PC directly to one of the switch interfaces.
14.


in rommon i can ping the tftp server but after the image has booted i cant ping the tftp server so i cant copy the flash over

i am using the cat4500-entservices-mz.122-52.SG.bin file


is there something i am wrong ?


any help would be appreciated.


thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 03/11/2010 - 06:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,

after your switch has loaded an IOS via TFTP you need to configure a port on it it has probably an empty configuration

example: use the appropriate interface name

int g0/5

no switchport

ip address 172.18.125.254 255.255.255.0

no sh


connect this port the cable towards TFTP server


you should then be able to ping the TFTP server and to issue a copy tftp flash:


Hope to help

Giuseppe

Ganesh Hariharan Thu, 03/11/2010 - 09:49
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Member's Choice, February 2016

Hi all First time here


we were handed a cisco 4948 switch and after some advice to reset it to factory defaults i issued a clear all/non volatile command. this in turn wiped the IOS and it only boots to rommon


so i followed the recovery guide for a 4500 and now i am stuck i get to this bit



12.
Ping the TFTP server by issuing the ping command to make sure the T
server is reachable, as this example shows:
Switch#ping 172.18.125.3
Type escape sequence to abort.
Sending 5, 100−byte ICMP Echos to 172.18.125.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round−trip min/avg/max = 8/10/16 ms
13.
If the ping is successful, skip to Step 15. If not, make sure you have a connection to the TFTP serv
from the switch. Typically you have to connect one of the regular 10/100 ports or Gigabit ports to
another switch, or connect the TFTP server installed PC directly to one of the switch interfaces.
14.


in rommon i can ping the tftp server but after the image has booted i cant ping the tftp server so i cant copy the flash over

i am using the cat4500-entservices-mz.122-52.SG.bin file


is there something i am wrong ?


any help would be appreciated.


thanks

Hi,


If you have booted the ios and you are on switch prompt then as suggested Giuseppe configure a interface with ip address and  check the connectivity for tftp server.


Hope to help !!


Ganesh.H

Giuseppe Larosa Fri, 03/12/2010 - 05:32
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,


you may need:


conf t

ip routing


! use the default gateway

ip route 0.0.0.0 0.0.0.0   10.8.2.1


if TFTP server is in another subnet you need to provide a routing path to reach it


also check the state of the interface with


sh interface gi1/46


it should be up/up and ping 10.8.2.254 should be successful


Hope to help

Giuseppe

Hi Giuseppe


ok done all that and still no link


int gi 1/46 is showing status down no connect


i'll explain my setup


i have 1 laptop ip 10.8.2.2 connected via terminal cable into cosole port( where i am running commands)


the network connection from the laptop goes to a standard procurve switch


there is 1 connection from the 4948 mgmt port that goes to procurve


mgmt ip 10.8.2.3


in rommon i can ping 10.8.2.2 and boot ios


once booted the switch assigns int gi 1/1 as a fastethernet port int fa 1


it is at this point i configure int gi 1/46 with 10.8.2.254


when i attach a cable nothing lights up


Hope this helps

Giuseppe Larosa Fri, 03/12/2010 - 09:54
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,

sorry my mistake you need to issue also a no shut like in:


Switch1 (config)# ip routing

Switch1 (config)# interface gigabitethernet 24

Switch1 (config-if)# no switchport 

>>>> Switch1 (config-if)# no shutdown 

Switch1 (config-if)# ip address 10.4.120.106 255.0.0.0

Switch1 (config-if)# exit


see

http://www.cisco.com/en/US/docs/switches/lan/catalyst4900/installation/guide/0bQuick.html#wp1151164


Hope to help

Giuseppe

Giuseppe Larosa Sat, 03/13/2010 - 01:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,

it is good that you have been able to copy the IOS in the local flash.

it should be as simple as clear config given in privileged mode.


switch# erase nvram:


>> The erase nvram: command replaces the write erase command and the erase  startup-config command.



old command is write erase


Warning:


if you do erase flash: you will delete the IOS image


use dir /all to see all filesystems in your device


you should see nvram:, flash: and other


running-config is in system: that  is RAM memory.



it will ask you a confirmation


However, it is difficult you need to do this during lab tests

note: it is handy also the default  interface typex/y to reset to default settings a single interface.


you may find out easier to default some interfaces to start a new lab


Hope to help

Giuseppe

Actions

This Discussion