7970 dead..attempting firmware upload

Unanswered Question
Mar 11th, 2010

There are a few posts on this so far.  I am trying to load firmware on a 7970g that has a black sceen.  I have it connected to a dhcp/tftp server and it is loading the term70.default.loads file but returns an error from the console port.  Error is

VERIFY failed. Code 126 bad envelope format. TLV has tag 0x0d must be 0x01

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Adam Thompson Fri, 03/12/2010 - 07:39


I had a very similar issue with a 7970 that died during a firmware update. The only way I was able to recover the phone was to do a "super factory reset". I don't know exactly what makes it super, but it worked for me.

1) boot the phone and hold down the # key until the buttons cycle orange

2) press 3 4 6 1 6 7 2 8 5 0 * #

After this sequence is complete, hopefully your phone will be able to get its full firmware load and come back to life.

Hope this helps,


Please rate if helpful

tholemu84 Fri, 03/12/2010 - 09:36


  I have experienced TLV errors when the phone model I have setup on CallManager is mismatched from the phone that I am attempting to upgrade.  On a Global model I selected 7961G-GE instead of just the 7961 and it returned a TLV error.  When I switched the model from 7961G-GE to 7961, it seemed to work and update fine.

  Not sure if this is will be of help.  I was running CallManager server 4.2(3) and doing some testing while I experienced this problem.

-Matt Bowler

dhooser Fri, 03/12/2010 - 12:52

Thanks. What I found was this. I opened the .loads file with notpad++ and found unreadable text which led me to believe this file had some type of signature related to the model or??. The .loads file was one that my sysad provided me but it was not named "term70". I renamed it and tried it and that is where this error came from. I then requested the term70 file from the sysad which he sent. I expect he got it from the call manager. I used that file and the phones are now fully functional. Many thanks to everyone. This issue has killed at least 6 phones in the last year. Very cool that I can bring them back from the dead......Just in time for Easter too.

tholemu84 Fri, 03/12/2010 - 13:12

Glad to hear you got that resolved.  It is always a joyous event to resurrect a dead phone..


This Discussion