Creating WAN Link between two sites

Answered Question
Mar 12th, 2010

Hi

I need a bit of assistance setting up a WAN link between two sites.

Our ISP has provided us with a WAN Extension link between the two sites. On Site A's end we have their equipment installed with two VLANS. VLAN 183 is our new direct link to the internet and VLAN 173 is our WAN Extension to our remote site (SITE B).

VLAN 183 is currently up and running. I had to create VLAN 183 on a Cisco 2950 Switch which is then in turn connected to a Cisco ASA 5505.

I now need to configure the WAN Link so SITE B can access all resources on SITE A.

SITE B also has equipment on site provided by the ISP.

The ISP havent provided IP Addresses for this link just VLAN numbers.

They have advised the following but I'm still a bit lost.

1. Configure an access port in VLAN 173 on your cisco switch and that will give you layer two connectivity to Site B

2. Install a router at each end

So on Site A....am I connecting my router directly to a VLAN 173 on my switch. An if so what kind of routing config needs to go on my router??

Thank you in advance for your help, this is my first time doing this so apologies for all the questions

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 6 years 10 months ago

Hello Drikilbride,

I cannot say if you configuration is correct.

As I wrote you need to create the L2 objects vlans you don't need the following:

interface Vlan176
description WanLink
no ip address
no ip route-cache
shutdown
!
interface Vlan183
description IP Link
no ip address
no ip route-cache
!

You should provide

sh vtp status

sh vlan id 183

sh vlan id 176

note: I see you are using vlan 176 not 173, this is not a problem you need to use the vlan-id as per ISP instructions

if vlans 176 or 183 don't exist as L2 objects ports fas0/3 and port fs0/4 will be not operational with an orange LED

if L2 broadcast domains don't exist you need to use one of the methods I've described to create them.

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Fri, 03/12/2010 - 04:50

Hello Drikiilbride,

the provider is giving you a L2 trunk that can carry the two vlans.

you need to create the vlan 173 on your lan switch and then you need to associate an access port to vlan 173.

switch

one of two methods work if VTP mode is server or transparent (you can check with sh vtp status)

a) old mode

vlan database

vlan 173

name tositeB

apply

exit

b)

config t

vlan 173

name tositeB

being a C2950 I would expect mode A to be the only one supported.

The ISP hasn't given you an IP subnet because you are free to use whatever IP subnet you like.

for example you can use an RFC 1918 private ip address

RA

int f0/0

ip address 10.100.173.1 255.255.255.0

RB at site B

int f0/0

ip address 10.100.173.2 255.255.255.0

it is highly recommended to run a routing protocol over the link like EIGRP or OSPF

like

RA, RB

router eigrp 100

network 10.0.0.0

! additional network commands can be needed per your address plan

no auto-summary

Edit:

above config if routerA can use two different interface one in vlan 173 one in vlan 183

if you have only one interface on router you will need to use subinterfaces

on c2950 you need to configure  a L2 trunk

int f0/x

switchport

switchport trunk allowed vlan 173,183

switchport mode trunk

on RA:

int f0/0

no ip addresss

int f0/0.173

enc dot1q 173

ip address 10.100.173.1 255.255.255.0

int f0/0.183

enc dot1q 183

ip address x.x.x.x y.y.y.y

Hope to help

Giuseppe

drikilbride Fri, 03/12/2010 - 07:43

Hi Giuseppe

I am attaching my switch config from Site A.

Can you tell me if it looks okay and then I will move onto configuring the router.

Thanks again for all your help!!

Correct Answer
Giuseppe Larosa Fri, 03/12/2010 - 09:11

Hello Drikilbride,

I cannot say if you configuration is correct.

As I wrote you need to create the L2 objects vlans you don't need the following:

interface Vlan176
description WanLink
no ip address
no ip route-cache
shutdown
!
interface Vlan183
description IP Link
no ip address
no ip route-cache
!

You should provide

sh vtp status

sh vlan id 183

sh vlan id 176

note: I see you are using vlan 176 not 173, this is not a problem you need to use the vlan-id as per ISP instructions

if vlans 176 or 183 don't exist as L2 objects ports fas0/3 and port fs0/4 will be not operational with an orange LED

if L2 broadcast domains don't exist you need to use one of the methods I've described to create them.

Hope to help

Giuseppe

Actions

This Discussion

Related Content