Please help !!!! How do i force traffic to use the uplink port?

Unanswered Question
Mar 12th, 2010

Hello

I am a network newbie so be gentle - can somebody help me with what I think is a trivial problem.  I have 2 switches (Cisco 3020) linked together via an uplink port and a number of servers (blades in this case) attached.  On each server/blade Nic0 is physically attached to Switch0 and Nic1 is physically attached to Switch1.

Network communication between all servers is ok as long as i hit the correct network card via the correct switch.. Eg from 10.10.11.203 if i hit a nic that is physically attached, it all works fine.  It is when i want to send traffic across the switches i have issues.  For example if i send traffic from 10.10.11.203 to 10.10.11.16 the traffic does not traverse switches via gi0/24, instead it insists on using gi0/19 which is attached to a switch (not uplinked) on another network which fails.

I need to somehow configure the switch(es) so that Switch 0 always attempts to use Switch 1 via the uplink before finally the decision is made to send traffic upwards over gi0/19 and onwards to other switches on the network.

Any help whatsoever is very much appreciated.

network diag Cisco.png

(1) Traceroute from (SW0) with SW1-gi0/19 enabled running traceroute from 10.10.11.203 to 10.10.11.16

Translating IP to mac .....
10.10.11.203 => 0022.649e.3ec6
10.10.11.16 => 0022.649b.dce2

Source 0022.649e.3ec6 found on SW0
1 SW0 (10.10.11.30) : Gi0/17 => Gi0/19
Unable to send a l2trace request to 192.168.20.5. Timed out
Layer2 trace aborted.

(2) Traceroute from (SW0) with SW1-gi0/19 enabled running  traceroute from 10.10.11.203 to 10.10.11.116

Translating IP to mac .....
10.10.11.203 => 0022.649e.3ec6
10.10.11.116 => 0022.649b.dce4

Source 0022.649e.3ec6 found on SW0
1 SW0 (10.10.11.30) : Gi0/17 => Gi0/16
Destination 0022.649b.dce4 found on SW0

Layer2 trace completed.

(3) Traceroute from (SW1) with SW1-gi0/19 enabled running  traceroute from 10.10.11.203 to 10.10.11.16

Translating IP to mac .....
10.10.11.203 => 0022.649e.3ec6
10.10.11.16 => 0022.649b.dce2

Unable to send a l2trace request to 192.168.20.5. Timed out
Layer2 trace aborted.

(4) Traceroute from (SW1) with SW1-gi0/19 enabled running  traceroute from 10.10.11.203 to 10.10.11.116

Translating IP to mac .....
10.10.11.203 => 0022.649e.3ec6
10.10.11.116 => 0022.649b.dce4

Unable to send a l2trace request to 192.168.20.5. Timed out
Layer2 trace aborted.

(5) Traceroute from (SW0) with SW1-gi0/19 disabled running  traceroute from 10.10.11.203 to 10.10.11.16

Translating IP to mac .....
10.10.11.203 => 0022.649e.3ec6
10.10.11.16 => 0022.649b.dce2

Source 0022.649e.3ec6 found on SW0
1 SW0 (10.10.11.30) : Gi0/17 => Gi0/24
2 SW1 (10.10.11.31) : Gi0/24 => Gi0/16
Destination 0022.649b.dce2 found on SW1
Layer 2 trace completed

(6) Traceroute from (SW0) with SW1-gi0/19 disabled running  traceroute from 10.10.11.203 to 10.10.11.116

Translating IP to mac .....

10.10.11.203 => 0022.649e.3ec6

10.10.11.116 => 0022.649b.dce4

Source 0022.649e.3ec6 found on SW0

1 SW0 (10.10.11.30) : Gi0/17 => Gi0/16

Destination 0022.649b.dce4 found on SW0

Layer2 trace completed.

(7) Traceroute from (SW1) with SW1-gi0/19 disabled running  traceroute from 10.10.11.203 to 10.10.11.116

Translating IP to mac .....
10.10.11.203 => 0022.649e.3ec6
10.10.11.16 => 0022.649b.dce2

Source 0022.649e.3ec6 found on SW0
1 SW0 (10.10.11.30) : Gi0/17 => Gi0/24
2 SW1 (10.10.11.31) : Gi0/24 => Gi0/16
Destination 0022.649b.dce2 found on SW1
Layer 2 trace completed

(8) Traceroute from (SW1) with SW1-gi0/19 disabled running  traceroute from 10.10.11.203 to 10.10.11.116

Translating IP to mac .....
10.10.11.203 => 0022.649e.3ec6
10.10.11.116 => 0022.649b.dce4

Source 0022.649e.3ec6 found on SW0
1 SW0 (10.10.11.30) : Gi0/17 => Gi0/16
Destination 0022.649b.dce4 found on SW0
Layer 2 trace completed

Switch 0 Running Config

!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname SW0
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$kDjk$GQ9ITEuCUwhGVFptPE2t9/
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
spanning-tree uplinkfast
!
vlan internal allocation policy ascending
!
ip tftp source-interface FastEthernet0
!
!
interface FastEthernet0
ip address dhcp
!
interface GigabitEthernet0/1
spanning-tree portfast
!
interface GigabitEthernet0/2
spanning-tree portfast
!
interface GigabitEthernet0/3
spanning-tree portfast
!
interface GigabitEthernet0/4
spanning-tree portfast
!
interface GigabitEthernet0/5
spanning-tree portfast
!
interface GigabitEthernet0/6
spanning-tree portfast
!
interface GigabitEthernet0/7
spanning-tree portfast
!
interface GigabitEthernet0/8
spanning-tree portfast
!
interface GigabitEthernet0/9
spanning-tree portfast
!
interface GigabitEthernet0/10
spanning-tree portfast
!
interface GigabitEthernet0/11
spanning-tree portfast
!
interface GigabitEthernet0/12
spanning-tree portfast
!
interface GigabitEthernet0/13
spanning-tree portfast
!
interface GigabitEthernet0/14
spanning-tree portfast
!
interface GigabitEthernet0/15
spanning-tree portfast
!
interface GigabitEthernet0/16
spanning-tree portfast
!
interface GigabitEthernet0/17
description G5 Uplink
spanning-tree portfast trunk
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
description Dev Network Uplink
media-type rj45
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
description X-Uplink Port
media-type internal
!
interface Vlan1
ip address 10.10.11.30 255.255.255.0
!
ip classless
ip http server
!
ip sla enable reaction-alerts
!
line con 0
line vty 0 4
password Passw0rd123
login
line vty 5 15
password Passw0rd123
login
!
end

Switch 1 Running Config
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$XR9L$VATn0pC6x/SxtOrhv1frA0
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
ip address dhcp
!
interface GigabitEthernet0/1
spanning-tree portfast
!
interface GigabitEthernet0/2
spanning-tree portfast
!
interface GigabitEthernet0/3
spanning-tree portfast
!
interface GigabitEthernet0/4
spanning-tree portfast
!
interface GigabitEthernet0/5
spanning-tree portfast
!
interface GigabitEthernet0/6
spanning-tree portfast
!
interface GigabitEthernet0/7
spanning-tree portfast
!
interface GigabitEthernet0/8
spanning-tree portfast
!
interface GigabitEthernet0/9
spanning-tree portfast
!
interface GigabitEthernet0/10
spanning-tree portfast
!
interface GigabitEthernet0/11
spanning-tree portfast
!
interface GigabitEthernet0/12
spanning-tree portfast
!
interface GigabitEthernet0/13
spanning-tree portfast
!
interface GigabitEthernet0/14
spanning-tree portfast
!
interface GigabitEthernet0/15
spanning-tree portfast
!
interface GigabitEthernet0/16
spanning-tree portfast
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
description Dev Network Uplink
shutdown
media-type rj45
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
description X-Uplink Port
media-type internal
!
interface Vlan1
ip address 10.10.11.31 255.255.255.0
!
ip classless
ip http server
!
ip sla enable reaction-alerts
!
line con 0
line vty 0 4
password Passw0rd123
login
line vty 5 15
password Passw0rd123
login
!
end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
AxiomConsulting Fri, 03/12/2010 - 07:35

Steve,

I havent had a chance to fully read the configs and traces you posted, so apologies if my answer is incorrect, however it sounds to me asthough there are 3 switches in the network, the 2 x 3020 and the upstream switch (attached to gig0/19).

Spanning tree may have put the link between the 2 x 3020 in to block to avoid any switching loops, therefore traffic will go via gig0/19.

Please run show 'spanning tree blockedports' on the 2 x 3020 to see if this is the case, if so you can adjust the STP config according.

Kind regards

Steve

pingcrosby Fri, 03/12/2010 - 08:21

Many many thanks for this heads up..

Running ... the following commands - i got this information...

I have no idea if its relevant, however i see that gi0/19 has a cost of 23 for SW1 and 3023 for SW0

Does this shed any light -- sorry for my total lack of knowledge on this ....

SW0#show spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority    32768

             Address     0007.85e7.2f00

             Cost        3023

             Port        19 (GigabitEthernet0/19)

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49153  (priority 49152 sys-id-ext 1)

             Address     0023.05dd.5d00

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  300 sec

  Uplinkfast enabled

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi0/1               Desg FWD 3004      128.1    P2p Edge

Gi0/2               Desg FWD 3004      128.2    P2p Edge

Gi0/3               Desg FWD 3004      128.3    P2p Edge

Gi0/4               Desg FWD 3004      128.4    P2p Edge

Gi0/5               Desg FWD 3004      128.5    P2p Edge

Gi0/6               Desg FWD 3004      128.6    P2p Edge

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi0/7               Desg FWD 3004      128.7    P2p Edge

Gi0/8               Desg FWD 3004      128.8    P2p Edge

Gi0/9               Desg FWD 3004      128.9    P2p Edge

Gi0/10              Desg FWD 3004      128.10   P2p Edge

Gi0/11              Desg FWD 3004      128.11   P2p Edge

Gi0/12              Desg FWD 3004      128.12   P2p Edge

Gi0/13              Desg FWD 3004      128.13   P2p Edge

Gi0/14              Desg FWD 3004      128.14   P2p Edge

Gi0/15              Desg FWD 3004      128.15   P2p Edge

Gi0/16              Desg FWD 3004      128.16   P2p Edge

Gi0/17              Desg FWD 3004      128.17   P2p Edge

Gi0/19              Root FWD 3019      128.19   Shr

Gi0/24              Desg FWD 3004      128.24   P2p


SW0#show spanning-tree blockedports

Name                 Blocked Interfaces List

-------------------- ------------------------------------

Number of blocked ports (segments) in the system : 0


SW0#sh span root

                                        Root    Hello Max Fwd
Vlan                   Root ID          Cost    Time  Age Dly  Root Port
---------------- -------------------- --------- ----- --- ---  ------------
VLAN0001         32768 0007.85e7.2f00      3023    2   20  15  Gi0/19

And on Switch 1

SW1#show spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     0007.85e7.2f00
             Cost        23
             Port        19 (GigabitEthernet0/19)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0023.05dd.3880
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1               Desg FWD 4         128.1    P2p Edge
Gi0/2               Desg FWD 4         128.2    P2p Edge
Gi0/3               Desg FWD 4         128.3    P2p Edge
Gi0/4               Desg FWD 4         128.4    P2p Edge
Gi0/5               Desg FWD 4         128.5    P2p Edge
Gi0/6               Desg FWD 4         128.6    P2p Edge
Gi0/7               Desg FWD 4         128.7    P2p Edge

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Gi0/8               Desg FWD 4         128.8    P2p Edge
Gi0/9               Desg FWD 4         128.9    P2p Edge
Gi0/10              Desg FWD 4         128.10   P2p Edge
Gi0/11              Desg FWD 4         128.11   P2p Edge
Gi0/12              Desg FWD 4         128.12   P2p Edge
Gi0/13              Desg FWD 4         128.13   P2p Edge
Gi0/14              Desg FWD 4         128.14   P2p Edge
Gi0/15              Desg FWD 4         128.15   P2p Edge
Gi0/16              Desg FWD 4         128.16   P2p Edge
Gi0/19              Root FWD 19        128.19   Shr
Gi0/24              Desg FWD 4         128.24   P2p


SW1#show spanning-tree blockedports

Name                 Blocked Interfaces List
-------------------- ------------------------------------

Number of blocked ports (segments) in the system : 0

SW1#sh span root

                                        Root    Hello Max Fwd
Vlan                   Root ID          Cost    Time  Age Dly  Root Port
---------------- -------------------- --------- ----- --- ---  ------------
VLAN0001         32768 0007.85e7.2f00        23    2   20  15  Gi0/19



jason.henderson Fri, 03/12/2010 - 15:50

Hi Steve,

I haven't read through the config, but whenever i see a port cost above 3000 i think uplinkfast.  Have you got uplinkfast enabled on one of the switches?

Thanks,

Jason.

pingcrosby Mon, 03/15/2010 - 04:36

Yes portfast is enabled on the switch

Should it be??


I thought portfast just allowed the switch to fail over via the uplink quickly.

Also i notice that on SW0 gi0/24 has the "orange" disabled light on ...is this relevant...i assume it should be "enabled" I have not disabled it, it seems to "disable" itself automatically.

Actions

This Discussion

Related Content