ASA 5505 Interfaces/VLANS/Switchports

Answered Question
Mar 12th, 2010
User Badges:

Hi All,


I have a question or 2 about 5505 Interfaces and how they work with VLANs.

I set IPs to Interf VLAN1 and 2 as inside and outside, respectively.

Figured out that VLAN2 should be set via switchport access command.

Ran a No Shut on all interfaces, inlcuded VLANs.

Checked to see if the Eth0/0 and 0/1 were in the correct VLANs thru the show vlan switch command.


When connecting eth0/0 to a PC, the PC is able to get an IP from the ASAs DHCP server.

Is this suppose to happen?  I'm guessing not.  NAT is setup, so how is this happening?



Thanks,


Vince


ASA Version 8.0(2)
!
hostname site
domain-name xxxx.net
enable password xxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.9.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.x 255.255.255.x

!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd xxxxxx encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name xxxx.net
pager lines 24
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.9.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
no crypto isakmp nat-traversal
telnet 192.168.9.0 255.255.255.0 inside
telnet timeout 7
ssh XXXXXX outside
ssh timeout 5
ssh version 2
console timeout 0
dhcpd address 192.168.9.5-192.168.9.20 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:xxxxxxxxxx: end
site(config)#

Correct Answer by Herbert Baerten about 7 years 3 months ago

Hi Vince,


this sounds strange indeed. Could it be that the PC was already connected (and received it's ip address) before you changed f0/0 to be in vlan 2?

In other words if you do an 'ipconfig /release' followed by 'ipconfig /renew' on the PC, does it still get a dhcp address?


Herbert

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
joyride_us2 Fri, 03/12/2010 - 13:27
User Badges:

Hi!

I guess you must be confused : your PC has to be connected to a Vlan1 port to get a DHCP addresse.

vdinenna71 Fri, 03/12/2010 - 13:33
User Badges:

Thanks for the reply.


I can get an IP from DHCP from all active ports- 0/0, 0/1, 0/2, etc.

Correct Answer
Herbert Baerten Fri, 03/12/2010 - 13:40
User Badges:
  • Cisco Employee,

Hi Vince,


this sounds strange indeed. Could it be that the PC was already connected (and received it's ip address) before you changed f0/0 to be in vlan 2?

In other words if you do an 'ipconfig /release' followed by 'ipconfig /renew' on the PC, does it still get a dhcp address?


Herbert

vdinenna71 Fri, 03/12/2010 - 14:25
User Badges:

Thanks for the reply.


I cleared out the config with a wr erase...status went red...and hung.  Reset with pin on back of unit.

Re-entered everything and now I get a 169.x.x.x on port 0/0, which is good in this case.

The rest pull an IP.


Probably should have done a release/renew like you said.


Thanks,


Vince

Actions

This Discussion