Point-to-Point Links and ISDN Dialer interfaces.

Unanswered Question
Mar 13th, 2010

Dear Friends,

I have four 7206 Routers as my core devices. These routers have HSRP configured in them. We have divided the routers in groups of 2 - 2. Every group's routers are reduntant for each other. The division is done to segregate the branches connected to my core through different service providers.

All of these four routers have point-to-point links which are terminating on the serial ports of my core routers. I have ISDN as my back up connection for every branch connecting through point-to-point links. Rest all branches connects through GRE Tunnels.

Now, whenever any of my point-to-point branch goes down. I do 'no shut' to my dialer interface for that particular site to start the ISDN connectivity.

But I have to manually shut the serial interface of this branch else the other users who have point-to-point connectivity experience extremely high latency. Similarly, I have to shut the dialer interface if the point-to-point link start working.

I had a major outage this week where my backhaul link went down and I had to manually transfer the tunnels to my DR Router.

The point-to-point links were up on ISDN at this time. When the bachaul link issue was resolved. The GRE Tunnels came up and started performing normally but my point-to-point branches started facing same extremely high latency issue. It didn't stop until I shut all the dialer interfaces for these point-to-point links.

Can anyone please explain me the concept behind this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sat, 03/13/2010 - 11:10

Hello Fisi1232000,

for starting a meaningful discussion  we should see the configuration of:

one remote site router

HQ primary router

HQ router terminating ISDN DDR calls.

remove username/pwds and change public ip addresses in something else for safety

A correctly configured DDR should work automatically without any manual change

Hope to help

Giuseppe

Faizan Shaikh Sat, 03/13/2010 - 11:23

Hi Giuslar,

With HQ you mean the router at my end , right?

I have my PRI configured on all four core routers, I try to fire my ISDN calls from any of the 4 core routers.

I will try my best to get the configuartion. It doesn't have any public IP addresses as I have just connected my core routers with remote branches via ISP.

You can make it simple by considering my core router connecting with 2 branches at remote site, these branches are terminating on serial ports on both ends. One site goes down, I shut the serial interface and fire the ISDN call. When my point to point link is up and I do not shut the dialer interface, the other branch which was working smooth start facing high latency issue. It continues till I shut the dialer interface.

Regards,

Faizan

Faizan Shaikh Tue, 03/16/2010 - 04:05

Serial Interface Config

DCRouter2#sh run int Se1/6
Building configuration...

Current configuration : 326 bytes
!
interface Serial1/6
bandwidth 2048
ip address 10.110.110.193 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1396
encapsulation ppp
ip tcp adjust-mss 1356
ntp disable
no peer neighbor-route
serial restart-delay 0
no cdp enable
end

Dialer Interface Config

DCRouter2#sh run int Di116
Building configuration...

Current configuration : 457 bytes
!
interface Dialer116
bandwidth 128
ip address 10.220.224.197 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1396
encapsulation ppp
ip tcp adjust-mss 1356
dialer pool 10
dialer string 27540120
dialer string 27540110
dialer caller 2227540120
dialer caller 2227540110
dialer load-threshold 1 either
dialer-group 1
no peer neighbor-route
no cdp enable
ppp multilink
end

Regards,

Faizan

Giuseppe Larosa Tue, 03/16/2010 - 07:53

Hello Faizan,

>> I have my PRI configured on all four core routers, I try to fire my ISDN  calls from any of the 4 core routers.

most of DDR designs I have seen give to the branch the role to call central site when primary link is down

Also it should be seen how the dialer list is configured and if there are any static routes using dialer interface as outgoing interface.

Central site would require multiple floating static routes using an IP next-hop and then dialer map commands to map each IP next-hop to the correct remote router ISDN number

The configuration you have provided is that of a remote site I suppose

Do you have a floating static route using dialer 116 on the remote?

if the router is the same you could declare the dialer as the backup interface of ser1/6

int ser1/6

backup interface dialer 116

this should give you the correct behaviuor see

http://www.cisco.com/en/US/docs/ios/dial/configuration/guide/dia_backup_serial_ps6441_TSD_Products_Configuration_Guide_Chapter.html

Hope to help

Giuseppe

Faizan Shaikh Wed, 03/17/2010 - 06:42

Giuseppe,

Central end:

DCRouter2#sh run | i XXXXXXX

ip route 10.10.190.0 255.255.254.0 Dialer116 150 name XXXXXXX

Remote End:

!

router ospf 10
router-id 10.10.190.1
log-adjacency-changes
network 10.10.190.0 0.0.1.255 area 1
network 10.110.110.192 0.0.0.3 area 1
network 10.220.224.196 0.0.0.3 area 1

!

Regards,

Faizan

Giuseppe Larosa Wed, 03/17/2010 - 07:12

Hello Faizan,

if you want to run OSPF over the ISDN backup link you should use OSPF on demand circuit

area 1 should be a stub area or totally stub area

see

http://www.cisco.com/en/US/partner/tech/tk365/technologies_tech_note09186a0080094a8f.shtml

it would wise to deny OSPF in the ACL used by dialer-group list

you should also assign an high OSPF cost to dialer interface so that it will no be used when primary link is restored

Hope to help

Giuseppe

Faizan Shaikh Mon, 03/22/2010 - 10:03

Hello Giuseppe,

I'm going to configure all the serial interfaces with their respective dialer interfaces as 'back up'.

I have studied the information from the links provided by you. It seems that implementing this can rectify the problem.

I still have a confusion about the effects on my other point to point links.

Why do they face issues when one of the point to point link interface has both dialer and serial interfaces working?

Regards,

Faizan

Giuseppe Larosa Mon, 03/22/2010 - 12:48

Hello Faizan,

>> Why do they face issues when one of the point to point link interface  has both dialer and serial interfaces working?

It is very difficult to answer to a question like this without access to your devices, but you can improve your backup solution for sure.

I can only guess that backup link is probably terminated in another core router.

Hope to help

Giuseppe

Faizan Shaikh Thu, 04/15/2010 - 11:25

Giuseppe,

I am extremely sorry for late reply.

The backup link is on all the four core routers. I mean I have dialer interfaces on all the four core routers. All of them are down, at the time of need I try to fire ISDN from all the four routers whichever is successful. However, there is no need of this as the first router itself allows me to connect through dialer interfaces. I kept it for the time of major outages where I have limited numbers of allowed dialers to fire from a single router.

I am now going to configure 'backup interface' commany on every serial interface which has pointopoint links. Also, I will have the routes for ISDN as static.

I will let you know if it helps.

Regards,

Faizan

Actions

This Discussion