Message Button question - forward to external VM via PSTN

Unanswered Question
Mar 14th, 2010
User Badges:

Ok, have a question surrounding a config and wanted to ping it off some great minds here.


Problem - when pressing the VM button - Voicemail system does not /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} recognize caller. VM - Acision uOne


Config Example CUCM Phone


Line 1 DN - 0000123456 (fake internal number - non DID)

VM profile - 000012XXXX

CFNA destination field = 200555 (VM Pilot)

E164 Line Mask - 5127771212  (DID number of Main location)


VOICEMAIL - Config

VM BOX = 0000123456 (matches Line 1 DN in CUCM)


VM Pilot to route pattern config:


VM pilot of 2005555 matches a route pattern that sends the call out a PSTN gateway - called party transformation changes the dialed number to the correct VM PSTN access number.



Call Flow:

When internal Phone A calls this phone and transfers to voicemail - user hears correct VM box greeting - works as it should

When PSTN A calls this phone and transfers to voicemail - user hears correct VM box greeting - works  as it should


Problem:

When user presses the Message button to retrieve messages the VM system does not recognize the caller.

If I change the line mask to equal - 0000123456 instead of the valid pstn DID - the message button works and all transfers work. Of course this then breaks the CLID for PSTN calls


Any suggestions on how to fix this problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vikramabrol Sun, 03/14/2010 - 18:00
User Badges:

You can take External CLID Mask off from DN and put the CLID Mask under the Route Pattern..

jslagle77 Sun, 03/14/2010 - 18:34
User Badges:

Thanks for the reply - unfortunately since these RP's are being used globally for other customers I cannot mask at the RP level. This would cause a lot of rework - but may be the only way to handle it.


Thanks!

vikramabrol Sun, 03/14/2010 - 18:43
User Badges:

Under your VM profile used for this particular phone, what configuration you have for the VM Profile in question....

What is the Mask set to is it blank or does it have x number of "X" based on your Extension length....


If its blank change it XXXX again equal to your internal extension length..

jslagle77 Sun, 03/14/2010 - 19:18
User Badges:

I have the VMP mask set to - 000012XXXX


Thanks!

vikramabrol Sun, 03/14/2010 - 19:40
User Badges:

use port status monitor on Unity and see what information is coming in when you hit "Msgs" key on phone

jslagle77 Mon, 03/15/2010 - 12:55
User Badges:

Updated - corrected config-- on Line 1 DN being used


Ok, have a question surrounding a  config and wanted to ping it off some great minds here.


Problem -  when pressing the VM button - Voicemail system does not recognize caller. VM - Acision uOne


Config  Example CUCM Phone


Line 1 DN - 123456 (fake internal number - non DID)

VM  profile - 000012XXXX

CFNA destination field = 200555 (VM Pilot)

E164  Line Mask - 5127771212  (DID number of Main location)


VOICEMAIL -  Config

VM BOX = 0000123456 (matches Line 1 DN in CUCM) (VM system requries full 10 digit number)


VM Pilot to  route pattern config:


VM pilot of 2005555 matches a route pattern that  sends the call out a PSTN gateway - called party transformation changes  the dialed number to the correct VM PSTN access number.



Call Flow:

When  internal Phone A calls this phone and transfers to voicemail - user  hears correct VM box greeting - works as it should

When PSTN A  calls this phone and transfers to voicemail - user hears correct VM box  greeting - works  as it should


Problem:

When user presses the Message  button to retrieve messages the VM system does not recognize the  caller.

If I change the line mask to equal - 0000123456 instead of  the valid pstn DID - the message button works and all transfers work.  Of course this then breaks the CLID for PSTN calls


Any  suggestions on how to fix this problem?

Actions

This Discussion

Related Content