WVC210 "FTP: Unknown FTP server"

Unanswered Question
Mar 14th, 2010

Hi,

I'm very satisfied with this product except for one very annoying issue:

When trying to send an FTP alert (with motion detection) if I put the ftp address (in the primary ftp server field), it gives me an error when motion is detected when it tries to connect with the ftp server (which I can see in the syslog): "FTP: Unknown FTP server"

If I do exactly the same thing inserting the ftp server IP address instead of its name, it works fine, and it uploads the corresponding avi file.

It doesn't seem to be a DNS issue to me as the server name is correctly resolved by ftp clients and browsers.

This is very annoying, as I'm using a dynamic IP address for my external ftp server (I get the name from DynDNS), and cannot insert the IP address as I would have to change it manually in the camera configuration every time it changes.

Anyone was able to succesfully connect to an external ftp server using its name and not its IP address?

I have firmware 1.1.0, and also tried to reinstall the firmware, but issue remains.

Any idea how to solve this would be very appreciated

Thank you!

Regards

Steven

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
asarutan Mon, 03/15/2010 - 09:24

Are you going through a router? If yes are you using the router's LAN IP as the camera's DNS server? If that's the case you'll need to use a real DNS IP address for your camera's DNS server IP such as 67.109.2.14 and not 192.168.1.1 (these are example DNS IP Addresses).

Alan.

stevenlugano Mon, 03/15/2010 - 12:38

Thx a lot Alan, this was exactly the problem. I put both primary and secondary real DNS server address in the camera settings and now it works fine. Thanks again! I just didn't think about that, and didn't even look at the camera DNS as I assumed it was correct, but it was not...

Here is how it is configured, so that those running into the same issue can understand how to fix it:

- The camera is behind a router, but I am trying to access an external ftp server (not on the local network)

- That ftp server is itself behind a router and is accessible by port forwarding. This router has a real IP address, let's say 67.109.2.14 to take your example

- If I put 67.109.2.14 in the "ftp server" field within the camera configuration menu, everything works fine.

- But if I put the name corresponding to the 67.109.2.14 IP address, then the camera doesn't find it. hence the error.

- I get a name for 67.109.2.14 through DynDNS and have no problem accessing the ftp server by its name with either a browser or an ftp client, which is why I was surprised.

- BUT: both the browsers and ftp clients were running from a PC that could correctly resolve the server name through the DNS, whereas the camera had no external DNS server specified and so could not resolve the name. Simple, but I'm pretty sure if Alan hadn't shown me the way, it would have taken me a long time to solve the issue.

Steven

Actions

This Discussion